diff mbox series

u-boot: add missing dependency on pyelftools-native

Message ID 20240124-u-boot-elftools-native-v1-1-63b133397a70@theobroma-systems.com
State Accepted, archived
Commit 70eca6a5ccf451572421f51eef9cc82ba120c7cb
Headers show
Series u-boot: add missing dependency on pyelftools-native | expand

Commit Message

Quentin Schulz Jan. 24, 2024, 1:34 p.m. UTC
From: Quentin Schulz <quentin.schulz@theobroma-systems.com>

When TF-A is necessary in U-Boot binary, binman requires elftools to be
installed to be able to generate that U-boot ITB image.

TF-A is necessary for at least all Aarch64 machines, so that is a
non-negligible amount of boards that have this requirement.

As a side note, Rockchip-based machines didn't need this until commit
12c3e948eeab ("rockchip: Drop the FIT generator script") (v2023.04-rc1).

This is already in meta-rockchip, c.f.
https://git.yoctoproject.org/meta-rockchip/commit/recipes-bsp/u-boot?id=6127d169acf239a53df989f34a6b825fa182cc0c
but I feel like this makes more sense to be present in OE-Core.

Cc: Quentin Schulz <foss+yocto@0leil.net>
Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>
---

I'm also wondering what are the criteria for having the DEPENDS in
u-boot_<vers>.bb instead of u-boot.inc?

 meta/recipes-bsp/u-boot/u-boot_2024.01.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


---
base-commit: 999bcf990b1b1357dda0636090561659336cc0bf
change-id: 20240124-u-boot-elftools-native-baa0d2cabff8

Best regards,
-- 
Quentin Schulz <quentin.schulz@theobroma-systems.com>
diff mbox series

Patch

diff --git a/meta/recipes-bsp/u-boot/u-boot_2024.01.bb b/meta/recipes-bsp/u-boot/u-boot_2024.01.bb
index 4f5b3e5dfd..b15bcaa818 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2024.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2024.01.bb
@@ -1,5 +1,5 @@ 
 require u-boot-common.inc
 require u-boot.inc
 
-DEPENDS += "bc-native dtc-native"
+DEPENDS += "bc-native dtc-native python3-pyelftools-native"