diff mbox series

coreutils: Ignore line-bytes.sh and no-allocate tests on musl

Message ID 20240110044941.3134791-1-raj.khem@gmail.com
State Accepted, archived
Commit cd31bb507bfb794379950dd0aa38b810ba194d2f
Headers show
Series coreutils: Ignore line-bytes.sh and no-allocate tests on musl | expand

Commit Message

Khem Raj Jan. 10, 2024, 4:49 a.m. UTC
bash fails in xmalloc when running these tests. More thorough
investigation may reveal real cause, however, it seems to fail on
other musl distros as well.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/coreutils/coreutils_9.4.bb | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-core/coreutils/coreutils_9.4.bb b/meta/recipes-core/coreutils/coreutils_9.4.bb
index e3e27e099d0..c0ca150253b 100644
--- a/meta/recipes-core/coreutils/coreutils_9.4.bb
+++ b/meta/recipes-core/coreutils/coreutils_9.4.bb
@@ -210,4 +210,10 @@  do_install_ptest () {
     sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
 }
 
+do_install_ptest:append:libc-musl () {
+    # these tests fail due to bash on musl systems
+    # xmalloc: cannot allocate 16146 bytes
+    sed -i -e '/tests\/dd\/no-allocate.sh/d' ${D}${PTEST_PATH}/Makefile
+    sed -i -e '/tests\/split\/line-bytes.sh/d' ${D}${PTEST_PATH}/Makefile
+}
 FILES:${PN}-ptest += "${bindir}/getlimits"