diff mbox series

abseil-cpp: readd use of -std=c++14

Message ID 20240109121208.170594-1-throos@amazon.de
State New
Headers show
Series abseil-cpp: readd use of -std=c++14 | expand

Commit Message

Roos, Thomas Jan. 9, 2024, 12:12 p.m. UTC
From: Thomas Roos <throos@amazon.de>

Protobuf is compiled with -std=c++14, so abseil-cpp must be as well.
Details can be found here: protocolbuffers/protobuf#10768

Signed-off-by: Thomas Roos <throos@amazon.de>
---
 meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index ee62d4b59..1a713e1c5 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -26,6 +26,7 @@  ASNEEDED:class-nativesdk = ""
 inherit cmake
 
 EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
+                 -DCMAKE_CXX_STANDARD=14 \
                  -DBUILD_TESTING=OFF    \
                  -DABSL_ENABLE_INSTALL=ON \
                 "