diff mbox series

[3/3] python3-cython: update 0.29.36 -> 3.0.7

Message ID 20240105133543.3017997-3-alex@linutronix.de
State Accepted, archived
Commit 21507a3be23a604259a6a903a7083db54d29487f
Headers show
Series [1/3] devtool/standard: correctly escape \ | expand

Commit Message

Alexander Kanavin Jan. 5, 2024, 1:35 p.m. UTC
pep517 build backends require cython 3.x when
python is at 3.12, so we can't hold this update any
longer. There are only a few things in meta-oe
and meta that break anymore, and fixes for them
are provided at the same time as this patch.

License-update: http -> https

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
 .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
 2 files changed, 5 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)

Comments

Alexandre Belloni Jan. 7, 2024, 7:54 p.m. UTC | #1
Hello,

I believe this causes those failures on fedora, oe-selftest passed on
the other hosts:

https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6287/steps/14/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6288/steps/14/logs/stdio

Or maybe fedora38-ty-4 is the issue, I've started a build without the
patch on this worker now.


On 05/01/2024 14:35:43+0100, Alexander Kanavin wrote:
> pep517 build backends require cython 3.x when
> python is at 3.12, so we can't hold this update any
> longer. There are only a few things in meta-oe
> and meta that break anymore, and fixes for them
> are provided at the same time as this patch.
> 
> License-update: http -> https
> 
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
>  .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
>  2 files changed, 5 insertions(+), 2 deletions(-)
>  rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)
> 
> diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
> index 6aec6b012f1..bc1953c5045 100644
> --- a/meta/recipes-devtools/python/python-cython.inc
> +++ b/meta/recipes-devtools/python/python-cython.inc
> @@ -5,11 +5,11 @@ It's designed to bridge the gap between the nice, high-level, easy-to-use world
>  and the messy, low-level world of C."
>  SECTION = "devel/python"
>  LICENSE = "Apache-2.0"
> -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
>  PYPI_PACKAGE = "Cython"
>  BBCLASSEXTEND = "native nativesdk"
>  
> -SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
> +SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
>  UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
>  
>  inherit pypi
> @@ -39,4 +39,7 @@ do_install:append() {
>  	for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
>  		sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
>  	done
> +
> +        # remove build paths from generated sources
> +        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
>  }
> diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
> similarity index 100%
> rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
> rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb
> -- 
> 2.39.2
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193357): https://lists.openembedded.org/g/openembedded-core/message/193357
> Mute This Topic: https://lists.openembedded.org/mt/103542146/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Jan. 7, 2024, 8:05 p.m. UTC | #2
2024-01-07 15:06:26,597 - oe-selftest - INFO - FAIL:
devtool.DevtoolAddTests.test_devtool_add_fetch_simple
(subunit.RemotedTestCase)
ERROR: Nothing PROVIDES 'pv'

2024-01-07 06:40:56,859 - oe-selftest - INFO - FAIL:
devtool.DevtoolAddTests.test_devtool_add_git_style1
(subunit.RemotedTestCase)
ERROR: Nothing PROVIDES 'mbedtls'

I'm totally puzzled. Why do you suspect cython?

Alex

On Sun, 7 Jan 2024 at 20:54, Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> Hello,
>
> I believe this causes those failures on fedora, oe-selftest passed on
> the other hosts:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6287/steps/14/logs/stdio
> https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6288/steps/14/logs/stdio
>
> Or maybe fedora38-ty-4 is the issue, I've started a build without the
> patch on this worker now.
>
>
> On 05/01/2024 14:35:43+0100, Alexander Kanavin wrote:
> > pep517 build backends require cython 3.x when
> > python is at 3.12, so we can't hold this update any
> > longer. There are only a few things in meta-oe
> > and meta that break anymore, and fixes for them
> > are provided at the same time as this patch.
> >
> > License-update: http -> https
> >
> > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > ---
> >  meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
> >  .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
> >  2 files changed, 5 insertions(+), 2 deletions(-)
> >  rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)
> >
> > diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
> > index 6aec6b012f1..bc1953c5045 100644
> > --- a/meta/recipes-devtools/python/python-cython.inc
> > +++ b/meta/recipes-devtools/python/python-cython.inc
> > @@ -5,11 +5,11 @@ It's designed to bridge the gap between the nice, high-level, easy-to-use world
> >  and the messy, low-level world of C."
> >  SECTION = "devel/python"
> >  LICENSE = "Apache-2.0"
> > -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
> > +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
> >  PYPI_PACKAGE = "Cython"
> >  BBCLASSEXTEND = "native nativesdk"
> >
> > -SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
> > +SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
> >  UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
> >
> >  inherit pypi
> > @@ -39,4 +39,7 @@ do_install:append() {
> >       for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
> >               sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
> >       done
> > +
> > +        # remove build paths from generated sources
> > +        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
> >  }
> > diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > similarity index 100%
> > rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
> > rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > --
> > 2.39.2
> >
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#193357): https://lists.openembedded.org/g/openembedded-core/message/193357
> > Mute This Topic: https://lists.openembedded.org/mt/103542146/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Alexandre Belloni Jan. 7, 2024, 8:09 p.m. UTC | #3
On 07/01/2024 21:05:45+0100, Alexander Kanavin wrote:
> 2024-01-07 15:06:26,597 - oe-selftest - INFO - FAIL:
> devtool.DevtoolAddTests.test_devtool_add_fetch_simple
> (subunit.RemotedTestCase)
> ERROR: Nothing PROVIDES 'pv'
> 
> 2024-01-07 06:40:56,859 - oe-selftest - INFO - FAIL:
> devtool.DevtoolAddTests.test_devtool_add_git_style1
> (subunit.RemotedTestCase)
> ERROR: Nothing PROVIDES 'mbedtls'
> 
> I'm totally puzzled. Why do you suspect cython?

I didn't have much else to suspect and I ran the same branch without
this patch successfully (but on fedora38-ty-3). Apart from this, I guess
I'm as puzzled as you are.

> 
> Alex
> 
> On Sun, 7 Jan 2024 at 20:54, Alexandre Belloni
> <alexandre.belloni@bootlin.com> wrote:
> >
> > Hello,
> >
> > I believe this causes those failures on fedora, oe-selftest passed on
> > the other hosts:
> >
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6287/steps/14/logs/stdio
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6288/steps/14/logs/stdio
> >
> > Or maybe fedora38-ty-4 is the issue, I've started a build without the
> > patch on this worker now.
> >
> >
> > On 05/01/2024 14:35:43+0100, Alexander Kanavin wrote:
> > > pep517 build backends require cython 3.x when
> > > python is at 3.12, so we can't hold this update any
> > > longer. There are only a few things in meta-oe
> > > and meta that break anymore, and fixes for them
> > > are provided at the same time as this patch.
> > >
> > > License-update: http -> https
> > >
> > > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > > ---
> > >  meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
> > >  .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
> > >  2 files changed, 5 insertions(+), 2 deletions(-)
> > >  rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)
> > >
> > > diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
> > > index 6aec6b012f1..bc1953c5045 100644
> > > --- a/meta/recipes-devtools/python/python-cython.inc
> > > +++ b/meta/recipes-devtools/python/python-cython.inc
> > > @@ -5,11 +5,11 @@ It's designed to bridge the gap between the nice, high-level, easy-to-use world
> > >  and the messy, low-level world of C."
> > >  SECTION = "devel/python"
> > >  LICENSE = "Apache-2.0"
> > > -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
> > > +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
> > >  PYPI_PACKAGE = "Cython"
> > >  BBCLASSEXTEND = "native nativesdk"
> > >
> > > -SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
> > > +SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
> > >  UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
> > >
> > >  inherit pypi
> > > @@ -39,4 +39,7 @@ do_install:append() {
> > >       for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
> > >               sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
> > >       done
> > > +
> > > +        # remove build paths from generated sources
> > > +        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
> > >  }
> > > diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > similarity index 100%
> > > rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
> > > rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > --
> > > 2.39.2
> > >
> >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#193357): https://lists.openembedded.org/g/openembedded-core/message/193357
> > > Mute This Topic: https://lists.openembedded.org/mt/103542146/3617179
> > > Group Owner: openembedded-core+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
> >
> >
> > --
> > Alexandre Belloni, co-owner and COO, Bootlin
> > Embedded Linux and Kernel engineering
> > https://bootlin.com
Alexandre Belloni Jan. 7, 2024, 8:14 p.m. UTC | #4
On 07/01/2024 21:09:11+0100, Alexandre Belloni wrote:
> On 07/01/2024 21:05:45+0100, Alexander Kanavin wrote:
> > 2024-01-07 15:06:26,597 - oe-selftest - INFO - FAIL:
> > devtool.DevtoolAddTests.test_devtool_add_fetch_simple
> > (subunit.RemotedTestCase)
> > ERROR: Nothing PROVIDES 'pv'
> > 
> > 2024-01-07 06:40:56,859 - oe-selftest - INFO - FAIL:
> > devtool.DevtoolAddTests.test_devtool_add_git_style1
> > (subunit.RemotedTestCase)
> > ERROR: Nothing PROVIDES 'mbedtls'
> > 
> > I'm totally puzzled. Why do you suspect cython?
> 
> I didn't have much else to suspect and I ran the same branch without
> this patch successfully (but on fedora38-ty-3). Apart from this, I guess
> I'm as puzzled as you are.

Note that dmesg on the worker had a bunch of
mips64-poky-linux-<something> and prelink-rtld segfaults that are not
unusual.

But also an interesting
[435224.430115] mmap: qemu-ppc (2739864): VmData 1126244352 exceed data ulimit 16777216. Update limits or use boot option ignore_rlimit_data.

I don't believe this is related to this issue.

> 
> > 
> > Alex
> > 
> > On Sun, 7 Jan 2024 at 20:54, Alexandre Belloni
> > <alexandre.belloni@bootlin.com> wrote:
> > >
> > > Hello,
> > >
> > > I believe this causes those failures on fedora, oe-selftest passed on
> > > the other hosts:
> > >
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6287/steps/14/logs/stdio
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6288/steps/14/logs/stdio
> > >
> > > Or maybe fedora38-ty-4 is the issue, I've started a build without the
> > > patch on this worker now.
> > >
> > >
> > > On 05/01/2024 14:35:43+0100, Alexander Kanavin wrote:
> > > > pep517 build backends require cython 3.x when
> > > > python is at 3.12, so we can't hold this update any
> > > > longer. There are only a few things in meta-oe
> > > > and meta that break anymore, and fixes for them
> > > > are provided at the same time as this patch.
> > > >
> > > > License-update: http -> https
> > > >
> > > > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > > > ---
> > > >  meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
> > > >  .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
> > > >  2 files changed, 5 insertions(+), 2 deletions(-)
> > > >  rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)
> > > >
> > > > diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
> > > > index 6aec6b012f1..bc1953c5045 100644
> > > > --- a/meta/recipes-devtools/python/python-cython.inc
> > > > +++ b/meta/recipes-devtools/python/python-cython.inc
> > > > @@ -5,11 +5,11 @@ It's designed to bridge the gap between the nice, high-level, easy-to-use world
> > > >  and the messy, low-level world of C."
> > > >  SECTION = "devel/python"
> > > >  LICENSE = "Apache-2.0"
> > > > -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
> > > > +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
> > > >  PYPI_PACKAGE = "Cython"
> > > >  BBCLASSEXTEND = "native nativesdk"
> > > >
> > > > -SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
> > > > +SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
> > > >  UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
> > > >
> > > >  inherit pypi
> > > > @@ -39,4 +39,7 @@ do_install:append() {
> > > >       for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
> > > >               sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
> > > >       done
> > > > +
> > > > +        # remove build paths from generated sources
> > > > +        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
> > > >  }
> > > > diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > > similarity index 100%
> > > > rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
> > > > rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > > --
> > > > 2.39.2
> > > >
> > >
> > > >
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > > Links: You receive all messages sent to this group.
> > > > View/Reply Online (#193357): https://lists.openembedded.org/g/openembedded-core/message/193357
> > > > Mute This Topic: https://lists.openembedded.org/mt/103542146/3617179
> > > > Group Owner: openembedded-core+owner@lists.openembedded.org
> > > > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > >
> > >
> > >
> > > --
> > > Alexandre Belloni, co-owner and COO, Bootlin
> > > Embedded Linux and Kernel engineering
> > > https://bootlin.com
> 
> -- 
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Alexandre Belloni Jan. 8, 2024, 7:39 a.m. UTC | #5
On 07/01/2024 20:54:18+0100, Alexandre Belloni via lists.openembedded.org wrote:
> Hello,
> 
> I believe this causes those failures on fedora, oe-selftest passed on
> the other hosts:
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6287/steps/14/logs/stdio
> https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6288/steps/14/logs/stdio
> 
> Or maybe fedora38-ty-4 is the issue, I've started a build without the
> patch on this worker now.
> 

Amazingly, I can't reproduce anymore...

> 
> On 05/01/2024 14:35:43+0100, Alexander Kanavin wrote:
> > pep517 build backends require cython 3.x when
> > python is at 3.12, so we can't hold this update any
> > longer. There are only a few things in meta-oe
> > and meta that break anymore, and fixes for them
> > are provided at the same time as this patch.
> > 
> > License-update: http -> https
> > 
> > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > ---
> >  meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
> >  .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
> >  2 files changed, 5 insertions(+), 2 deletions(-)
> >  rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)
> > 
> > diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
> > index 6aec6b012f1..bc1953c5045 100644
> > --- a/meta/recipes-devtools/python/python-cython.inc
> > +++ b/meta/recipes-devtools/python/python-cython.inc
> > @@ -5,11 +5,11 @@ It's designed to bridge the gap between the nice, high-level, easy-to-use world
> >  and the messy, low-level world of C."
> >  SECTION = "devel/python"
> >  LICENSE = "Apache-2.0"
> > -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
> > +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
> >  PYPI_PACKAGE = "Cython"
> >  BBCLASSEXTEND = "native nativesdk"
> >  
> > -SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
> > +SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
> >  UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
> >  
> >  inherit pypi
> > @@ -39,4 +39,7 @@ do_install:append() {
> >  	for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
> >  		sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
> >  	done
> > +
> > +        # remove build paths from generated sources
> > +        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
> >  }
> > diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > similarity index 100%
> > rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
> > rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > -- 
> > 2.39.2
> > 
> 
> > 
> > 
> > 
> 
> 
> -- 
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193390): https://lists.openembedded.org/g/openembedded-core/message/193390
> Mute This Topic: https://lists.openembedded.org/mt/103542146/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Jan. 8, 2024, 8:10 a.m. UTC | #6
I suspect this might have been a transient network issue. Both tests
fetch stuff from 3rd party servers.

Alex

On Mon, 8 Jan 2024 at 08:39, Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> On 07/01/2024 20:54:18+0100, Alexandre Belloni via lists.openembedded.org wrote:
> > Hello,
> >
> > I believe this causes those failures on fedora, oe-selftest passed on
> > the other hosts:
> >
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6287/steps/14/logs/stdio
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6288/steps/14/logs/stdio
> >
> > Or maybe fedora38-ty-4 is the issue, I've started a build without the
> > patch on this worker now.
> >
>
> Amazingly, I can't reproduce anymore...
>
> >
> > On 05/01/2024 14:35:43+0100, Alexander Kanavin wrote:
> > > pep517 build backends require cython 3.x when
> > > python is at 3.12, so we can't hold this update any
> > > longer. There are only a few things in meta-oe
> > > and meta that break anymore, and fixes for them
> > > are provided at the same time as this patch.
> > >
> > > License-update: http -> https
> > >
> > > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > > ---
> > >  meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
> > >  .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
> > >  2 files changed, 5 insertions(+), 2 deletions(-)
> > >  rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)
> > >
> > > diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
> > > index 6aec6b012f1..bc1953c5045 100644
> > > --- a/meta/recipes-devtools/python/python-cython.inc
> > > +++ b/meta/recipes-devtools/python/python-cython.inc
> > > @@ -5,11 +5,11 @@ It's designed to bridge the gap between the nice, high-level, easy-to-use world
> > >  and the messy, low-level world of C."
> > >  SECTION = "devel/python"
> > >  LICENSE = "Apache-2.0"
> > > -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
> > > +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
> > >  PYPI_PACKAGE = "Cython"
> > >  BBCLASSEXTEND = "native nativesdk"
> > >
> > > -SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
> > > +SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
> > >  UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
> > >
> > >  inherit pypi
> > > @@ -39,4 +39,7 @@ do_install:append() {
> > >     for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
> > >             sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
> > >     done
> > > +
> > > +        # remove build paths from generated sources
> > > +        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
> > >  }
> > > diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > similarity index 100%
> > > rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
> > > rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > --
> > > 2.39.2
> > >
> >
> > >
> > >
> > >
> >
> >
> > --
> > Alexandre Belloni, co-owner and COO, Bootlin
> > Embedded Linux and Kernel engineering
> > https://bootlin.com
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#193390): https://lists.openembedded.org/g/openembedded-core/message/193390
> > Mute This Topic: https://lists.openembedded.org/mt/103542146/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Alexandre Belloni Jan. 9, 2024, 9:50 p.m. UTC | #7
On 08/01/2024 09:10:14+0100, Alexander Kanavin wrote:
> I suspect this might have been a transient network issue. Both tests
> fetch stuff from 3rd party servers.

This is super weird but I added the cython upgrade and got this one, on
fedora38-ty-4 again:
https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6296/steps/14/logs/stdio

I'll try to reproduce without the other patches I'm carrying.

> 
> Alex
> 
> On Mon, 8 Jan 2024 at 08:39, Alexandre Belloni
> <alexandre.belloni@bootlin.com> wrote:
> >
> > On 07/01/2024 20:54:18+0100, Alexandre Belloni via lists.openembedded.org wrote:
> > > Hello,
> > >
> > > I believe this causes those failures on fedora, oe-selftest passed on
> > > the other hosts:
> > >
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6287/steps/14/logs/stdio
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6288/steps/14/logs/stdio
> > >
> > > Or maybe fedora38-ty-4 is the issue, I've started a build without the
> > > patch on this worker now.
> > >
> >
> > Amazingly, I can't reproduce anymore...
> >
> > >
> > > On 05/01/2024 14:35:43+0100, Alexander Kanavin wrote:
> > > > pep517 build backends require cython 3.x when
> > > > python is at 3.12, so we can't hold this update any
> > > > longer. There are only a few things in meta-oe
> > > > and meta that break anymore, and fixes for them
> > > > are provided at the same time as this patch.
> > > >
> > > > License-update: http -> https
> > > >
> > > > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > > > ---
> > > >  meta/recipes-devtools/python/python-cython.inc             | 7 +++++--
> > > >  .../{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} | 0
> > > >  2 files changed, 5 insertions(+), 2 deletions(-)
> > > >  rename meta/recipes-devtools/python/{python3-cython_0.29.36.bb => python3-cython_3.0.7.bb} (100%)
> > > >
> > > > diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
> > > > index 6aec6b012f1..bc1953c5045 100644
> > > > --- a/meta/recipes-devtools/python/python-cython.inc
> > > > +++ b/meta/recipes-devtools/python/python-cython.inc
> > > > @@ -5,11 +5,11 @@ It's designed to bridge the gap between the nice, high-level, easy-to-use world
> > > >  and the messy, low-level world of C."
> > > >  SECTION = "devel/python"
> > > >  LICENSE = "Apache-2.0"
> > > > -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
> > > > +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
> > > >  PYPI_PACKAGE = "Cython"
> > > >  BBCLASSEXTEND = "native nativesdk"
> > > >
> > > > -SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
> > > > +SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
> > > >  UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
> > > >
> > > >  inherit pypi
> > > > @@ -39,4 +39,7 @@ do_install:append() {
> > > >     for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
> > > >             sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
> > > >     done
> > > > +
> > > > +        # remove build paths from generated sources
> > > > +        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
> > > >  }
> > > > diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > > similarity index 100%
> > > > rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
> > > > rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb
> > > > --
> > > > 2.39.2
> > > >
> > >
> > > >
> > > >
> > > >
> > >
> > >
> > > --
> > > Alexandre Belloni, co-owner and COO, Bootlin
> > > Embedded Linux and Kernel engineering
> > > https://bootlin.com
> >
> > >
> > > 
> > >
> >
> >
> > --
> > Alexandre Belloni, co-owner and COO, Bootlin
> > Embedded Linux and Kernel engineering
> > https://bootlin.com

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193396): https://lists.openembedded.org/g/openembedded-core/message/193396
> Mute This Topic: https://lists.openembedded.org/mt/103542146/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
index 6aec6b012f1..bc1953c5045 100644
--- a/meta/recipes-devtools/python/python-cython.inc
+++ b/meta/recipes-devtools/python/python-cython.inc
@@ -5,11 +5,11 @@  It's designed to bridge the gap between the nice, high-level, easy-to-use world
 and the messy, low-level world of C."
 SECTION = "devel/python"
 LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
 PYPI_PACKAGE = "Cython"
 BBCLASSEXTEND = "native nativesdk"
 
-SRC_URI[sha256sum] = "41c0cfd2d754e383c9eeb95effc9aa4ab847d0c9747077ddd7c0dcb68c3bc01f"
+SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
 UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
 
 inherit pypi
@@ -39,4 +39,7 @@  do_install:append() {
 	for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
 		sed -i -e '1s|^#!.*|#!/usr/bin/env ${PYTHON_PN}|' $PYTHSCRIPT
 	done
+
+        # remove build paths from generated sources
+        sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c
 }
diff --git a/meta/recipes-devtools/python/python3-cython_0.29.36.bb b/meta/recipes-devtools/python/python3-cython_3.0.7.bb
similarity index 100%
rename from meta/recipes-devtools/python/python3-cython_0.29.36.bb
rename to meta/recipes-devtools/python/python3-cython_3.0.7.bb