diff mbox series

[1/2] Revert "opkg-utils: upgrade 0.6.2 -> 0.6.3"

Message ID 20240104021052.754030-1-raj.khem@gmail.com
State New
Headers show
Series [1/2] Revert "opkg-utils: upgrade 0.6.2 -> 0.6.3" | expand

Commit Message

Khem Raj Jan. 4, 2024, 2:10 a.m. UTC
This reverts commit a856192be5dd78c621478ed29871191c580686c4.

It causes a regression in creating different GIDs in image and ipk as
reported in [1]

[1] https://bugzilla.yoctoproject.org/show_bug.cgi?id=15334

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../opkg-utils/{opkg-utils_0.6.3.bb => opkg-utils_0.6.2.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/opkg-utils/{opkg-utils_0.6.3.bb => opkg-utils_0.6.2.bb} (97%)

Comments

Alexandre Belloni Jan. 5, 2024, 4:16 p.m. UTC | #1
I believe this caused:

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4191/steps/12/logs/stdio

On 03/01/2024 18:10:51-0800, Khem Raj wrote:
> This reverts commit a856192be5dd78c621478ed29871191c580686c4.
> 
> It causes a regression in creating different GIDs in image and ipk as
> reported in [1]
> 
> [1] https://bugzilla.yoctoproject.org/show_bug.cgi?id=15334
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  .../opkg-utils/{opkg-utils_0.6.3.bb => opkg-utils_0.6.2.bb}     | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>  rename meta/recipes-devtools/opkg-utils/{opkg-utils_0.6.3.bb => opkg-utils_0.6.2.bb} (97%)
> 
> diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
> similarity index 97%
> rename from meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb
> rename to meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
> index b509227e1a6..eb88b9b734c 100644
> --- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb
> +++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
> @@ -10,7 +10,7 @@ PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtu
>  SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=https;branch=master \
>             file://0001-update-alternatives-correctly-match-priority.patch \
>             "
> -SRCREV = "589880d01969eb9af1e66120e731d43193504718"
> +SRCREV = "67994e62dc598282830385da75ba9b1abbbda941"
>  
>  S = "${WORKDIR}/git"
>  
> -- 
> 2.43.0
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193299): https://lists.openembedded.org/g/openembedded-core/message/193299
> Mute This Topic: https://lists.openembedded.org/mt/103515671/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Jan. 5, 2024, 5:43 p.m. UTC | #2
On Fri, Jan 5, 2024 at 8:16 AM Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> I believe this caused:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4191/steps/12/logs/stdio
>

Likely, so because this patch
https://git.yoctoproject.org/opkg-utils/commit/?id=8d9953dd8d589e9b740307976cbe474e0ce292a0
to opkg fixes mtime to be consistent across runs and this seems likely
to be the reason for
the reproducibiliy failiure. I wish xattr/acl support and this piece
were two separate patches perhaps we could then revert just the
one affecting GID issue. I would say lets wait for above bugs progress
and hold on to this patch until then.

> On 03/01/2024 18:10:51-0800, Khem Raj wrote:
> > This reverts commit a856192be5dd78c621478ed29871191c580686c4.
> >
> > It causes a regression in creating different GIDs in image and ipk as
> > reported in [1]
> >
> > [1] https://bugzilla.yoctoproject.org/show_bug.cgi?id=15334
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >  .../opkg-utils/{opkg-utils_0.6.3.bb => opkg-utils_0.6.2.bb}     | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >  rename meta/recipes-devtools/opkg-utils/{opkg-utils_0.6.3.bb => opkg-utils_0.6.2.bb} (97%)
> >
> > diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
> > similarity index 97%
> > rename from meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb
> > rename to meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
> > index b509227e1a6..eb88b9b734c 100644
> > --- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb
> > +++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
> > @@ -10,7 +10,7 @@ PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtu
> >  SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=https;branch=master \
> >             file://0001-update-alternatives-correctly-match-priority.patch \
> >             "
> > -SRCREV = "589880d01969eb9af1e66120e731d43193504718"
> > +SRCREV = "67994e62dc598282830385da75ba9b1abbbda941"
> >
> >  S = "${WORKDIR}/git"
> >
> > --
> > 2.43.0
> >
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#193299): https://lists.openembedded.org/g/openembedded-core/message/193299
> > Mute This Topic: https://lists.openembedded.org/mt/103515671/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
similarity index 97%
rename from meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb
rename to meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
index b509227e1a6..eb88b9b734c 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.3.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
@@ -10,7 +10,7 @@  PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtu
 SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=https;branch=master \
            file://0001-update-alternatives-correctly-match-priority.patch \
            "
-SRCREV = "589880d01969eb9af1e66120e731d43193504718"
+SRCREV = "67994e62dc598282830385da75ba9b1abbbda941"
 
 S = "${WORKDIR}/git"