diff mbox series

[v5,2/2] cairo: fix builds on targets without qemu usermode

Message ID 20240102175026.2903297-2-alex@linutronix.de
State New
Headers show
Series [v5,1/2] cairo: upgrade 1.16.0 -> 1.18.0 | expand

Commit Message

Alexander Kanavin Jan. 2, 2024, 5:50 p.m. UTC
There is a hastily copy-pasted, untested fix for this, which
needs some adjustments:

- drop irrelevant comment

- section should be [properties], not [binaries]

- the setting should only be forced if qemu usermode
isn't available, otherwise it can be determined by
runinng the code as intended.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-graphics/cairo/cairo_1.18.0.bb | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-graphics/cairo/cairo_1.18.0.bb b/meta/recipes-graphics/cairo/cairo_1.18.0.bb
index ffae13b48a6..fe72537b776 100644
--- a/meta/recipes-graphics/cairo/cairo_1.18.0.bb
+++ b/meta/recipes-graphics/cairo/cairo_1.18.0.bb
@@ -36,14 +36,15 @@  SRC_URI[sha256sum] = "243a0736b978a33dee29f9cca7521733b78a65b5418206fef7bd1c3d4c
 
 inherit meson pkgconfig upstream-version-is-even gtk-doc multilib_script
 
-# Tell libsoup where the target ntlm_auth is installed
+# if qemu usermode isn't available, this value needs to be set statically
+# (otherwise it's determinted by running a small target executable with qemu)
 do_write_config:append:class-target() {
     cat >${WORKDIR}/cairo.cross <<EOF
-[binaries]
+[properties]
 ipc_rmid_deferred_release = 'true'
 EOF
 }
-EXTRA_OEMESON:append:class-target = " --cross-file ${WORKDIR}/cairo.cross"
+EXTRA_OEMESON:append:class-target = "${@' --cross-file ${WORKDIR}/cairo.cross' if d.getVar('EXEWRAPPER_ENABLED') == 'False' else ''}"
 
 GTKDOC_MESON_OPTION = "gtk_doc"