diff mbox series

packagegroups: Add perl modules to rdeps

Message ID 20231227125025.2531461-1-Deepthi.Hemraj@windriver.com
State New
Headers show
Series packagegroups: Add perl modules to rdeps | expand

Commit Message

Deepthi H Dec. 27, 2023, 12:50 p.m. UTC
From: Deepthi Hemraj <Deepthi.Hemraj@windriver.com>

In SDK,running "x86_64-poky-linux-gp-display-html --help" fails due to missing perl modules which are required for it to work.

Fixes:Can't locate feature.pm in @INC (you may need to install the feature module) and also add all the perl modules to sdk.

Signed-off-by: Deepthi Hemraj <Deepthi.Hemraj@windriver.com>
---
 .../packagegroups/nativesdk-packagegroup-sdk-host.bb          | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Randy MacLeod Dec. 27, 2023, 3:47 p.m. UTC | #1
On 2023-12-27 7:50 a.m., Deepthi.Hemraj@windriver.com wrote:
> From: Deepthi Hemraj<Deepthi.Hemraj@windriver.com>
>
> In SDK,running "x86_64-poky-linux-gp-display-html --help" fails due to missing perl modules which are required for it to work.
>
> Fixes:Can't locate feature.pm in @INC (you may need to install the feature module) and also add all the perl modules to sdk.
>
> Signed-off-by: Deepthi Hemraj<Deepthi.Hemraj@windriver.com>
> ---
>   .../packagegroups/nativesdk-packagegroup-sdk-host.bb          | 4 +---
>   1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
> index 11e31dcba3..2561d79900 100644
> --- a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
> +++ b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
> @@ -8,8 +8,6 @@ inherit packagegroup nativesdk
>   
>   PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
>   
> -# autoconf pulls in nativesdk-perl but perl-module-integer is needed to
> -# build some recent linux kernels (5.14+) for arm
>   RDEPENDS:${PN} = "\
>       nativesdk-pkgconfig \
>       nativesdk-qemu \
> @@ -28,7 +26,7 @@ RDEPENDS:${PN} = "\
>       nativesdk-sdk-provides-dummy \
>       nativesdk-bison \
>       nativesdk-flex \
> -    nativesdk-perl-module-integer \
> +    nativesdk-perl-modules \
>       "

perl-modules is a meta-package that pulls in *all* **726** (1) perl 
modules with each one
being ~100KB.

That's adding quite a bit of bloat for a feature that few people need ( 
gp-display-html --help 
https://manpages.debian.org/unstable/binutils-common/gp-display-html.1.en.html 
)

We just need perl-modue-feature to get features.pm.

tmp-glibc/work/core2-64-wrs-linux/perl/5.38.0/packages-split/perl-module-feature/usr/lib64/perl5/5.38.0/feature.pm

Can you try again to see if you can require fewer packages please?
If you can explain that you tried adding > 15 perl modules and you still 
don't have all the dependencies,
then we can talk about what to do.

Please confirm that you are able to use gp-display-html to view the 
results of a profiling run.

../Randy


1)

❯ ls tmp-glibc/work/core2-64-wrs-linux/perl/5.38.0/packages-split/ | rg 
module | wc -l
726


I
>   
>   RDEPENDS:${PN}:darwin = "\
Randy MacLeod Dec. 27, 2023, 3:53 p.m. UTC | #2
Also, your subject is to vague:
    [patch] packagegroups: Add perl modules to rdeps
it should be something like:
   [PATCH] nativesdk-packagegroup-sdk-host: Add perl modules to RDEPENDS


That's 62 characters so still under the limt, iirc.

It's better to be specific, since there are 27 packagegroup files in poky:
poky.git> fd packagegroup.*bb  | wc -l
Sadineni, Harish Dec. 28, 2023, 6:07 a.m. UTC | #3
Hi Randy,

There were a few such failure instances (similar to current issue) we've seen in the past and those were fixed by adding the respective modules. So, to avoid such failure in future 'nativesdk-perl-modules' is added. If that causing memory overhead, this issue will be fixed with only adding the module 'perl-module-feature'. We will send a V2 by adding only that.

Thanks & Regards

Harish Sadineni
Sadineni, Harish Dec. 28, 2023, 2:27 p.m. UTC | #4
Hi Randy,

I have sent a new patch for this. the link to new patch is given below,
https://lists.openembedded.org/g/openembedded-core/message/192979

Thanks & Regards
Harish Sadineni
diff mbox series

Patch

diff --git a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
index 11e31dcba3..2561d79900 100644
--- a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
+++ b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
@@ -8,8 +8,6 @@  inherit packagegroup nativesdk
 
 PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
 
-# autoconf pulls in nativesdk-perl but perl-module-integer is needed to 
-# build some recent linux kernels (5.14+) for arm
 RDEPENDS:${PN} = "\
     nativesdk-pkgconfig \
     nativesdk-qemu \
@@ -28,7 +26,7 @@  RDEPENDS:${PN} = "\
     nativesdk-sdk-provides-dummy \
     nativesdk-bison \
     nativesdk-flex \
-    nativesdk-perl-module-integer \
+    nativesdk-perl-modules \
     "
 
 RDEPENDS:${PN}:darwin = "\