diff mbox series

python3-maturin: Add missing space appending to CFLAGS

Message ID 20231221215733.1057373-1-renat_khalikov@trimble.com
State Accepted, archived
Commit cac54e6a6c6601629305b006f99fd1215565182b
Headers show
Series python3-maturin: Add missing space appending to CFLAGS | expand

Commit Message

Renat Khalikov Dec. 21, 2023, 9:57 p.m. UTC
When the CFLAGS variable is appended to, the missing space causes build
errors when CFLAGS was set previously.

For example:

  error: unrecognized command-line option '-mno-unaligned-access-fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home'

Signed-off-by: Renat Khalikov <renat_khalikov@trimble.com>
CC: Tim Orling <tim.orling@konsulko.com>
---
 meta/recipes-devtools/python/python3-maturin_1.4.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Tim Orling Dec. 22, 2023, 3:51 a.m. UTC | #1
Acknowledged. This was intended but not present in the series as merged.

On Thu, Dec 21, 2023 at 1:57 PM Renat Khalikov <renat_khalikov@trimble.com>
wrote:

> When the CFLAGS variable is appended to, the missing space causes build
> errors when CFLAGS was set previously.
>
> For example:
>
>   error: unrecognized command-line option
> '-mno-unaligned-access-fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home'
>
> Signed-off-by: Renat Khalikov <renat_khalikov@trimble.com>
> CC: Tim Orling <tim.orling@konsulko.com>
> ---
>  meta/recipes-devtools/python/python3-maturin_1.4.0.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
> b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
> index 07ad1201b8..82e65abb24 100644
> --- a/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
> +++ b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
> @@ -9,7 +9,7 @@ SRC_URI[sha256sum] =
> "ed12e1768094a7adeafc3a74ebdb8dc2201fa64c4e7e31f14cfc70378b
>
>  S = "${WORKDIR}/maturin-${PV}"
>
> -CFLAGS:append =
> "-fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home"
> +CFLAGS:append = "
> -fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home"
>
>  DEPENDS += "\
>      python3-setuptools-rust-native \
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192852):
> https://lists.openembedded.org/g/openembedded-core/message/192852
> Mute This Topic: https://lists.openembedded.org/mt/103308686/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-maturin_1.4.0.bb b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
index 07ad1201b8..82e65abb24 100644
--- a/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
+++ b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
@@ -9,7 +9,7 @@  SRC_URI[sha256sum] = "ed12e1768094a7adeafc3a74ebdb8dc2201fa64c4e7e31f14cfc70378b
 
 S = "${WORKDIR}/maturin-${PV}"
 
-CFLAGS:append = "-fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home"
+CFLAGS:append = " -fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home"
 
 DEPENDS += "\
     python3-setuptools-rust-native \