diff mbox series

util-linux: Delete md-raid tests

Message ID 20231214193436.224539-1-raj.khem@gmail.com
State Accepted, archived
Commit 4f3b4b4f27924f9093dc6b4dd949cabe5cd2891b
Headers show
Series util-linux: Delete md-raid tests | expand

Commit Message

Khem Raj Dec. 14, 2023, 7:34 p.m. UTC
These tests are marked as known failures upstream as well [1]
if we delete them then we can drop dependency on mdadm for ptests which
can further reduce the dependency chain for ptest enabled minimal images

[1] https://github.com/util-linux/util-linux/commit/7519c3edab120b14623931d5ddb16fdc6e7cad5d

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/util-linux/util-linux_2.39.2.bb | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Richard Purdie Dec. 15, 2023, 12:45 a.m. UTC | #1
On Thu, 2023-12-14 at 11:34 -0800, Khem Raj wrote:
> These tests are marked as known failures upstream as well [1]
> if we delete them then we can drop dependency on mdadm for ptests which
> can further reduce the dependency chain for ptest enabled minimal images
> 
> [1] https://github.com/util-linux/util-linux/commit/7519c3edab120b14623931d5ddb16fdc6e7cad5d
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-core/util-linux/util-linux_2.39.2.bb | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-core/util-linux/util-linux_2.39.2.bb b/meta/recipes-core/util-linux/util-linux_2.39.2.bb
> index 927037a3429..8c081674017 100644
> --- a/meta/recipes-core/util-linux/util-linux_2.39.2.bb
> +++ b/meta/recipes-core/util-linux/util-linux_2.39.2.bb
> @@ -137,7 +137,7 @@ RDEPENDS:${PN}-dev += " util-linux-libuuid-dev"
>  RPROVIDES:${PN}-dev = "${PN}-libblkid-dev ${PN}-libmount-dev"
>  
>  RDEPENDS:${PN}-bash-completion += "${PN}-lsblk"
> -RDEPENDS:${PN}-ptest += "bash bc btrfs-tools coreutils e2fsprogs findutils grep iproute2 kmod mdadm procps sed socat which xz"
> +RDEPENDS:${PN}-ptest += "bash bc btrfs-tools coreutils e2fsprogs findutils grep iproute2 kmod procps sed socat which xz"
>  RRECOMMENDS:${PN}-ptest += "kernel-module-scsi-debug kernel-module-sd-mod kernel-module-loop kernel-module-algif-hash"
>  RDEPENDS:${PN}-swaponoff = "${PN}-swapon ${PN}-swapoff"
>  ALLOW_EMPTY:${PN}-swaponoff = "1"
> @@ -320,6 +320,12 @@ do_install_ptest() {
>      if ! ${@bb.utils.contains('PACKAGECONFIG', 'pam', 'true', 'false', d)}; then
>          rm -rf ${D}${PTEST_PATH}/tests/ts/chfn
>      fi
> +    # remove raid tests, known failures and avoid dependency on mdadm therefore
> +    # See https://github.com/util-linux/util-linux/commit/7519c3edab120b14623931d5ddb16fdc6e7cad5d
> +    rm -rf ${D}${PTEST_PATH}/tests/ts/blkid/md-raid0-whole
> +    rm -rf ${D}${PTEST_PATH}/tests/ts/blkid/md-raid1-part
> +    rm -rf ${D}${PTEST_PATH}/tests/ts/blkid/md-raid1-whole
> +    rm -rf ${D}${PTEST_PATH}/tests/ts/fdisk/align-512-4K-md
>  }
>  
>  # Delete tests not working on musl
> -

This sounds good to me, thanks!

Unwinding a few dependencies like this can make all the difference to
build times.

Cheers,

Richard
Yoann Congal Dec. 15, 2023, 10:42 a.m. UTC | #2
Hi,

Le 14/12/2023 à 20:34, Khem Raj a écrit :
> These tests are marked as known failures upstream as well [1]
> if we delete them then we can drop dependency on mdadm for ptests which
> can further reduce the dependency chain for ptest enabled minimal images
> 
> [1] https://github.com/util-linux/util-linux/commit/7519c3edab120b14623931d5ddb16fdc6e7cad5d
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-core/util-linux/util-linux_2.39.2.bb | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)

Just tested it: this patch also work to remove bluez from the dependency chain of a default core-image-minimal build (https://bugzilla.yoctoproject.org/show_bug.cgi?id=15323)

Regards,
diff mbox series

Patch

diff --git a/meta/recipes-core/util-linux/util-linux_2.39.2.bb b/meta/recipes-core/util-linux/util-linux_2.39.2.bb
index 927037a3429..8c081674017 100644
--- a/meta/recipes-core/util-linux/util-linux_2.39.2.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.39.2.bb
@@ -137,7 +137,7 @@  RDEPENDS:${PN}-dev += " util-linux-libuuid-dev"
 RPROVIDES:${PN}-dev = "${PN}-libblkid-dev ${PN}-libmount-dev"
 
 RDEPENDS:${PN}-bash-completion += "${PN}-lsblk"
-RDEPENDS:${PN}-ptest += "bash bc btrfs-tools coreutils e2fsprogs findutils grep iproute2 kmod mdadm procps sed socat which xz"
+RDEPENDS:${PN}-ptest += "bash bc btrfs-tools coreutils e2fsprogs findutils grep iproute2 kmod procps sed socat which xz"
 RRECOMMENDS:${PN}-ptest += "kernel-module-scsi-debug kernel-module-sd-mod kernel-module-loop kernel-module-algif-hash"
 RDEPENDS:${PN}-swaponoff = "${PN}-swapon ${PN}-swapoff"
 ALLOW_EMPTY:${PN}-swaponoff = "1"
@@ -320,6 +320,12 @@  do_install_ptest() {
     if ! ${@bb.utils.contains('PACKAGECONFIG', 'pam', 'true', 'false', d)}; then
         rm -rf ${D}${PTEST_PATH}/tests/ts/chfn
     fi
+    # remove raid tests, known failures and avoid dependency on mdadm therefore
+    # See https://github.com/util-linux/util-linux/commit/7519c3edab120b14623931d5ddb16fdc6e7cad5d
+    rm -rf ${D}${PTEST_PATH}/tests/ts/blkid/md-raid0-whole
+    rm -rf ${D}${PTEST_PATH}/tests/ts/blkid/md-raid1-part
+    rm -rf ${D}${PTEST_PATH}/tests/ts/blkid/md-raid1-whole
+    rm -rf ${D}${PTEST_PATH}/tests/ts/fdisk/align-512-4K-md
 }
 
 # Delete tests not working on musl