diff mbox series

[v2,1/2] systemd-boot: Add recipe to compile native

Message ID 20231213115748.487216-1-quic_vkraleti@quicinc.com
State New
Headers show
Series [v2,1/2] systemd-boot: Add recipe to compile native | expand

Commit Message

Viswanath Kraleti Dec. 13, 2023, 11:57 a.m. UTC
systemd-boot native recipe provides ukify tool to build
UKI images for systemd-boot

Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
---
 .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb

Comments

Khem Raj Dec. 13, 2023, 8:52 p.m. UTC | #1
On Wed, Dec 13, 2023 at 3:58 AM Viswanath Kraleti
<quic_vkraleti@quicinc.com> wrote:
>
> systemd-boot native recipe provides ukify tool to build
> UKI images for systemd-boot
>
> Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
> ---
>  .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>
> diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> new file mode 100644
> index 0000000000..0cdd7e7045
> --- /dev/null
> +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> @@ -0,0 +1,15 @@
> +require systemd.inc
> +
> +inherit native
> +
> +RRECOMMENDS:${PN} += "python3-pefile-native"
> +
> +COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"

this is a native recipe, so I wonder why do we need COMPATIBLE_HOST

> +
> +do_configure[noexec] = "1"
> +do_compile[noexec] = "1"

should these tasks be simply deleted using deltask

> +
> +do_install () {
> +       install -d ${D}${bindir}
> +       install -m 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify

you can make it one liner

install -Dm 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify

> +}
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192289): https://lists.openembedded.org/g/openembedded-core/message/192289
> Mute This Topic: https://lists.openembedded.org/mt/103147679/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexandre Belloni Dec. 14, 2023, 8:02 a.m. UTC | #2
Hello, this causes:

https://autobuilder.yoctoproject.org/typhoon/#/builders/23/builds/8617/steps/11/logs/warnings

WARNING: Nothing RPROVIDES 'python3-pefile-native' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
WARNING: Nothing RPROVIDES 'systemd-boot-native-dev' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
WARNING: Nothing RPROVIDES 'systemd-boot-native' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)

and:

https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/6133/steps/14/logs/stdio

The following recipes do not have a maintainer assigned to them. Please add an entry to meta/conf/distro/include/maintainers.inc file.
systemd-boot-native (/home/pokybuild/yocto-worker/oe-selftest-debian/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb)

On 13/12/2023 17:27:47+0530, Viswanath Kraleti wrote:
> systemd-boot native recipe provides ukify tool to build
> UKI images for systemd-boot
> 
> Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
> ---
>  .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> 
> diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> new file mode 100644
> index 0000000000..0cdd7e7045
> --- /dev/null
> +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> @@ -0,0 +1,15 @@
> +require systemd.inc
> +
> +inherit native
> +
> +RRECOMMENDS:${PN} += "python3-pefile-native"
> +
> +COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
> +
> +do_configure[noexec] = "1"
> +do_compile[noexec] = "1"
> +
> +do_install () {
> +       install -d ${D}${bindir}
> +       install -m 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
> +}
> -- 
> 2.25.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192289): https://lists.openembedded.org/g/openembedded-core/message/192289
> Mute This Topic: https://lists.openembedded.org/mt/103147679/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Viswanath Kraleti Dec. 14, 2023, 2:35 p.m. UTC | #3
On 12/14/2023 2:22 AM, Khem Raj wrote:
> On Wed, Dec 13, 2023 at 3:58 AM Viswanath Kraleti
> <quic_vkraleti@quicinc.com> wrote:
>>
>> systemd-boot native recipe provides ukify tool to build
>> UKI images for systemd-boot
>>
>> Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
>> ---
>>   .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
>>   1 file changed, 15 insertions(+)
>>   create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>>
>> diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>> new file mode 100644
>> index 0000000000..0cdd7e7045
>> --- /dev/null
>> +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>> @@ -0,0 +1,15 @@
>> +require systemd.inc
>> +
>> +inherit native
>> +
>> +RRECOMMENDS:${PN} += "python3-pefile-native"
>> +
>> +COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
> 
> this is a native recipe, so I wonder why do we need COMPATIBLE_HOST
> 
Removed it.
>> +
>> +do_configure[noexec] = "1"
>> +do_compile[noexec] = "1"
> 
> should these tasks be simply deleted using deltask
> 
Used noexec to let default task dependencies to remain as is so that 
install can find source under ${S}. I'll explicitly add 'addtask install 
after do_unpack'.
>> +
>> +do_install () {
>> +       install -d ${D}${bindir}
>> +       install -m 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
> 
> you can make it one liner
> 
> install -Dm 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
>
Thanks for the input.

>> +}
>> --
>> 2.25.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#192289): https://lists.openembedded.org/g/openembedded-core/message/192289
>> Mute This Topic: https://lists.openembedded.org/mt/103147679/1997914
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Viswanath Kraleti Dec. 14, 2023, 2:41 p.m. UTC | #4
On 12/14/2023 1:32 PM, Alexandre Belloni via lists.openembedded.org wrote:
> Hello, this causes:
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/23/builds/8617/steps/11/logs/warnings
> 
> WARNING: Nothing RPROVIDES 'python3-pefile-native' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
> WARNING: Nothing RPROVIDES 'systemd-boot-native-dev' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
> WARNING: Nothing RPROVIDES 'systemd-boot-native' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
> 

Thanks for pointing.Uploaded a new patch-set to address these.
https://lists.openembedded.org/g/openembedded-core/message/192384

Some how in local build no warnings seen. Is there a way to run auto 
builder locally before submitting patches to avoid this?

> and:
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/6133/steps/14/logs/stdio
> 
> The following recipes do not have a maintainer assigned to them. Please add an entry to meta/conf/distro/include/maintainers.inc file.
> systemd-boot-native (/home/pokybuild/yocto-worker/oe-selftest-debian/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb)
>
For updating maintainer, can I submit a change post patch acceptance?

> On 13/12/2023 17:27:47+0530, Viswanath Kraleti wrote:
>> systemd-boot native recipe provides ukify tool to build
>> UKI images for systemd-boot
>>
>> Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
>> ---
>>   .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
>>   1 file changed, 15 insertions(+)
>>   create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>>
>> diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>> new file mode 100644
>> index 0000000000..0cdd7e7045
>> --- /dev/null
>> +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>> @@ -0,0 +1,15 @@
>> +require systemd.inc
>> +
>> +inherit native
>> +
>> +RRECOMMENDS:${PN} += "python3-pefile-native"
>> +
>> +COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
>> +
>> +do_configure[noexec] = "1"
>> +do_compile[noexec] = "1"
>> +
>> +do_install () {
>> +       install -d ${D}${bindir}
>> +       install -m 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
>> +}
>> -- 
>> 2.25.1
>>
> 
>>
>>
>>
> 
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192337): https://lists.openembedded.org/g/openembedded-core/message/192337
> Mute This Topic: https://lists.openembedded.org/mt/103147679/5192326
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [quic_vkraleti@quicinc.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexandre Belloni Dec. 14, 2023, 11:04 p.m. UTC | #5
On 14/12/2023 20:11:16+0530, Viswanath Kraleti wrote:
> 
> 
> On 12/14/2023 1:32 PM, Alexandre Belloni via lists.openembedded.org wrote:
> > Hello, this causes:
> > 
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/23/builds/8617/steps/11/logs/warnings
> > 
> > WARNING: Nothing RPROVIDES 'python3-pefile-native' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
> > WARNING: Nothing RPROVIDES 'systemd-boot-native-dev' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
> > WARNING: Nothing RPROVIDES 'systemd-boot-native' (but /home/pokybuild/yocto-worker/build-appliance/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb RDEPENDS on or otherwise requires it)
> > 
> 
> Thanks for pointing.Uploaded a new patch-set to address these.
> https://lists.openembedded.org/g/openembedded-core/message/192384
> 
> Some how in local build no warnings seen. Is there a way to run auto builder
> locally before submitting patches to avoid this?

Well, this one is simply a checkout of poky with the following
configuration:

https://autobuilder.yoctoproject.org/typhoon/#/builders/23/builds/8617/steps/10/logs/stdio

The failing command was then:
bitbake universe -k -c fetch -k


> 
> > and:
> > 
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/6133/steps/14/logs/stdio
> > 
> > The following recipes do not have a maintainer assigned to them. Please add an entry to meta/conf/distro/include/maintainers.inc file.
> > systemd-boot-native (/home/pokybuild/yocto-worker/oe-selftest-debian/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb)
> > 
> For updating maintainer, can I submit a change post patch acceptance?

No, your patches need to pass the tests before they can be merged.


> 
> > On 13/12/2023 17:27:47+0530, Viswanath Kraleti wrote:
> > > systemd-boot native recipe provides ukify tool to build
> > > UKI images for systemd-boot
> > > 
> > > Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
> > > ---
> > >   .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
> > >   1 file changed, 15 insertions(+)
> > >   create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> > > 
> > > diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> > > new file mode 100644
> > > index 0000000000..0cdd7e7045
> > > --- /dev/null
> > > +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> > > @@ -0,0 +1,15 @@
> > > +require systemd.inc
> > > +
> > > +inherit native
> > > +
> > > +RRECOMMENDS:${PN} += "python3-pefile-native"
> > > +
> > > +COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
> > > +
> > > +do_configure[noexec] = "1"
> > > +do_compile[noexec] = "1"
> > > +
> > > +do_install () {
> > > +       install -d ${D}${bindir}
> > > +       install -m 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
> > > +}
> > > -- 
> > > 2.25.1
> > > 
> > 
> > > 
> > > 
> > > 
> > 
> > 
> > 
> > 
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#192337): https://lists.openembedded.org/g/openembedded-core/message/192337
> > Mute This Topic: https://lists.openembedded.org/mt/103147679/5192326
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [quic_vkraleti@quicinc.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
new file mode 100644
index 0000000000..0cdd7e7045
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
@@ -0,0 +1,15 @@ 
+require systemd.inc
+
+inherit native
+
+RRECOMMENDS:${PN} += "python3-pefile-native"
+
+COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+       install -d ${D}${bindir}
+       install -m 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
+}