diff mbox series

[v2] strace: Disable bluetooth support by default

Message ID 20231213074323.2547894-1-yoann.congal@smile.fr
State Accepted, archived
Commit 5dbfeea1c90c4dab9291d27da5a7ed1706e2ac2e
Headers show
Series [v2] strace: Disable bluetooth support by default | expand

Commit Message

Yoann Congal Dec. 13, 2023, 7:43 a.m. UTC
The bluetooth support adds a bluez5 dependency (and,recursively, a lot
of other stuff). Disable it by default to avoid having to build all of
this when it is not needed.

This decrease the number of tasks run for a core-image-minimal build by
~1000 (-21%).

To re-enable bluetooth support in strace, add "bluez" to strace
PACKAGECONFIG. For example, in local.conf:
  PACKAGECONFIG:append:pn-strace = "bluez"

Fixes [YOCTO #15323]

Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
Suggested-by: Ross Burton <ross.burton@arm.com>
---
v1->v2:
* Fixed local.conf example (thanks Tim)
* Added Suggested-by: Ross (thanks Ross)
* Removed an extra empty line
---
 meta/recipes-devtools/strace/strace_6.6.bb | 4 ----
 1 file changed, 4 deletions(-)

Comments

Martin Jansa Dec. 13, 2023, 8:35 a.m. UTC | #1
There is missing leading space in suggested:
PACKAGECONFIG:append:pn-strace = "bluez"

On Wed, Dec 13, 2023 at 8:43 AM Yoann Congal <yoann.congal@smile.fr> wrote:

> The bluetooth support adds a bluez5 dependency (and,recursively, a lot
> of other stuff). Disable it by default to avoid having to build all of
> this when it is not needed.
>
> This decrease the number of tasks run for a core-image-minimal build by
> ~1000 (-21%).
>
> To re-enable bluetooth support in strace, add "bluez" to strace
> PACKAGECONFIG. For example, in local.conf:
>   PACKAGECONFIG:append:pn-strace = "bluez"
>
> Fixes [YOCTO #15323]
>
> Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
> Suggested-by: Ross Burton <ross.burton@arm.com>
> ---
> v1->v2:
> * Fixed local.conf example (thanks Tim)
> * Added Suggested-by: Ross (thanks Ross)
> * Removed an extra empty line
> ---
>  meta/recipes-devtools/strace/strace_6.6.bb | 4 ----
>  1 file changed, 4 deletions(-)
>
> diff --git a/meta/recipes-devtools/strace/strace_6.6.bb
> b/meta/recipes-devtools/strace/strace_6.6.bb
> index a3de7941cf..eeffe477b3 100644
> --- a/meta/recipes-devtools/strace/strace_6.6.bb
> +++ b/meta/recipes-devtools/strace/strace_6.6.bb
> @@ -22,10 +22,6 @@ inherit autotools ptest
>  # Not yet ported to rv32
>  COMPATIBLE_HOST:riscv32 = "null"
>
> -PACKAGECONFIG:class-target ??= "\
> -    ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}
> \
> -"
> -
>  PACKAGECONFIG[bluez] =
> "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
>  PACKAGECONFIG[libunwind] =
> "--with-libunwind,--without-libunwind,libunwind"
>
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192269):
> https://lists.openembedded.org/g/openembedded-core/message/192269
> Mute This Topic: https://lists.openembedded.org/mt/103145986/3617156
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> martin.jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Yoann Congal Dec. 13, 2023, 8:58 a.m. UTC | #2
Le 13/12/2023 à 09:35, Martin Jansa a écrit :
> There is missing leading space in suggested:
> PACKAGECONFIG:append:pn-strace = "bluez"

V3 sent. Thanks! 

> On Wed, Dec 13, 2023 at 8:43 AM Yoann Congal <yoann.congal@smile.fr <mailto:yoann.congal@smile.fr>> wrote:
> 
>     The bluetooth support adds a bluez5 dependency (and,recursively, a lot
>     of other stuff). Disable it by default to avoid having to build all of
>     this when it is not needed.
> 
>     This decrease the number of tasks run for a core-image-minimal build by
>     ~1000 (-21%).
> 
>     To re-enable bluetooth support in strace, add "bluez" to strace
>     PACKAGECONFIG. For example, in local.conf:
>       PACKAGECONFIG:append:pn-strace = "bluez"
> 
>     Fixes [YOCTO #15323]
> 
>     Signed-off-by: Yoann Congal <yoann.congal@smile.fr <mailto:yoann.congal@smile.fr>>
>     Suggested-by: Ross Burton <ross.burton@arm.com <mailto:ross.burton@arm.com>>
>     ---
>     v1->v2:
>     * Fixed local.conf example (thanks Tim)
>     * Added Suggested-by: Ross (thanks Ross)
>     * Removed an extra empty line
>     ---
>      meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb> | 4 ----
>      1 file changed, 4 deletions(-)
> 
>     diff --git a/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb> b/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb>
>     index a3de7941cf..eeffe477b3 100644
>     --- a/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb>
>     +++ b/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb>
>     @@ -22,10 +22,6 @@ inherit autotools ptest
>      # Not yet ported to rv32
>      COMPATIBLE_HOST:riscv32 = "null"
> 
>     -PACKAGECONFIG:class-target ??= "\
>     -    ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
>     -"
>     -
>      PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
>      PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
> 
>     -- 
>     2.30.2
> 
> 
>     -=-=-=-=-=-=-=-=-=-=-=-
>     Links: You receive all messages sent to this group.
>     View/Reply Online (#192269): https://lists.openembedded.org/g/openembedded-core/message/192269 <https://lists.openembedded.org/g/openembedded-core/message/192269>
>     Mute This Topic: https://lists.openembedded.org/mt/103145986/3617156 <https://lists.openembedded.org/mt/103145986/3617156>
>     Group Owner: openembedded-core+owner@lists.openembedded.org <mailto:openembedded-core%2Bowner@lists.openembedded.org>
>     Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub <https://lists.openembedded.org/g/openembedded-core/unsub> [martin.jansa@gmail.com <mailto:martin.jansa@gmail.com>]
>     -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/strace/strace_6.6.bb b/meta/recipes-devtools/strace/strace_6.6.bb
index a3de7941cf..eeffe477b3 100644
--- a/meta/recipes-devtools/strace/strace_6.6.bb
+++ b/meta/recipes-devtools/strace/strace_6.6.bb
@@ -22,10 +22,6 @@  inherit autotools ptest
 # Not yet ported to rv32
 COMPATIBLE_HOST:riscv32 = "null"
 
-PACKAGECONFIG:class-target ??= "\
-    ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
-"
-
 PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
 PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"