diff mbox series

[kirkstone] nativesdk-sdk-provides-dummy.bb: Update host tools for rust-cross-canadian

Message ID 20231211122613.2429111-1-Deepthi.Hemraj@windriver.com
State New, archived
Delegated to: Steve Sakoman
Headers show
Series [kirkstone] nativesdk-sdk-provides-dummy.bb: Update host tools for rust-cross-canadian | expand

Commit Message

Deepthi H Dec. 11, 2023, 12:26 p.m. UTC
From: Deepthi Hemraj <Deepthi.Hemraj@windriver.com>

[YOCTO #15082]
Packagegroup-rust-cross-canadian package requires rust-cross-canadian, but the necessary libstdc++.so.6(GLIBCXX_3.4.30)(64bit) library is missing.
The fix adds the libstdc++.so.6(GLIBCXX_3.4.30)(64bit) library requirement to the  SDK dummy package, resolving the dependency conflict.

Signed-off-by: Deepthi Hemraj <Deepthi.Hemraj@windriver.com>
---
 meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Randy MacLeod Dec. 11, 2023, 3:20 p.m. UTC | #1
On 2023-12-11 7:26 a.m., Deepthi.Hemraj@windriver.com wrote:
> From: Deepthi Hemraj<Deepthi.Hemraj@windriver.com>
>
> [YOCTO #15082]
> Packagegroup-rust-cross-canadian package requires rust-cross-canadian, but the necessary libstdc++.so.6(GLIBCXX_3.4.30)(64bit) library is missing.
> The fix adds the libstdc++.so.6(GLIBCXX_3.4.30)(64bit) library requirement to the  SDK dummy package, resolving the dependency conflict.
>
> Signed-off-by: Deepthi Hemraj<Deepthi.Hemraj@windriver.com>
> ---
>   meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb | 3 ++-
>   1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb b/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
> index 1d71f373a4..dc3ae1edaf 100644
> --- a/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
> +++ b/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
> @@ -10,7 +10,8 @@ DUMMYPROVIDES = "\
>       /usr/bin/env \
>       libGL.so()(64bit) \
>       libGL.so \
> -"
> +    libstdc++.so.6(GLIBCXX_3.4.30)(64bit) \
> +"
>   
>   require dummy-sdk-package.inc
>   

This doesn't seem right to me...

Does the problem happen on master?

I haven't tried it but I suspect we want to add something like:

nativesdk-libstdc++

to:

DEPENDS:append:class-nativesdk = " nativesdk-rust-llvm"

in the rust bb file.
Deepthi H Dec. 20, 2023, 1:13 p.m. UTC | #2
Hi Randy,

I tried adding nativesdk-libstdc++ to DEPENDS:append:class-nativesdk = " nativesdk-libstdc++" but the issue is still reproducing.

The nativesdk-libstdc++ is not having the GLIBCXX_3.4.30 symbols. Below cmd shows only GLIBCXX_3.4.29.
"strings /ala-lpggp31/dhemraj/kirkstone/5082/poky/build/tmp/work/x86_64-nativesdk-pokysdk-linux/rust-cross-canadian-x86-64/1.59.0-r0/recipe-sysroot/usr/lib/libstdc++.so.6 | grep GLIBCXX"

So, I added libstdc++.so.6 as dummy in <<meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb>>

Also in the gcc documentation (https://gcc.gnu.org/onlinedocs/libstdc++/manual/abi.html) I see that, libstdc++.so.6.0.30 is provided by GCC 12.1.0 but on kirkstone the gcc version is 11.4. I think libstdc++.so.6.0.30 is not supported.

Thank you,
Deepthi
Richard Purdie Dec. 20, 2023, 1:18 p.m. UTC | #3
On Wed, 2023-12-20 at 13:13 +0000, Hemraj, Deepthi via lists.openembedded.org wrote:
> I tried adding nativesdk-libstdc++ to DEPENDS:append:class-nativesdk
> = " nativesdk-libstdc++" but the issue is still reproducing.
>  
> The nativesdk-libstdc++ is not having the GLIBCXX_3.4.30 symbols.
> Below cmd shows only GLIBCXX_3.4.29.
> "strings /ala-
> lpggp31/dhemraj/kirkstone/5082/poky/build/tmp/work/x86_64-nativesdk-
> pokysdk-linux/rust-cross-canadian-x86-64/1.59.0-r0/recipe-
> sysroot/usr/lib/libstdc++.so.6 | grep GLIBCXX"
>  
> So, I added libstdc++.so.6 as dummy in <<meta/recipes-
> core/meta/nativesdk-sdk-provides-dummy.bb>>
>  
> Also in the gcc documentation
> (https://gcc.gnu.org/onlinedocs/libstdc++/manual/abi.html) I see
> that, libstdc++.so.6.0.30 is provided by GCC 12.1.0 but on kirkstone
> the gcc version is 11.4. I think libstdc++.so.6.0.30 is not
> supported.

That suggests that rust-cross-canadian isn't building against our own
libstdc++ but against the one from the host instead. nativesdk-gcc-
runtime (which from memory contains libstdc++) should be being used
rather than any host dependencies.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb b/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
index 1d71f373a4..dc3ae1edaf 100644
--- a/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
+++ b/meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb
@@ -10,7 +10,8 @@  DUMMYPROVIDES = "\
     /usr/bin/env \
     libGL.so()(64bit) \
     libGL.so \
-"
+    libstdc++.so.6(GLIBCXX_3.4.30)(64bit) \
+" 
 
 require dummy-sdk-package.inc