diff mbox series

subports: Use _GNU_SOURCE

Message ID 20231207143031.1790457-1-pidge@baylibre.com
State New
Headers show
Series subports: Use _GNU_SOURCE | expand

Commit Message

Eilís 'pidge' Ní Fhlannagáin Dec. 7, 2023, 2:30 p.m. UTC
[YOCTO #15074]

The syncfs probe in ports/unix/subports was failing if the compiler does not 
support implicit function declarations. syncfs is protected and requires 
_GNU_SOURCE, so the answer here is to pull it in.

Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>
---
 .../pseudo/files/syncfs-probe.patch           | 44 +++++++++++++++++++
 meta/recipes-devtools/pseudo/pseudo_git.bb    |  1 +
 2 files changed, 45 insertions(+)
 create mode 100644 meta/recipes-devtools/pseudo/files/syncfs-probe.patch
diff mbox series

Patch

diff --git a/meta/recipes-devtools/pseudo/files/syncfs-probe.patch b/meta/recipes-devtools/pseudo/files/syncfs-probe.patch
new file mode 100644
index 00000000000..23f01673e3c
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/files/syncfs-probe.patch
@@ -0,0 +1,44 @@ 
+From e38b1fec2eb4a5dcefafdab7f1a240966f3632f1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Eil=C3=ADs=20=27pidge=27=20N=C3=AD=20Fhlannag=C3=A1in?=
+ <pidge@baylibre.com>
+Date: Wed, 6 Dec 2023 13:00:29 +0000
+Subject: [PATCH] subports: Add _GNU_SOURCE
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+[YOCTO #15074]
+
+The syncfs probe in ports/unix/subports was failing if the compiler does not 
+support implicit function declarations. syncfs is protected and requires 
+_GNU_SOURCE, so the answer here is to pull it in.
+
+Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>
+
+---
+Upstream-Status: Pending
+
+ ports/unix/subports | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/ports/unix/subports b/ports/unix/subports
+index e41b036..bd5a2f6 100755
+--- a/ports/unix/subports
++++ b/ports/unix/subports
+@@ -1,11 +1,13 @@
+ #!/bin/sh
+ cat > dummy.c <<EOF
++#define _GNU_SOURCE
+ #include <unistd.h>
+ int main(void) {
+ 	syncfs(0);
+ 	return 0;
+ }
+ EOF
++
+ if ${CC} -o dummy dummy.c > /dev/null 2>&1; then
+ 	echo "unix/syncfs"
+ fi
+-- 
+2.34.1
+
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 4a894ebdd0b..3ffbc311b74 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -2,6 +2,7 @@  require pseudo.inc
 
 SRC_URI = "git://git.yoctoproject.org/pseudo;branch=master;protocol=https \
            file://0001-configure-Prune-PIE-flags.patch \
+           file://syncfs-probe.patch \
            file://glibc238.patch \
            file://fallback-passwd \
            file://fallback-group \