diff mbox series

musl: Update to latest tip of trunk

Message ID 20231202065754.3646660-1-raj.khem@gmail.com
State Accepted, archived
Commit da8fcd0155f1cf3394d0886c940bee77669009d4
Headers show
Series musl: Update to latest tip of trunk | expand

Commit Message

Khem Raj Dec. 2, 2023, 6:57 a.m. UTC
* f314e133 mntent: fields are delimited only by tabs or spaces, not general whitespace
* ee1d39bc mntent: unescape octal sequences
* e17b9d74 ldso: fix TLSDESC addend processing on archs with backwards descriptors
* 039d3c34 ldso: convert TLSDESC_BACKWARDS from "#ifdef" to "if" logic
* 7b6a6516 byte-based printf family: emit a nul byte for %lc with argument zero
* 8c086e76 remove arbitrary limit from dns result parsing
* 2265a4c9 pass AT_NO_AUTOMOUNT when emulating fstatat via statx
* 2d84486a __year_to_secs: fix dangling pointer
* c5459df1 timer_create: volatile static -> static volatile
* 7bb11f75 ensure valid setxid return value in an unexpected error case
* 7f3a2925 synccall: add separate exit_sem to fix thread release logic bug
* 5baf2d92 ldso: use __ehdr_start if available to locate its own ELF headers
* 725e17ed remove non-prototype declaration of basename from string.h
* 6be76895 elf.h: add typedefs for Elf64_Relr and Elf32_Relr

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Dec. 3, 2023, 4:24 p.m. UTC | #1
There are two issues with this

1. SRC_URI needs to fall back to using git protocol
2. basename has been removed from string.h which causes few recipes to build [1]

I will see to work though them before we apply this patch

[1] https://errors.yoctoproject.org/Errors/Build/175430/

On Fri, Dec 1, 2023 at 10:57 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> * f314e133 mntent: fields are delimited only by tabs or spaces, not general whitespace
> * ee1d39bc mntent: unescape octal sequences
> * e17b9d74 ldso: fix TLSDESC addend processing on archs with backwards descriptors
> * 039d3c34 ldso: convert TLSDESC_BACKWARDS from "#ifdef" to "if" logic
> * 7b6a6516 byte-based printf family: emit a nul byte for %lc with argument zero
> * 8c086e76 remove arbitrary limit from dns result parsing
> * 2265a4c9 pass AT_NO_AUTOMOUNT when emulating fstatat via statx
> * 2d84486a __year_to_secs: fix dangling pointer
> * c5459df1 timer_create: volatile static -> static volatile
> * 7bb11f75 ensure valid setxid return value in an unexpected error case
> * 7f3a2925 synccall: add separate exit_sem to fix thread release logic bug
> * 5baf2d92 ldso: use __ehdr_start if available to locate its own ELF headers
> * 725e17ed remove non-prototype declaration of basename from string.h
> * 6be76895 elf.h: add typedefs for Elf64_Relr and Elf32_Relr
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-core/musl/musl_git.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
> index 7dd949ffafd..87ac1641af1 100644
> --- a/meta/recipes-core/musl/musl_git.bb
> +++ b/meta/recipes-core/musl/musl_git.bb
> @@ -4,7 +4,7 @@
>  require musl.inc
>  inherit linuxloader
>
> -SRCREV = "79bdacff83a6bd5b70ff5ae5eb8b6de82c2f7c30"
> +SRCREV = "f314e133929b6379eccc632bef32eaebb66a7335"
>
>  BASEVER = "1.2.4"
>
> --
> 2.43.0
>
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 7dd949ffafd..87ac1641af1 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "79bdacff83a6bd5b70ff5ae5eb8b6de82c2f7c30"
+SRCREV = "f314e133929b6379eccc632bef32eaebb66a7335"
 
 BASEVER = "1.2.4"