diff mbox series

[6/6] llvm: Upgrade to 17.0.6

Message ID 20231201183356.311137-6-raj.khem@gmail.com
State Accepted, archived
Commit eab3ce3184d66a98fe9f5992c462552dfc89397f
Headers show
Series [v12,1/6] vte: upgrade 0.72.2 -> 0.74.0 | expand

Commit Message

Khem Raj Dec. 1, 2023, 6:33 p.m. UTC
Bring in these changes

* 6009708b4367 Revert "[runtimes] Add missing test dependencies to check-all (#72955)"
* 04caadc61fa2 [Driver] Enable __float128 support on X86 on FreeBSD / NetBSD (#72788)
* e919a83f96fe eliminate python SyntaxWarnings from check-all output.
* f6c231c15ec8 [clang-format] Fix crashes in AlignArrayOfStructures (#72520)
* f74f3e6f58d3 [clang] Fix sorting module headers (#73146)
* 7e30ce9528d9 [JITLink][aarch32] Change writeRegister's return type to void.
* 03373fd9cb6c [CMake] Support building shared library for NetBSD
* 21af3b62b632 workflows/release-binaries: Do a preliminary build to fill ccache (#72576)
* 201faeca595e Add RV64 constraint to SRLIW (#69416)
* e957e6dcb29d [runtimes] Add missing test dependencies to check-all (#72955)
* f8575ff46f89 [clang-format] Fix a bug in aligning comments above PPDirective (#72791)
* a71237b9f67f [clangd] Avoid null result in FindRecordTypeAt()
* 308c816de5a4 Bump version to 17.0.6
* 442401f7c0ca remove tests from bad merge
* 76c7e0e1e2d1 Use the correct namespace for looking up matching operator!= (#68922)
* b5cbb35408a3 [libc++] Use correct size for deallocation of arrays in shared_ptr (#68233)
* e6de86cb9ef8 Revert "Reland [clang] Canonicalize system headers in dependency file when -canonical-prefixes" (#71697)
* bb66d8f8f73b [clang][WebAssembly] Link crt1 even in case of -shared

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Alexandre Belloni Dec. 1, 2023, 11:27 p.m. UTC | #1
This breaks:

https://autobuilder.yoctoproject.org/typhoon/#/builders/106/builds/7190/steps/11/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/146/builds/960/steps/12/logs/stdio

On 01/12/2023 10:33:54-0800, Khem Raj wrote:
> Bring in these changes
> 
> * 6009708b4367 Revert "[runtimes] Add missing test dependencies to check-all (#72955)"
> * 04caadc61fa2 [Driver] Enable __float128 support on X86 on FreeBSD / NetBSD (#72788)
> * e919a83f96fe eliminate python SyntaxWarnings from check-all output.
> * f6c231c15ec8 [clang-format] Fix crashes in AlignArrayOfStructures (#72520)
> * f74f3e6f58d3 [clang] Fix sorting module headers (#73146)
> * 7e30ce9528d9 [JITLink][aarch32] Change writeRegister's return type to void.
> * 03373fd9cb6c [CMake] Support building shared library for NetBSD
> * 21af3b62b632 workflows/release-binaries: Do a preliminary build to fill ccache (#72576)
> * 201faeca595e Add RV64 constraint to SRLIW (#69416)
> * e957e6dcb29d [runtimes] Add missing test dependencies to check-all (#72955)
> * f8575ff46f89 [clang-format] Fix a bug in aligning comments above PPDirective (#72791)
> * a71237b9f67f [clangd] Avoid null result in FindRecordTypeAt()
> * 308c816de5a4 Bump version to 17.0.6
> * 442401f7c0ca remove tests from bad merge
> * 76c7e0e1e2d1 Use the correct namespace for looking up matching operator!= (#68922)
> * b5cbb35408a3 [libc++] Use correct size for deallocation of arrays in shared_ptr (#68233)
> * e6de86cb9ef8 Revert "Reland [clang] Canonicalize system headers in dependency file when -canonical-prefixes" (#71697)
> * bb66d8f8f73b [clang][WebAssembly] Link crt1 even in case of -shared
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
> index de8d4116868..9a88549260a 100644
> --- a/meta/recipes-devtools/llvm/llvm_git.bb
> +++ b/meta/recipes-devtools/llvm/llvm_git.bb
> @@ -14,14 +14,14 @@ RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
>  
>  inherit cmake pkgconfig
>  
> -PV = "17.0.5"
> +PV = "17.0.6"
>  
>  MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
>  
>  LLVM_RELEASE = "${PV}"
>  
>  BRANCH = "release/${MAJOR_VERSION}.x"
> -SRCREV = "98bfdac5ce82d1679f8af9a57501471812ab68d7"
> +SRCREV = "6009708b4367171ccdbf4b5905cb6a803753fe18"
>  SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
>             file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
>             file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
> -- 
> 2.43.0
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#191682): https://lists.openembedded.org/g/openembedded-core/message/191682
> Mute This Topic: https://lists.openembedded.org/mt/102921840/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexandre Belloni Dec. 1, 2023, 11:55 p.m. UTC | #2
On 02/12/2023 00:27:39+0100, Alexandre Belloni via lists.openembedded.org wrote:
> This breaks:
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/106/builds/7190/steps/11/logs/stdio

Actually, this one reproduced without the patch

> https://autobuilder.yoctoproject.org/typhoon/#/builders/146/builds/960/steps/12/logs/stdio

But not this one.

> 
> On 01/12/2023 10:33:54-0800, Khem Raj wrote:
> > Bring in these changes
> > 
> > * 6009708b4367 Revert "[runtimes] Add missing test dependencies to check-all (#72955)"
> > * 04caadc61fa2 [Driver] Enable __float128 support on X86 on FreeBSD / NetBSD (#72788)
> > * e919a83f96fe eliminate python SyntaxWarnings from check-all output.
> > * f6c231c15ec8 [clang-format] Fix crashes in AlignArrayOfStructures (#72520)
> > * f74f3e6f58d3 [clang] Fix sorting module headers (#73146)
> > * 7e30ce9528d9 [JITLink][aarch32] Change writeRegister's return type to void.
> > * 03373fd9cb6c [CMake] Support building shared library for NetBSD
> > * 21af3b62b632 workflows/release-binaries: Do a preliminary build to fill ccache (#72576)
> > * 201faeca595e Add RV64 constraint to SRLIW (#69416)
> > * e957e6dcb29d [runtimes] Add missing test dependencies to check-all (#72955)
> > * f8575ff46f89 [clang-format] Fix a bug in aligning comments above PPDirective (#72791)
> > * a71237b9f67f [clangd] Avoid null result in FindRecordTypeAt()
> > * 308c816de5a4 Bump version to 17.0.6
> > * 442401f7c0ca remove tests from bad merge
> > * 76c7e0e1e2d1 Use the correct namespace for looking up matching operator!= (#68922)
> > * b5cbb35408a3 [libc++] Use correct size for deallocation of arrays in shared_ptr (#68233)
> > * e6de86cb9ef8 Revert "Reland [clang] Canonicalize system headers in dependency file when -canonical-prefixes" (#71697)
> > * bb66d8f8f73b [clang][WebAssembly] Link crt1 even in case of -shared
> > 
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >  meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
> > index de8d4116868..9a88549260a 100644
> > --- a/meta/recipes-devtools/llvm/llvm_git.bb
> > +++ b/meta/recipes-devtools/llvm/llvm_git.bb
> > @@ -14,14 +14,14 @@ RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
> >  
> >  inherit cmake pkgconfig
> >  
> > -PV = "17.0.5"
> > +PV = "17.0.6"
> >  
> >  MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
> >  
> >  LLVM_RELEASE = "${PV}"
> >  
> >  BRANCH = "release/${MAJOR_VERSION}.x"
> > -SRCREV = "98bfdac5ce82d1679f8af9a57501471812ab68d7"
> > +SRCREV = "6009708b4367171ccdbf4b5905cb6a803753fe18"
> >  SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
> >             file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
> >             file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
> > -- 
> > 2.43.0
> > 
> 
> > 
> > 
> > 
> 
> 
> -- 
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#191693): https://lists.openembedded.org/g/openembedded-core/message/191693
> Mute This Topic: https://lists.openembedded.org/mt/102921840/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Dec. 2, 2023, 12:03 a.m. UTC | #3
On Fri, Dec 1, 2023 at 3:55 PM Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> On 02/12/2023 00:27:39+0100, Alexandre Belloni via lists.openembedded.org wrote:
> > This breaks:
> >
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/106/builds/7190/steps/11/logs/stdio
>
> Actually, this one reproduced without the patch
>

how is llvm used by rust ?

> > https://autobuilder.yoctoproject.org/typhoon/#/builders/146/builds/960/steps/12/logs/stdio
>
> But not this one.
>
> >
> > On 01/12/2023 10:33:54-0800, Khem Raj wrote:
> > > Bring in these changes
> > >
> > > * 6009708b4367 Revert "[runtimes] Add missing test dependencies to check-all (#72955)"
> > > * 04caadc61fa2 [Driver] Enable __float128 support on X86 on FreeBSD / NetBSD (#72788)
> > > * e919a83f96fe eliminate python SyntaxWarnings from check-all output.
> > > * f6c231c15ec8 [clang-format] Fix crashes in AlignArrayOfStructures (#72520)
> > > * f74f3e6f58d3 [clang] Fix sorting module headers (#73146)
> > > * 7e30ce9528d9 [JITLink][aarch32] Change writeRegister's return type to void.
> > > * 03373fd9cb6c [CMake] Support building shared library for NetBSD
> > > * 21af3b62b632 workflows/release-binaries: Do a preliminary build to fill ccache (#72576)
> > > * 201faeca595e Add RV64 constraint to SRLIW (#69416)
> > > * e957e6dcb29d [runtimes] Add missing test dependencies to check-all (#72955)
> > > * f8575ff46f89 [clang-format] Fix a bug in aligning comments above PPDirective (#72791)
> > > * a71237b9f67f [clangd] Avoid null result in FindRecordTypeAt()
> > > * 308c816de5a4 Bump version to 17.0.6
> > > * 442401f7c0ca remove tests from bad merge
> > > * 76c7e0e1e2d1 Use the correct namespace for looking up matching operator!= (#68922)
> > > * b5cbb35408a3 [libc++] Use correct size for deallocation of arrays in shared_ptr (#68233)
> > > * e6de86cb9ef8 Revert "Reland [clang] Canonicalize system headers in dependency file when -canonical-prefixes" (#71697)
> > > * bb66d8f8f73b [clang][WebAssembly] Link crt1 even in case of -shared
> > >
> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > ---
> > >  meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
> > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > >
> > > diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
> > > index de8d4116868..9a88549260a 100644
> > > --- a/meta/recipes-devtools/llvm/llvm_git.bb
> > > +++ b/meta/recipes-devtools/llvm/llvm_git.bb
> > > @@ -14,14 +14,14 @@ RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
> > >
> > >  inherit cmake pkgconfig
> > >
> > > -PV = "17.0.5"
> > > +PV = "17.0.6"
> > >
> > >  MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
> > >
> > >  LLVM_RELEASE = "${PV}"
> > >
> > >  BRANCH = "release/${MAJOR_VERSION}.x"
> > > -SRCREV = "98bfdac5ce82d1679f8af9a57501471812ab68d7"
> > > +SRCREV = "6009708b4367171ccdbf4b5905cb6a803753fe18"
> > >  SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
> > >             file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
> > >             file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
> > > --
> > > 2.43.0
> > >
> >
> > >
> > >
> > >
> >
> >
> > --
> > Alexandre Belloni, co-owner and COO, Bootlin
> > Embedded Linux and Kernel engineering
> > https://bootlin.com
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#191693): https://lists.openembedded.org/g/openembedded-core/message/191693
> > Mute This Topic: https://lists.openembedded.org/mt/102921840/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Khem Raj Dec. 2, 2023, 12:10 a.m. UTC | #4
On Fri, Dec 1, 2023 at 4:03 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Fri, Dec 1, 2023 at 3:55 PM Alexandre Belloni
> <alexandre.belloni@bootlin.com> wrote:
> >
> > On 02/12/2023 00:27:39+0100, Alexandre Belloni via lists.openembedded.org wrote:
> > > This breaks:
> > >
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/106/builds/7190/steps/11/logs/stdio
> >
> > Actually, this one reproduced without the patch
> >
>
> how is llvm used by rust ?

The problem was in the rust patch for x32, I have sent a v2 please use
that patch with rest of the series.

>
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/146/builds/960/steps/12/logs/stdio
> >
> > But not this one.
> >
> > >
> > > On 01/12/2023 10:33:54-0800, Khem Raj wrote:
> > > > Bring in these changes
> > > >
> > > > * 6009708b4367 Revert "[runtimes] Add missing test dependencies to check-all (#72955)"
> > > > * 04caadc61fa2 [Driver] Enable __float128 support on X86 on FreeBSD / NetBSD (#72788)
> > > > * e919a83f96fe eliminate python SyntaxWarnings from check-all output.
> > > > * f6c231c15ec8 [clang-format] Fix crashes in AlignArrayOfStructures (#72520)
> > > > * f74f3e6f58d3 [clang] Fix sorting module headers (#73146)
> > > > * 7e30ce9528d9 [JITLink][aarch32] Change writeRegister's return type to void.
> > > > * 03373fd9cb6c [CMake] Support building shared library for NetBSD
> > > > * 21af3b62b632 workflows/release-binaries: Do a preliminary build to fill ccache (#72576)
> > > > * 201faeca595e Add RV64 constraint to SRLIW (#69416)
> > > > * e957e6dcb29d [runtimes] Add missing test dependencies to check-all (#72955)
> > > > * f8575ff46f89 [clang-format] Fix a bug in aligning comments above PPDirective (#72791)
> > > > * a71237b9f67f [clangd] Avoid null result in FindRecordTypeAt()
> > > > * 308c816de5a4 Bump version to 17.0.6
> > > > * 442401f7c0ca remove tests from bad merge
> > > > * 76c7e0e1e2d1 Use the correct namespace for looking up matching operator!= (#68922)
> > > > * b5cbb35408a3 [libc++] Use correct size for deallocation of arrays in shared_ptr (#68233)
> > > > * e6de86cb9ef8 Revert "Reland [clang] Canonicalize system headers in dependency file when -canonical-prefixes" (#71697)
> > > > * bb66d8f8f73b [clang][WebAssembly] Link crt1 even in case of -shared
> > > >
> > > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > > ---
> > > >  meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
> > > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > > >
> > > > diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
> > > > index de8d4116868..9a88549260a 100644
> > > > --- a/meta/recipes-devtools/llvm/llvm_git.bb
> > > > +++ b/meta/recipes-devtools/llvm/llvm_git.bb
> > > > @@ -14,14 +14,14 @@ RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
> > > >
> > > >  inherit cmake pkgconfig
> > > >
> > > > -PV = "17.0.5"
> > > > +PV = "17.0.6"
> > > >
> > > >  MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
> > > >
> > > >  LLVM_RELEASE = "${PV}"
> > > >
> > > >  BRANCH = "release/${MAJOR_VERSION}.x"
> > > > -SRCREV = "98bfdac5ce82d1679f8af9a57501471812ab68d7"
> > > > +SRCREV = "6009708b4367171ccdbf4b5905cb6a803753fe18"
> > > >  SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
> > > >             file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
> > > >             file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
> > > > --
> > > > 2.43.0
> > > >
> > >
> > > >
> > > >
> > > >
> > >
> > >
> > > --
> > > Alexandre Belloni, co-owner and COO, Bootlin
> > > Embedded Linux and Kernel engineering
> > > https://bootlin.com
> >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#191693): https://lists.openembedded.org/g/openembedded-core/message/191693
> > > Mute This Topic: https://lists.openembedded.org/mt/102921840/3617179
> > > Group Owner: openembedded-core+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
> >
> >
> > --
> > Alexandre Belloni, co-owner and COO, Bootlin
> > Embedded Linux and Kernel engineering
> > https://bootlin.com
diff mbox series

Patch

diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index de8d4116868..9a88549260a 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -14,14 +14,14 @@  RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
 
 inherit cmake pkgconfig
 
-PV = "17.0.5"
+PV = "17.0.6"
 
 MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
 
 LLVM_RELEASE = "${PV}"
 
 BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "98bfdac5ce82d1679f8af9a57501471812ab68d7"
+SRCREV = "6009708b4367171ccdbf4b5905cb6a803753fe18"
 SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
            file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
            file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \