diff mbox series

[PATCHv2,07/12] perf: drop PE, PR from /usr/src/debug paths

Message ID 20231116224836.2696913-7-martin.jansa@gmail.com
State Accepted, archived
Commit 4cac17c7de064b6d4e5d7dd252c5b4c610a0c6ee
Headers show
Series [PATCHv4,01/12] bitbake.conf: drop ${PE} and ${PR} from -f{file,macro,debug}-prefix-map | expand

Commit Message

Martin Jansa Nov. 16, 2023, 10:48 p.m. UTC
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
---
 meta/recipes-kernel/perf/perf.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index a90acd55ef..32882afdf4 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -98,7 +98,7 @@  EXTRA_OEMAKE = '\
     AR="${AR}" \
     LD="${LD}" \
     EXTRA_CFLAGS="-ldw -I${S}" \
-    YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
+    YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \
     EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
     perfexecdir=${libexecdir} \
     NO_GTK2=1 \
@@ -405,7 +405,7 @@  PACKAGESPLITFUNCS =+ "perf_fix_sources"
 perf_fix_sources () {
 	for f in util/parse-events-flex.h util/parse-events-flex.c util/pmu-flex.c \
 			util/pmu-flex.h util/expr-flex.h util/expr-flex.c; do
-		f=${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/$f
+		f=${PKGD}${TARGET_DBGSRC_DIR}/$f
 		if [ -e $f ]; then
 			sed -i -e 's#${S}/##g' $f
 		fi