diff mbox series

[meta-oe,v2,1/4] systemd: use nonarch libdir for tmpfiles.d

Message ID 20231116115457.1462082-2-lukas.funke-oss@weidmueller.com
State New
Headers show
Series tmpfiles.d: use nonarch libdir | expand

Commit Message

Lukas Funke Nov. 16, 2023, 11:54 a.m. UTC
From: Malte Schmidt <malte.schmidt@weidmueller.com>

The documentation of systemd states that /etc/tmpfiles.d should be
reserved for the local administrator and packages should put their files
in /usr/lib/tmpfiles.d [1].

[1] https://www.freedesktop.org/software/systemd/man/tmpfiles.d.html

Signed-off-by: Malte Schmidt <malte.schmidt@weidmueller.com>
Signed-off-by: Stefan Herbrechtsmeier <stefan.herbrechtsmeier@weidmueller.com>
Signed-off-by: Lukas Funke <lukas.funke@weidmueller.com>
---
 meta/recipes-core/systemd/systemd_254.4.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Jose Quaresma Nov. 16, 2023, 12:13 p.m. UTC | #1
<lukas.funke-oss@weidmueller.com> escreveu no dia quinta, 16/11/2023 à(s)
11:55:

> From: Malte Schmidt <malte.schmidt@weidmueller.com>
>
> The documentation of systemd states that /etc/tmpfiles.d should be
> reserved for the local administrator and packages should put their files
> in /usr/lib/tmpfiles.d [1].
>
> [1] https://www.freedesktop.org/software/systemd/man/tmpfiles.d.html
>
> Signed-off-by: Malte Schmidt <malte.schmidt@weidmueller.com>
> Signed-off-by: Stefan Herbrechtsmeier <
> stefan.herbrechtsmeier@weidmueller.com>
> Signed-off-by: Lukas Funke <lukas.funke@weidmueller.com>
> ---
>  meta/recipes-core/systemd/systemd_254.4.bb | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/meta/recipes-core/systemd/systemd_254.4.bb
> b/meta/recipes-core/systemd/systemd_254.4.bb
> index cc0e29fdd2..6d71fbaba2 100644
> --- a/meta/recipes-core/systemd/systemd_254.4.bb
> +++ b/meta/recipes-core/systemd/systemd_254.4.bb
> @@ -282,12 +282,12 @@ do_install() {
>         [ ! -e ${D}/${base_sbindir}/udevd ] && ln -s
> ${rootlibexecdir}/systemd/systemd-udevd ${D}/${base_sbindir}/udevd
>
>         install -d ${D}${sysconfdir}/udev/rules.d/
> -       install -d ${D}${sysconfdir}/tmpfiles.d
> +       install -d ${D}${nonarch_libdir}/tmpfiles.d
>         for rule in $(find ${WORKDIR} -maxdepth 1 -type f -name
> "*.rules"); do
>                 install -m 0644 $rule ${D}${sysconfdir}/udev/rules.d/
>         done
>
> -       install -m 0644 ${WORKDIR}/00-create-volatile.conf
> ${D}${sysconfdir}/tmpfiles.d/
> +       install -m 0644 ${WORKDIR}/00-create-volatile.conf
> ${D}${exec_prefix}/lib/tmpfiles.d/
>

${nonarch_libdir} still missing there.


>
>         if
> ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
>                 install -d ${D}${sysconfdir}/init.d
> --
> 2.30.2
>
>
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
index cc0e29fdd2..6d71fbaba2 100644
--- a/meta/recipes-core/systemd/systemd_254.4.bb
+++ b/meta/recipes-core/systemd/systemd_254.4.bb
@@ -282,12 +282,12 @@  do_install() {
 	[ ! -e ${D}/${base_sbindir}/udevd ] && ln -s ${rootlibexecdir}/systemd/systemd-udevd ${D}/${base_sbindir}/udevd
 
 	install -d ${D}${sysconfdir}/udev/rules.d/
-	install -d ${D}${sysconfdir}/tmpfiles.d
+	install -d ${D}${nonarch_libdir}/tmpfiles.d
 	for rule in $(find ${WORKDIR} -maxdepth 1 -type f -name "*.rules"); do
 		install -m 0644 $rule ${D}${sysconfdir}/udev/rules.d/
 	done
 
-	install -m 0644 ${WORKDIR}/00-create-volatile.conf ${D}${sysconfdir}/tmpfiles.d/
+	install -m 0644 ${WORKDIR}/00-create-volatile.conf ${D}${exec_prefix}/lib/tmpfiles.d/
 
 	if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
 		install -d ${D}${sysconfdir}/init.d