diff mbox series

debianutils: Fix warnings

Message ID 20231107091722.1299842-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 9f8d3438530abceabdfd03d2ff2157bb79e4e034
Headers show
Series debianutils: Fix warnings | expand

Commit Message

Richard Purdie Nov. 7, 2023, 9:17 a.m. UTC
In the recent upgrade, which started to be installed as which.debianutils and the man
page was also renamed. Update the recipe to remove the now unneeded man page alternatives
and rename the binary to match what the code expects. This avoids warnings like:

WARNING: debianutils-5.14-r0 do_package: debianutils: alternative target (/usr/share/man/man1/which.1 or /usr/share/man/man1/which.1.debianutils) does not exist, skipping...
WARNING: debianutils-5.14-r0 do_package: debianutils: NOT adding alternative provide /usr/share/man/man1/which.1: /usr/share/man/man1/which.1.debianutils does not exist
WARNING: debianutils-5.14-r0 do_package: debianutils: alt_link == alt_target: /usr/share/man/man1/which.1 == /usr/share/man/man1/which.1

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-support/debianutils/debianutils_5.14.bb | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-support/debianutils/debianutils_5.14.bb b/meta/recipes-support/debianutils/debianutils_5.14.bb
index f6ca8a6fdda..deec8d1fe84 100644
--- a/meta/recipes-support/debianutils/debianutils_5.14.bb
+++ b/meta/recipes-support/debianutils/debianutils_5.14.bb
@@ -31,6 +31,7 @@  do_install:append() {
             mv ${D}${bindir}/$app ${D}${base_bindir}/$app
         done
     fi
+    mv ${D}${bindir}/which.debianutils ${D}${bindir}/which
 }
 
 # Note that we package the update-alternatives name.
@@ -47,9 +48,6 @@  ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog which"
 ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
 ALTERNATIVE:${PN}-run-parts = "run-parts"
 
-ALTERNATIVE:${PN}-doc = "which.1"
-ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
-
 ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"
 ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
 ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"