diff mbox series

systemd: Make libnss-mymachines conditional upon packageconfig

Message ID 20231106170934.3738696-1-raj.khem@gmail.com
State Accepted, archived
Commit 40f2e5776ebf6cf93694d05189488e8448767b3a
Headers show
Series systemd: Make libnss-mymachines conditional upon packageconfig | expand

Commit Message

Khem Raj Nov. 6, 2023, 5:09 p.m. UTC
nss-mymachines packageconfig controls this features therefore add this
dependency only when it is enabled.

Fixes
    ERROR: systemd-1_254.4-r0 do_package_qa: QA Issue: systemd-container rdepends on libnss-mymachines, but it isn't a build dependency? [build-deps]

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Florian Wickert <fw@ferncast.de>
---
 meta/recipes-core/systemd/systemd_254.4.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Jose Quaresma Nov. 6, 2023, 5:56 p.m. UTC | #1
Khem Raj <raj.khem@gmail.com> escreveu no dia segunda, 6/11/2023 à(s) 17:09:

> nss-mymachines packageconfig controls this features therefore add this
> dependency only when it is enabled.
>
> Fixes
>     ERROR: systemd-1_254.4-r0 do_package_qa: QA Issue: systemd-container
> rdepends on libnss-mymachines, but it isn't a build dependency? [build-deps]
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Florian Wickert <fw@ferncast.de>
> ---
>  meta/recipes-core/systemd/systemd_254.4.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/systemd/systemd_254.4.bb
> b/meta/recipes-core/systemd/systemd_254.4.bb
> index 8a8ff545995..f22e5bfd059 100644
> --- a/meta/recipes-core/systemd/systemd_254.4.bb
> +++ b/meta/recipes-core/systemd/systemd_254.4.bb
> @@ -542,7 +542,7 @@ FILES:${PN}-container =
> "${sysconfdir}/dbus-1/system.d/org.freedesktop.import1.c
>
> ${datadir}/polkit-1/actions/org.freedesktop.machine1.policy \
>                          "
>
> -RDEPENDS:${PN}-container = "libnss-mymachines"
> +$RDEPENDS:${PN}-container = "{@bb.utils.contains('PACKAGECONFIG',
> 'nss-mymachines', 'libnss-mymachines', '', d)}"
>

extra $ nitpick.


>
>  # "machinectl import-tar" uses "tar --numeric-owner", not supported by
> busybox.
>  RRECOMMENDS:${PN}-container += "\
> --
> 2.42.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#190239):
> https://lists.openembedded.org/g/openembedded-core/message/190239
> Mute This Topic: https://lists.openembedded.org/mt/102424819/5052612
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
index 8a8ff545995..f22e5bfd059 100644
--- a/meta/recipes-core/systemd/systemd_254.4.bb
+++ b/meta/recipes-core/systemd/systemd_254.4.bb
@@ -542,7 +542,7 @@  FILES:${PN}-container = "${sysconfdir}/dbus-1/system.d/org.freedesktop.import1.c
                          ${datadir}/polkit-1/actions/org.freedesktop.machine1.policy \
                         "
 
-RDEPENDS:${PN}-container = "libnss-mymachines"
+$RDEPENDS:${PN}-container = "{@bb.utils.contains('PACKAGECONFIG', 'nss-mymachines', 'libnss-mymachines', '', d)}"
 
 # "machinectl import-tar" uses "tar --numeric-owner", not supported by busybox.
 RRECOMMENDS:${PN}-container += "\