diff mbox series

llvm: Upgrade to 17.0.4 release

Message ID 20231103022552.979709-1-raj.khem@gmail.com
State Accepted, archived
Commit 198f10d12eea50942acb60cdf8c7bc0700065df1
Headers show
Series llvm: Upgrade to 17.0.4 release | expand

Commit Message

Khem Raj Nov. 3, 2023, 2:25 a.m. UTC
Brings following changes/fixes

* 309d55140c46 [AArch64][GlobalISel] Fix incorrect ABI when tail call not supported (#70215)
* 9477268e4247 [AArch64] Add test for #70207 (NFC)
* c2eab59e622c [GVN] Fix use-after-free in load PRE with select available value (#69314)
* 586481468a07 [clang-tidy] Fix crash in modernize-use-trailing-return-type (#70709)
* 9d0ca259eed6 [OpenMP] Fix building for 32-bit DragonFly, NetBSD, OpenBSD (#70527)
* a8046f72bfb3 [OpenMP] record-replay use static-cast  (#70516)
* 12bbcd627f60 [flang] Add comdats to functions with linkonce linkage (#66516)
* bdb1553c7639 [mlir] Add pass to add comdat to all linkonce functions (#65270)
* 3347c8441588 Update release note for the fix
* f6fb6a996c7f [clang][ExprConst] Fix crash on uninitialized array subobject (#67817)
* 8c8abe6b93c0 [RISCV] Correct copyPhysReg for GPRPF64. (#70419)
* 615beaec04f9 [SVE] Fix incorrect offset calculation when rewriting an instruction's frame index. (#70315)
* bb29e1ead22f [MemCpyOpt] Combine alias metadatas when replacing byval arguments (#70580)
* 2b82ec7947fe [OpenMP] Use the more appropriate function to retrieve the thread id on OpenBSD (#65553)
* 8909a24d0af1 [libc++] Encode additional ODR-affecting properties in the ABI tag (#69669)
* e9dcc15f514a [AArch64] Prevent argument promotion of vector with size > 128 bits (#70034)
* 4b7f4152a8d1 [LoongArch] Implement COPY instruction between CFRs (#69300)
* fb62a201a199 Revert "[clang-format] Fix align consecutive declarations over function pointers"
* 1f6d35b36681 Fix tests for c23 <-> c2x
* 030d68ef2cd7 Fix a c23 -> c2x think-o
* 2a41d978b4fa [C23] Use thread_local semantics (#70107)
* afbe3549af4d [clangd] Disable crashy unchecked-optional-access tidy check (#69427)
* 7f790f9a39e3 [ConstraintElim] Don't decompose values wider than 64 bits (#68803)
* a1c67ffd0a1f [ConstraintElim] Add test for #68751 (NFC)
* ef50a367e3d5 [mlir] Avoid including <alloca.h> on DragonFly
* a7101379d75e [LVI][CVP] Treat undef like a full range on abs(x, false) (#68711)
* aa03fba83b17 [libcxx] [test] Add a test parameter for disabling memory intensive tests (#68214)
* 71f408bc3623 workflows/release-tasks: Fix release note artifact upload (#69522)
* 9ab3ce1d7a06 Bump version to 17.0.4
* 880a282a40e3 workflows/release-lit: Pass correct build directory to pypa/gh-action-pypi-publish (#69438)
* 8719ee0cb39a workflows/release-lit: Fix dev suffix removal (#69397)

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index bd2ef0ebec9..0f811624a46 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -14,14 +14,14 @@  RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
 
 inherit cmake pkgconfig
 
-PV = "17.0.3"
+PV = "17.0.4"
 
 MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
 
 LLVM_RELEASE = "${PV}"
 
 BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "888437e1b60011b8a375dd30928ec925b448da57"
+SRCREV = "309d55140c46384b6de7a7573206cbeba3f7077f"
 SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
            file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
            file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \