diff mbox series

systemd: fix DynamicUser issue

Message ID 20231101084822.1887693-1-Qi.Chen@windriver.com
State Accepted, archived
Commit ba3a78c08cb0ce08afde049610d3172b9e3b0695
Headers show
Series systemd: fix DynamicUser issue | expand

Commit Message

ChenQi Nov. 1, 2023, 8:48 a.m. UTC
From: Chen Qi <Qi.Chen@windriver.com>

The DynamicUser needs libnss-systemd to be installed to function
well. The tweaks to nsswitch.conf should be conditional on PACKAGECONFIG
values.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta/recipes-core/systemd/systemd_254.4.bb | 22 +++++++++++++++++++---
 1 file changed, 19 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
index ef29116bf9..b3066b7c42 100644
--- a/meta/recipes-core/systemd/systemd_254.4.bb
+++ b/meta/recipes-core/systemd/systemd_254.4.bb
@@ -179,7 +179,7 @@  PACKAGECONFIG[microhttpd] = "-Dmicrohttpd=true,-Dmicrohttpd=false,libmicrohttpd"
 PACKAGECONFIG[myhostname] = "-Dnss-myhostname=true,-Dnss-myhostname=false,,libnss-myhostname"
 PACKAGECONFIG[networkd] = "-Dnetworkd=true,-Dnetworkd=false"
 PACKAGECONFIG[no-dns-fallback] = "-Ddns-servers="
-PACKAGECONFIG[nss] = "-Dnss-systemd=true,-Dnss-systemd=false"
+PACKAGECONFIG[nss] = "-Dnss-systemd=true,-Dnss-systemd=false,,libnss-systemd"
 PACKAGECONFIG[nss-mymachines] = "-Dnss-mymachines=true,-Dnss-mymachines=false"
 PACKAGECONFIG[nss-resolve] = "-Dnss-resolve=true,-Dnss-resolve=false"
 PACKAGECONFIG[oomd] = "-Doomd=true,-Doomd=false"
@@ -839,15 +839,31 @@  ALTERNATIVE_LINK_NAME[runlevel] = "${base_sbindir}/runlevel"
 ALTERNATIVE_PRIORITY[runlevel] ?= "300"
 
 pkg_postinst:${PN}:libc-glibc () {
+    if ${@bb.utils.contains('PACKAGECONFIG', 'myhostname', 'true', 'false', d)}; then
 	sed -e '/^hosts:/s/\s*\<myhostname\>//' \
-		-e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 myhostname \3\4\5/' \
-		-i $D${sysconfdir}/nsswitch.conf
+	    -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 myhostname \3\4\5/' \
+	    -i $D${sysconfdir}/nsswitch.conf
+    fi
+    if ${@bb.utils.contains('PACKAGECONFIG', 'nss', 'true', 'false', d)}; then
+	sed -e 's#\(^passwd:.*\)#\1 systemd#' \
+	    -e 's#\(^group:.*\)#\1 systemd#' \
+	    -e 's#\(^shadow:.*\)#\1 systemd#' \
+	    -i $D${sysconfdir}/nsswitch.conf
+    fi
 }
 
 pkg_prerm:${PN}:libc-glibc () {
+    if ${@bb.utils.contains('PACKAGECONFIG', 'myhostname', 'true', 'false', d)}; then
 	sed -e '/^hosts:/s/\s*\<myhostname\>//' \
 		-e '/^hosts:/s/\s*myhostname//' \
 		-i $D${sysconfdir}/nsswitch.conf
+    fi
+    if ${@bb.utils.contains('PACKAGECONFIG', 'nss', 'true', 'false', d)}; then
+	sed -e '/^passwd:/s#\s*systemd##' \
+	    -e '/^group:/s#\s*systemd##' \
+	    -e '/^shadow:/s#\s*systemd##' \
+	    -i $D${sysconfdir}/nsswitch.conf
+    fi
 }
 
 PACKAGE_WRITE_DEPS += "qemu-native"