diff mbox series

[2/4] systemd: add systemd-crypt package

Message ID 20231017091900.114311-2-jose.quaresma@foundries.io
State Accepted, archived
Commit c8c615329ad62a28c0762e79e7f11216f9bd88db
Headers show
Series [1/4] systemd: sort packages before pn | expand

Commit Message

Jose Quaresma Oct. 17, 2023, 9:18 a.m. UTC
Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
---
 meta/recipes-core/systemd/systemd_254.4.bb | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Erik Schilling Oct. 18, 2023, 10:36 a.m. UTC | #1
On Tue Oct 17, 2023 at 11:18 AM CEST, Jose Quaresma wrote:
> Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> ---
>  meta/recipes-core/systemd/systemd_254.4.bb | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
> index d24bf0cb06..2146c130d5 100644
> --- a/meta/recipes-core/systemd/systemd_254.4.bb
> +++ b/meta/recipes-core/systemd/systemd_254.4.bb
> @@ -387,6 +387,7 @@ PACKAGE_BEFORE_PN = "\
>      ${PN}-analyze \
>      ${PN}-binfmt \
>      ${PN}-container \
> +    ${PN}-crypt \
>      ${PN}-extra-utils \
>      ${PN}-gui \
>      ${PN}-initramfs \
> @@ -446,6 +447,11 @@ USERADD_PARAM:${PN}-journal-upload = "--system -d / -M --shell /sbin/nologin sys
>  
>  FILES:${PN}-analyze = "${bindir}/systemd-analyze"
>  
> +FILES:${PN}-crypt = "${bindir}/systemd-cryptenroll \
> +                     ${nonarch_libdir}/cryptsetup \

Won't there be .so plugin files in this folder that are arch-specific?
I assumed ${nonarch_libdir} should only be used for non-architecture
specific files?

- Erik

> +                    "
> +RRECOMMENDS:${PN} += "${PN}-crypt"
> +
>  FILES:${PN}-initramfs = "/init"
>  RDEPENDS:${PN}-initramfs = "${PN}"
>  
> @@ -552,7 +558,6 @@ FILES:${PN}-extra-utils = "\
>                          ${bindir}/systemd-run \
>                          ${bindir}/systemd-cat \
>                          ${bindir}/systemd-creds \
> -                        ${bindir}/systemd-cryptenroll \
>                          ${bindir}/systemd-delta \
>                          ${bindir}/systemd-cgls \
>                          ${bindir}/systemd-cgtop \
Erik Schilling Oct. 18, 2023, 10:39 a.m. UTC | #2
On Tue Oct 17, 2023 at 11:18 AM CEST, Jose Quaresma wrote:
> Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> ---
>  meta/recipes-core/systemd/systemd_254.4.bb | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)

Looks reasonable to me. I can test it, but it will probably take me a
few days until I get to this.

- Erik

>
> diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
> index d24bf0cb06..2146c130d5 100644
> --- a/meta/recipes-core/systemd/systemd_254.4.bb
> +++ b/meta/recipes-core/systemd/systemd_254.4.bb
> @@ -387,6 +387,7 @@ PACKAGE_BEFORE_PN = "\
>      ${PN}-analyze \
>      ${PN}-binfmt \
>      ${PN}-container \
> +    ${PN}-crypt \
>      ${PN}-extra-utils \
>      ${PN}-gui \
>      ${PN}-initramfs \
> @@ -446,6 +447,11 @@ USERADD_PARAM:${PN}-journal-upload = "--system -d / -M --shell /sbin/nologin sys
>  
>  FILES:${PN}-analyze = "${bindir}/systemd-analyze"
>  
> +FILES:${PN}-crypt = "${bindir}/systemd-cryptenroll \
> +                     ${nonarch_libdir}/cryptsetup \
> +                    "
> +RRECOMMENDS:${PN} += "${PN}-crypt"
> +
>  FILES:${PN}-initramfs = "/init"
>  RDEPENDS:${PN}-initramfs = "${PN}"
>  
> @@ -552,7 +558,6 @@ FILES:${PN}-extra-utils = "\
>                          ${bindir}/systemd-run \
>                          ${bindir}/systemd-cat \
>                          ${bindir}/systemd-creds \
> -                        ${bindir}/systemd-cryptenroll \
>                          ${bindir}/systemd-delta \
>                          ${bindir}/systemd-cgls \
>                          ${bindir}/systemd-cgtop \
Jose Quaresma Oct. 18, 2023, 11:30 a.m. UTC | #3
Erik Schilling <erik.schilling@linaro.org> escreveu no dia quarta,
18/10/2023 à(s) 11:36:

> On Tue Oct 17, 2023 at 11:18 AM CEST, Jose Quaresma wrote:
> > Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> > ---
> >  meta/recipes-core/systemd/systemd_254.4.bb | 7 ++++++-
> >  1 file changed, 6 insertions(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-core/systemd/systemd_254.4.bb
> b/meta/recipes-core/systemd/systemd_254.4.bb
> > index d24bf0cb06..2146c130d5 100644
> > --- a/meta/recipes-core/systemd/systemd_254.4.bb
> > +++ b/meta/recipes-core/systemd/systemd_254.4.bb
> > @@ -387,6 +387,7 @@ PACKAGE_BEFORE_PN = "\
> >      ${PN}-analyze \
> >      ${PN}-binfmt \
> >      ${PN}-container \
> > +    ${PN}-crypt \
> >      ${PN}-extra-utils \
> >      ${PN}-gui \
> >      ${PN}-initramfs \
> > @@ -446,6 +447,11 @@ USERADD_PARAM:${PN}-journal-upload = "--system -d /
> -M --shell /sbin/nologin sys
> >
> >  FILES:${PN}-analyze = "${bindir}/systemd-analyze"
> >
> > +FILES:${PN}-crypt = "${bindir}/systemd-cryptenroll \
> > +                     ${nonarch_libdir}/cryptsetup \
>
> Won't there be .so plugin files in this folder that are arch-specific?
> I assumed ${nonarch_libdir} should only be used for non-architecture
> specific files?
>

yeah you are right, the plugins are arch specific and nonarch_libdir will
break multilib.
I will change it to just ${libdir} and send a v2.
Thanks for your time.


>
> - Erik
>
> > +                    "
> > +RRECOMMENDS:${PN} += "${PN}-crypt"
> > +
> >  FILES:${PN}-initramfs = "/init"
> >  RDEPENDS:${PN}-initramfs = "${PN}"
> >
> > @@ -552,7 +558,6 @@ FILES:${PN}-extra-utils = "\
> >                          ${bindir}/systemd-run \
> >                          ${bindir}/systemd-cat \
> >                          ${bindir}/systemd-creds \
> > -                        ${bindir}/systemd-cryptenroll \
> >                          ${bindir}/systemd-delta \
> >                          ${bindir}/systemd-cgls \
> >                          ${bindir}/systemd-cgtop \
>
>
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
index d24bf0cb06..2146c130d5 100644
--- a/meta/recipes-core/systemd/systemd_254.4.bb
+++ b/meta/recipes-core/systemd/systemd_254.4.bb
@@ -387,6 +387,7 @@  PACKAGE_BEFORE_PN = "\
     ${PN}-analyze \
     ${PN}-binfmt \
     ${PN}-container \
+    ${PN}-crypt \
     ${PN}-extra-utils \
     ${PN}-gui \
     ${PN}-initramfs \
@@ -446,6 +447,11 @@  USERADD_PARAM:${PN}-journal-upload = "--system -d / -M --shell /sbin/nologin sys
 
 FILES:${PN}-analyze = "${bindir}/systemd-analyze"
 
+FILES:${PN}-crypt = "${bindir}/systemd-cryptenroll \
+                     ${nonarch_libdir}/cryptsetup \
+                    "
+RRECOMMENDS:${PN} += "${PN}-crypt"
+
 FILES:${PN}-initramfs = "/init"
 RDEPENDS:${PN}-initramfs = "${PN}"
 
@@ -552,7 +558,6 @@  FILES:${PN}-extra-utils = "\
                         ${bindir}/systemd-run \
                         ${bindir}/systemd-cat \
                         ${bindir}/systemd-creds \
-                        ${bindir}/systemd-cryptenroll \
                         ${bindir}/systemd-delta \
                         ${bindir}/systemd-cgls \
                         ${bindir}/systemd-cgtop \