diff mbox series

[3/3] autotools.bbclass: Add *.m4 to CONFIGURE_FILES

Message ID 20231003010529.2892756-3-pkj@axis.com
State Accepted, archived
Commit 492559191943c9e2666c3dda1824c5aafbe487d5
Headers show
Series [1/3] externalsrc.bbclass: Support specifying patterns in CONFIGURE_FILES | expand

Commit Message

Peter Kjellerstedt Oct. 3, 2023, 1:05 a.m. UTC
This makes do_configure depend on changes to any m4 file when
externalsrc is active.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
---
 meta/classes-recipe/autotools.bbclass | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/classes-recipe/autotools.bbclass b/meta/classes-recipe/autotools.bbclass
index a4c1c4be41..5ed21a3d68 100644
--- a/meta/classes-recipe/autotools.bbclass
+++ b/meta/classes-recipe/autotools.bbclass
@@ -157,7 +157,7 @@  python autotools_aclocals () {
 
 do_configure[file-checksums] += "${@' '.join(siteinfo_get_files(d, sysrootcache=False)[1])}"
 
-CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am"
+CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in *.m4 Makefile.am"
 
 autotools_do_configure() {
 	# WARNING: gross hack follows: