diff mbox series

llvm: Upgrade to 17.0.2

Message ID 20230926030940.1143050-1-raj.khem@gmail.com
State Accepted, archived
Commit c2e059a036ac5c4d2cb3c7267be2403e0611dea5
Headers show
Series llvm: Upgrade to 17.0.2 | expand

Commit Message

Khem Raj Sept. 26, 2023, 3:09 a.m. UTC
* 481358974fb0 [GVN] Also remove phi nodes from VN table (PR65447)
* 9f77e96186be [GVN] Invalidate MDA when deduplicating phi nodes
* a13a89402f53 Bump version to 17.0.2
* 2c04bdb24677 [SVE] Ensure SVE call operands passed via memory are correctly initialised. (#66070)
* 701620d58cdf [SVE] Precommit test to show missing initialisation of call operand.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/llvm/llvm_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 611aacba147..934f842b908 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -14,14 +14,14 @@  RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
 
 inherit cmake pkgconfig
 
-PV = "17.0.1"
+PV = "17.0.2"
 
 MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
 
 LLVM_RELEASE = "${PV}"
 
 BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "e19b7dc36bc047b9eb72078d034596be766da350"
+SRCREV = "481358974fb0f732e33d503c224492a543f4d7bd"
 SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
            file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
            file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \