diff mbox series

[v3,1/5] musl: Update to latest

Message ID 20230922210508.24087-1-raj.khem@gmail.com
State Accepted, archived
Commit bb14f1dee4547726ab66e20d535d58563029d67f
Headers show
Series [v3,1/5] musl: Update to latest | expand

Commit Message

Khem Raj Sept. 22, 2023, 9:05 p.m. UTC
Brings following bug fixes

* 79bdacff glob: fix wrong return code when aborting before any matches
* 7291c6c6 statvfs: allocate spare for f_type
* 39e43f08 math: fix ld80 powl(x,huge) and powl(LDBL_MAX,small)
* 6d101027 math: fix ld80 acoshl(x) for x < 0

Drop MIRRORS and switch to etalabs.net for git fetch URI
original repo is not working correcting with git Fetcher

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v3: Update SRC_URI to fetchable location

 meta/recipes-core/musl/musl_git.bb | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

Comments

Alexandre Belloni Sept. 25, 2023, 4:04 p.m. UTC | #1
Hello,

I had this with the series:

https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/7848/steps/12/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/7876/steps/12/logs/stdio

make[2]: Entering directory '/home/root/buildtest/cpio-2.13/rmt'
  CC       rmt.o
  CCLD     rmt
/usr/lib/gcc/i686-poky-linux-musl/13.2.0/../../../../i686-poky-linux-musl/bin/ld: rmt.o: in function `parse_opt':
/home/root/buildtest/cpio-2.13/rmt/rmt.c:715:(.text+0x190): undefined reference to `error'
/usr/lib/gcc/i686-poky-linux-musl/13.2.0/../../../../i686-poky-linux-musl/bin/ld: rmt.o: in function `main':
/home/root/buildtest/cpio-2.13/rmt/rmt.c:780:(.text.startup+0x170): undefined reference to `error'
/usr/lib/gcc/i686-poky-linux-musl/13.2.0/../../../../i686-poky-linux-musl/bin/ld: /home/root/buildtest/cpio-2.13/rmt/rmt.c:783:(.text.startup+0x7af): undefined reference to `error'
collect2: error: ld returned 1 exit status
make[2]: Leaving directory '/home/root/buildtest/cpio-2.13/rmt'
make[2]: *** [Makefile:1221: rmt] Error 1
make[1]: *** [Makefile:1282: all-recursive] Error 1
make[1]: Leaving directory '/home/root/buildtest/cpio-2.13'
make: *** [Makefile:1222: all] Error 2



On 22/09/2023 14:05:04-0700, Khem Raj wrote:
> Brings following bug fixes
> 
> * 79bdacff glob: fix wrong return code when aborting before any matches
> * 7291c6c6 statvfs: allocate spare for f_type
> * 39e43f08 math: fix ld80 powl(x,huge) and powl(LDBL_MAX,small)
> * 6d101027 math: fix ld80 acoshl(x) for x < 0
> 
> Drop MIRRORS and switch to etalabs.net for git fetch URI
> original repo is not working correcting with git Fetcher
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
> v3: Update SRC_URI to fetchable location
> 
>  meta/recipes-core/musl/musl_git.bb | 8 ++------
>  1 file changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
> index 4a4fe978f93..7dd949ffafd 100644
> --- a/meta/recipes-core/musl/musl_git.bb
> +++ b/meta/recipes-core/musl/musl_git.bb
> @@ -4,21 +4,17 @@
>  require musl.inc
>  inherit linuxloader
>  
> -SRCREV = "83b858f83b658bd34eca5d8ad4d145f673ae7e5e"
> +SRCREV = "79bdacff83a6bd5b70ff5ae5eb8b6de82c2f7c30"
>  
>  BASEVER = "1.2.4"
>  
>  PV = "${BASEVER}+git"
>  
> -# mirror is at git://github.com/kraj/musl.git
> -
> -SRC_URI = "git://git.musl-libc.org/git/musl.git;branch=master;protocol=https \
> +SRC_URI = "git://git.etalabs.net/git/musl;branch=master;protocol=https \
>             file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
>             file://0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch \
>            "
>  
> -MIRRORS += "git://git.musl-libc.org/git/musl.git git://github.com/kraj/musl.git"
> -
>  S = "${WORKDIR}/git"
>  
>  PROVIDES += "virtual/libc virtual/libiconv virtual/libintl virtual/crypt"
> -- 
> 2.42.0
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188133): https://lists.openembedded.org/g/openembedded-core/message/188133
> Mute This Topic: https://lists.openembedded.org/mt/101529915/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Sept. 25, 2023, 5:26 p.m. UTC | #2
On Mon, Sep 25, 2023 at 9:04 AM Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> Hello,
>
> I had this with the series:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/7848/steps/12/logs/stdio
> https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/7876/steps/12/logs/stdio
>
> make[2]: Entering directory '/home/root/buildtest/cpio-2.13/rmt'
>   CC       rmt.o
>   CCLD     rmt
> /usr/lib/gcc/i686-poky-linux-musl/13.2.0/../../../../i686-poky-linux-musl/bin/ld: rmt.o: in function `parse_opt':
> /home/root/buildtest/cpio-2.13/rmt/rmt.c:715:(.text+0x190): undefined reference to `error'
> /usr/lib/gcc/i686-poky-linux-musl/13.2.0/../../../../i686-poky-linux-musl/bin/ld: rmt.o: in function `main':
> /home/root/buildtest/cpio-2.13/rmt/rmt.c:780:(.text.startup+0x170): undefined reference to `error'
> /usr/lib/gcc/i686-poky-linux-musl/13.2.0/../../../../i686-poky-linux-musl/bin/ld: /home/root/buildtest/cpio-2.13/rmt/rmt.c:783:(.text.startup+0x7af): undefined reference to `error'
> collect2: error: ld returned 1 exit status
> make[2]: Leaving directory '/home/root/buildtest/cpio-2.13/rmt'
> make[2]: *** [Makefile:1221: rmt] Error 1
> make[1]: *** [Makefile:1282: all-recursive] Error 1
> make[1]: Leaving directory '/home/root/buildtest/cpio-2.13'
> make: *** [Makefile:1222: all] Error 2
>
>


Please cherry-pick -
https://patchwork.yoctoproject.org/project/oe-core/patch/20230923073100.851867-1-raj.khem@gmail.com/
on top

>
> On 22/09/2023 14:05:04-0700, Khem Raj wrote:
> > Brings following bug fixes
> >
> > * 79bdacff glob: fix wrong return code when aborting before any matches
> > * 7291c6c6 statvfs: allocate spare for f_type
> > * 39e43f08 math: fix ld80 powl(x,huge) and powl(LDBL_MAX,small)
> > * 6d101027 math: fix ld80 acoshl(x) for x < 0
> >
> > Drop MIRRORS and switch to etalabs.net for git fetch URI
> > original repo is not working correcting with git Fetcher
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> > v3: Update SRC_URI to fetchable location
> >
> >  meta/recipes-core/musl/musl_git.bb | 8 ++------
> >  1 file changed, 2 insertions(+), 6 deletions(-)
> >
> > diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
> > index 4a4fe978f93..7dd949ffafd 100644
> > --- a/meta/recipes-core/musl/musl_git.bb
> > +++ b/meta/recipes-core/musl/musl_git.bb
> > @@ -4,21 +4,17 @@
> >  require musl.inc
> >  inherit linuxloader
> >
> > -SRCREV = "83b858f83b658bd34eca5d8ad4d145f673ae7e5e"
> > +SRCREV = "79bdacff83a6bd5b70ff5ae5eb8b6de82c2f7c30"
> >
> >  BASEVER = "1.2.4"
> >
> >  PV = "${BASEVER}+git"
> >
> > -# mirror is at git://github.com/kraj/musl.git
> > -
> > -SRC_URI = "git://git.musl-libc.org/git/musl.git;branch=master;protocol=https \
> > +SRC_URI = "git://git.etalabs.net/git/musl;branch=master;protocol=https \
> >             file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
> >             file://0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch \
> >            "
> >
> > -MIRRORS += "git://git.musl-libc.org/git/musl.git git://github.com/kraj/musl.git"
> > -
> >  S = "${WORKDIR}/git"
> >
> >  PROVIDES += "virtual/libc virtual/libiconv virtual/libintl virtual/crypt"
> > --
> > 2.42.0
> >
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#188133): https://lists.openembedded.org/g/openembedded-core/message/188133
> > Mute This Topic: https://lists.openembedded.org/mt/101529915/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 4a4fe978f93..7dd949ffafd 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,21 +4,17 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "83b858f83b658bd34eca5d8ad4d145f673ae7e5e"
+SRCREV = "79bdacff83a6bd5b70ff5ae5eb8b6de82c2f7c30"
 
 BASEVER = "1.2.4"
 
 PV = "${BASEVER}+git"
 
-# mirror is at git://github.com/kraj/musl.git
-
-SRC_URI = "git://git.musl-libc.org/git/musl.git;branch=master;protocol=https \
+SRC_URI = "git://git.etalabs.net/git/musl;branch=master;protocol=https \
            file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
            file://0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch \
           "
 
-MIRRORS += "git://git.musl-libc.org/git/musl.git git://github.com/kraj/musl.git"
-
 S = "${WORKDIR}/git"
 
 PROVIDES += "virtual/libc virtual/libiconv virtual/libintl virtual/crypt"