diff mbox series

[08/17] python3-license-expression: Copy recipe from meta-python

Message ID 20230922144628.2495839-9-samantha.jalabert@syslinbit.com
State Accepted, archived
Commit 84d07b09582b69653f11ec025a5074055483a97f
Headers show
Series python3-spdx-tools implementation | expand

Commit Message

Samantha Jalabert Sept. 22, 2023, 2:46 p.m. UTC
From: Samantha Jalabert <samantha.jalabert@syslinbit.com>

commit: cabfde8c84e100968bc9ab8407ede616100fddbb

Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com>
---
 .../python3-license-expression/run-ptest      |  3 ++
 .../python3-license-expression_30.1.1.bb      | 36 +++++++++++++++++++
 2 files changed, 39 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-license-expression/run-ptest
 create mode 100644 meta/recipes-devtools/python/python3-license-expression_30.1.1.bb
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-license-expression/run-ptest b/meta/recipes-devtools/python/python3-license-expression/run-ptest
new file mode 100644
index 0000000000..5cec711696
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-license-expression/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest
diff --git a/meta/recipes-devtools/python/python3-license-expression_30.1.1.bb b/meta/recipes-devtools/python/python3-license-expression_30.1.1.bb
new file mode 100644
index 0000000000..31fb88d6e5
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-license-expression_30.1.1.bb
@@ -0,0 +1,36 @@ 
+SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
+HOMEPAGE = "https://github.com/nexB/license-expression"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI[sha256sum] = "42375df653ad85e6f5b4b0385138b2dbea1f5d66360783d8625c3e4f97f11f0c"
+
+inherit pypi ptest python_setuptools_build_meta
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-booleanpy \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-json \
+    ${PYTHON_PN}-stringold \
+    ${PYTHON_PN}-logging \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+	file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+	${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+    install -d ${D}${PTEST_PATH}/tests
+    install -d ${D}${PTEST_PATH}/src
+    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+    cp -rf ${S}/src/* ${D}${PTEST_PATH}/src/
+}