diff mbox series

[06/29] perl: use 64 bit integers across all targets

Message ID 20230917093901.428214-6-alex@linutronix.de
State Accepted, archived
Commit c99c1b92eb5fb76f22b3458df15d876748528a20
Headers show
Series [01/29] sstate.bbclass: setscene_depvalid(): do not exclude shadow-native from task dependency resolution | expand

Commit Message

Alexander Kanavin Sept. 17, 2023, 9:38 a.m. UTC
Otherwise perl would use 32 bit integers on 32 bit targets,
causing loss of bits when copying 64 bit time_t into an
internal representation.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/perl/perl_5.38.0.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/perl/perl_5.38.0.bb b/meta/recipes-devtools/perl/perl_5.38.0.bb
index a8623b6e84b..956e4d64d70 100644
--- a/meta/recipes-devtools/perl/perl_5.38.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.38.0.bb
@@ -58,6 +58,7 @@  do_configure:prepend() {
 do_configure:class-target() {
     ./configure --prefix=${prefix} --libdir=${libdir} \
     --target=${TARGET_SYS} \
+    -Duse64bitint \
     -Duseshrplib \
     -Dusethreads \
     -Dsoname=libperl.so.5 \