diff mbox series

stress-ng: disable DEBUG_BUILD

Message ID 20230830044800.874927-1-Qi.Chen@windriver.com
State Accepted, archived
Commit 3270f6f3bcb7811fd5e576808c086428f1a8c568
Headers show
Series stress-ng: disable DEBUG_BUILD | expand

Commit Message

ChenQi Aug. 30, 2023, 4:48 a.m. UTC
From: Chen Qi <Qi.Chen@windriver.com>

We get do_compile error when DEBUG_BUILD is enabled:

  error: inlining failed in call to 'always_inline' '_mm512_storeu_si512': target specific option mismatch

To reproduce the issue, set the following lines in local.conf
and then `bitbake stress-ng'.

  MACHINE = "qemux86-64"
  DEBUG_BUILD = "1"

A new issue is filed for stress-ng to track it:
https://github.com/ColinIanKing/stress-ng/issues/315

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta/recipes-extended/stress-ng/stress-ng_0.16.04.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.16.04.bb b/meta/recipes-extended/stress-ng/stress-ng_0.16.04.bb
index 6e5665cc3b..af8433975b 100644
--- a/meta/recipes-extended/stress-ng/stress-ng_0.16.04.bb
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.16.04.bb
@@ -31,3 +31,6 @@  do_install() {
     oe_runmake DESTDIR=${D} BINDIR=${bindir} install
     ln -s stress-ng ${D}${bindir}/stress
 }
+
+# upstream issue: https://github.com/ColinIanKing/stress-ng/issues/315
+DEBUG_BUILD = "0"