diff mbox series

[8/9] python3-pygobject: add explicit check for qemu-usermode MACHINE_FEATURE

Message ID 20230810162451.1766532-8-ross.burton@arm.com
State Accepted, archived
Commit 86941419ef2d315db6bf5645491bf97ec129eb34
Headers show
Series [1/9] meson.bbclass: add MESON_TARGET | expand

Commit Message

Ross Burton Aug. 10, 2023, 4:24 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

When building for the target this recipe absolutely needs
gobject-introspection to be enabled, so add an explict
---
 meta/recipes-devtools/python/python3-pygobject_3.44.1.bb | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

Alexander Kanavin Aug. 10, 2023, 4:41 p.m. UTC | #1
Adding anonymous python is not good. Can this be solved via COMBINED_FEATURES?

Alex

On Thu, 10 Aug 2023 at 18:25, Ross Burton <ross.burton@arm.com> wrote:
>
> From: Ross Burton <ross.burton@arm.com>
>
> When building for the target this recipe absolutely needs
> gobject-introspection to be enabled, so add an explict
> ---
>  meta/recipes-devtools/python/python3-pygobject_3.44.1.bb | 7 +++++--
>  1 file changed, 5 insertions(+), 2 deletions(-)
>
> diff --git a/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
> index 6f7d9a09ecd..797a7cec8ba 100644
> --- a/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
> +++ b/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
> @@ -8,9 +8,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
>  GNOMEBASEBUILDCLASS = "meson"
>  GIR_MESON_OPTION = ""
>
> -inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even features_check
> +inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even
>
> -REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
> +python() {
> +    if d.getVar('CLASSOVERRIDE') == "class-target" and not bb.utils.to_boolean(d.getVar("GI_DATA_ENABLED")):
> +        raise bb.parse.SkipRecipe("GI not available")
> +}
>
>  DEPENDS += "python3 glib-2.0"
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#185809): https://lists.openembedded.org/g/openembedded-core/message/185809
> Mute This Topic: https://lists.openembedded.org/mt/100666863/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Ross Burton Aug. 10, 2023, 4:51 p.m. UTC | #2
On 10 Aug 2023, at 17:41, Alexander Kanavin <alex.kanavin@gmail.com> wrote:
> 
> Adding anonymous python is not good. Can this be solved via COMBINED_FEATURES?

No, because there’s no overlap in the names.

And the features_check is anonymous Python so we’re just swapping a big piece of general logic which isn’t correct with a more accurate piece of logic.

Ross
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
index 6f7d9a09ecd..797a7cec8ba 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
@@ -8,9 +8,12 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
 GNOMEBASEBUILDCLASS = "meson"
 GIR_MESON_OPTION = ""
 
-inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even features_check
+inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even
 
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+python() {
+    if d.getVar('CLASSOVERRIDE') == "class-target" and not bb.utils.to_boolean(d.getVar("GI_DATA_ENABLED")):
+        raise bb.parse.SkipRecipe("GI not available")
+}
 
 DEPENDS += "python3 glib-2.0"