diff mbox series

systemd-boot: Ensure EFI_LD is also passed to compiler driver

Message ID 20230805152621.331289-1-raj.khem@gmail.com
State Accepted, archived
Commit d497362d52bd934101e7d7a49eeee0fffb0f4f46
Headers show
Series systemd-boot: Ensure EFI_LD is also passed to compiler driver | expand

Commit Message

Khem Raj Aug. 5, 2023, 3:26 p.m. UTC
Where compiler driver is used for linking ensure bfd linker is used as
well so its consistent when called directly or via compiler

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/systemd/systemd-boot_254.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb b/meta/recipes-core/systemd/systemd-boot_254.bb
index e887e636e86..5d69cf83abc 100644
--- a/meta/recipes-core/systemd/systemd-boot_254.bb
+++ b/meta/recipes-core/systemd/systemd-boot_254.bb
@@ -11,6 +11,7 @@  inherit deploy
 LDFLAGS:prepend = "${@ " ".join(d.getVar('LD').split()[1:])} "
 
 EFI_LD = "bfd"
+LDFLAGS:append = " -fuse-ld=${EFI_LD}"
 
 do_write_config[vardeps] += "CC OBJCOPY EFI_LD"
 do_write_config:append() {