diff mbox series

systemd: set correct paths for kdb binaries

Message ID 20230804152936.1861831-1-ross.burton@arm.com
State Accepted, archived
Commit 458fdd085beb14572e5a1ed0f94861cf10648725
Headers show
Series systemd: set correct paths for kdb binaries | expand

Commit Message

Ross Burton Aug. 4, 2023, 3:29 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

The kbd binaries (loadkeys and setfont) are installed to bindir, not
base_bindir.

Fixes: 94ccc7acc4a871f5bb7ab8e135e70b5519eff6ad
Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-core/systemd/systemd_254.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ross Burton Aug. 8, 2023, 9:52 a.m. UTC | #1
On 8 Aug 2023, at 09:32, Francesco Dolcini <francesco@dolcini.it> wrote:
> 
> Hello,
> 
> On Fri, Aug 04, 2023 at 04:29:36PM +0100, ross.burton@arm.com wrote:
>> From: Ross Burton <ross.burton@arm.com>
>> 
>> The kbd binaries (loadkeys and setfont) are installed to bindir, not
>> base_bindir.
>> 
>> Fixes: 94ccc7acc4a871f5bb7ab8e135e70b5519eff6ad
>> Signed-off-by: Ross Burton <ross.burton@arm.com>
> 
> Is my understanding correct that this patch is supposed to fix the
> following error:
> 
> ```
>>> systemd-test: systemd-vconsole-setup.service status:
> x systemd-vconsole-setup.service - Virtual Console Setup
>     Loaded: loaded (/lib/systemd/system/systemd-vconsole-setup.service; static)
>     Active: failed (Result: exit-code) since Mon 2023-08-07 15:34:29 UTC; 8min ago
>       Docs: man:systemd-vconsole-setup.service(8)
>             man:vconsole.conf(5)
>    Process: 765 ExecStart=/lib/systemd/systemd-vconsole-setup (code=exited, status=1/FAILURE)
>   Main PID: 765 (code=exited, status=1/FAILURE)
> Aug 07 15:34:29 localhost systemd[1]: Starting Virtual Console Setup...
> Aug 07 15:34:29 localhost systemd-vconsole-setup[765]: /bin/loadkeys failed with exit status 1.
> Aug 07 15:34:29 localhost systemd[1]: systemd-vconsole-setup.service: Main process exited, code=exited, status=1/FAILURE
> Aug 07 15:34:29 localhost systemd[1]: systemd-vconsole-setup.service: Failed with result 'exit-code'.
> Aug 07 15:34:29 localhost systemd[1]: Failed to start Virtual Console Setup.
> ```
> 
> just introduced with systemd 254 in oe-core ?

Yes, that’s right.

Ross
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd_254.bb b/meta/recipes-core/systemd/systemd_254.bb
index ea1a4f02f05..3dd949e69c7 100644
--- a/meta/recipes-core/systemd/systemd_254.bb
+++ b/meta/recipes-core/systemd/systemd_254.bb
@@ -252,8 +252,8 @@  EXTRA_OEMESON += "-Dkexec-path=${sbindir}/kexec \
                   -Dsulogin-path=${base_sbindir}/sulogin \
                   -Dnologin-path=${base_sbindir}/nologin \
                   -Dumount-path=${base_bindir}/umount \
-                  -Dloadkeys-path=${base_bindir}/loadkeys \
-                  -Dsetfont-path=${base_bindir}/setfont"
+                  -Dloadkeys-path=${bindir}/loadkeys \
+                  -Dsetfont-path=${bindir}/setfont"
 
 # The 60 seconds is watchdog's default vaule.
 WATCHDOG_TIMEOUT ??= "60"