diff mbox series

[mickledore] webkitgtk: disable DEBUG_BUILD

Message ID 20230724074815.591827-1-kai.kang@windriver.com
State New
Headers show
Series [mickledore] webkitgtk: disable DEBUG_BUILD | expand

Commit Message

Kai July 24, 2023, 7:48 a.m. UTC
From: Kai Kang <kai.kang@windriver.com>

It fails to build webkitgtk with DEBUG_BUILD:

  Source/bmalloc/libpas/src/libpas/pas_generic_large_free_heap.h:140:1:
  error: inlining failed in call to 'always_inline'
  'pas_generic_large_free_heap_try_allocate_test_allocation_candidate':
  indirect function call with a yet undetermined callee
  | pas_generic_large_free_heap_try_allocate_test_allocation_candidate(
  | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

So disable DEBUG_BUILD for it.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 meta/recipes-sato/webkit/webkitgtk_2.38.6.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Alexander Kanavin July 24, 2023, 8:37 a.m. UTC | #1
Does this happen on master? If so, does this need an upstream bug
report, or maybe a better fix?

Alex

On Mon, 24 Jul 2023 at 09:48, Kai Kang <kai.kang@eng.windriver.com> wrote:
>
> From: Kai Kang <kai.kang@windriver.com>
>
> It fails to build webkitgtk with DEBUG_BUILD:
>
>   Source/bmalloc/libpas/src/libpas/pas_generic_large_free_heap.h:140:1:
>   error: inlining failed in call to 'always_inline'
>   'pas_generic_large_free_heap_try_allocate_test_allocation_candidate':
>   indirect function call with a yet undetermined callee
>   | pas_generic_large_free_heap_try_allocate_test_allocation_candidate(
>   | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> So disable DEBUG_BUILD for it.
>
> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> ---
>  meta/recipes-sato/webkit/webkitgtk_2.38.6.bb | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb b/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
> index 5e8adf50fc..e6d817cb62 100644
> --- a/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
> +++ b/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
> @@ -42,6 +42,9 @@ DEPENDS += " \
>            gettext-native \
>            "
>
> +# webkitgtk fails to build with DEBUG_BUILD enabled
> +DEBUG_BUILD = "0"
> +
>  PACKAGECONFIG_SOUP ?= "soup3"
>  PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
>                     ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#184778): https://lists.openembedded.org/g/openembedded-core/message/184778
> Mute This Topic: https://lists.openembedded.org/mt/100324919/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Kai July 24, 2023, 8:56 a.m. UTC | #2
On 7/24/23 16:37, Alexander Kanavin wrote:
> Does this happen on master? If so, does this need an upstream bug
> report, or maybe a better fix?
Yes, if fails through webkitgtk 2.38.x to 2.40.x. It needs many 
replacement that replace 'PAS_ALWAYS_INLINE'
with 'inline' and I'm not sure that is a good fix. I'll discuss with 
upstream about it.

Regards,
Kai

>
> Alex
>
> On Mon, 24 Jul 2023 at 09:48, Kai Kang <kai.kang@eng.windriver.com> wrote:
>> From: Kai Kang <kai.kang@windriver.com>
>>
>> It fails to build webkitgtk with DEBUG_BUILD:
>>
>>    Source/bmalloc/libpas/src/libpas/pas_generic_large_free_heap.h:140:1:
>>    error: inlining failed in call to 'always_inline'
>>    'pas_generic_large_free_heap_try_allocate_test_allocation_candidate':
>>    indirect function call with a yet undetermined callee
>>    | pas_generic_large_free_heap_try_allocate_test_allocation_candidate(
>>    | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>
>> So disable DEBUG_BUILD for it.
>>
>> Signed-off-by: Kai Kang <kai.kang@windriver.com>
>> ---
>>   meta/recipes-sato/webkit/webkitgtk_2.38.6.bb | 3 +++
>>   1 file changed, 3 insertions(+)
>>
>> diff --git a/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb b/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
>> index 5e8adf50fc..e6d817cb62 100644
>> --- a/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
>> +++ b/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
>> @@ -42,6 +42,9 @@ DEPENDS += " \
>>             gettext-native \
>>             "
>>
>> +# webkitgtk fails to build with DEBUG_BUILD enabled
>> +DEBUG_BUILD = "0"
>> +
>>   PACKAGECONFIG_SOUP ?= "soup3"
>>   PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
>>                      ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
>> --
>> 2.34.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#184778): https://lists.openembedded.org/g/openembedded-core/message/184778
>> Mute This Topic: https://lists.openembedded.org/mt/100324919/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb b/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
index 5e8adf50fc..e6d817cb62 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.38.6.bb
@@ -42,6 +42,9 @@  DEPENDS += " \
           gettext-native \
           "
 
+# webkitgtk fails to build with DEBUG_BUILD enabled
+DEBUG_BUILD = "0"
+
 PACKAGECONFIG_SOUP ?= "soup3"
 PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
                    ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \