diff mbox series

mdadm: add util-linux-blockdev ptest dependency

Message ID 20230721105827.1637688-1-ovidiu.panait@windriver.com
State Accepted, archived
Commit a15cd04f528d137d428a572f15d1ec5ebbbd81f0
Headers show
Series mdadm: add util-linux-blockdev ptest dependency | expand

Commit Message

Ovidiu Panait July 21, 2023, 10:58 a.m. UTC
From: Ovidiu Panait <ovidiu.panait@windriver.com>

07revert-inplace test logs contain the following:
func.sh: line 335: /sbin/blockdev: No such file or directory

Add the missing util-linux-blockdev dependency.

Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
---
 meta/recipes-extended/mdadm/mdadm_4.2.bb | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Alexander Kanavin July 23, 2023, 12:08 p.m. UTC | #1
Can you please check why the test doesn't fail with the dependency absent?

Alex

On Fri, 21 Jul 2023 at 12:58, Ovidiu Panait via lists.openembedded.org
<ovidiu.panait=windriver.com@lists.openembedded.org> wrote:
>
> From: Ovidiu Panait <ovidiu.panait@windriver.com>
>
> 07revert-inplace test logs contain the following:
> func.sh: line 335: /sbin/blockdev: No such file or directory
>
> Add the missing util-linux-blockdev dependency.
>
> Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
> ---
>  meta/recipes-extended/mdadm/mdadm_4.2.bb | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> index 50d9548747..fa50325f1f 100644
> --- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
> +++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> @@ -107,7 +107,14 @@ do_install_ptest() {
>  }
>
>  RDEPENDS:${PN} += "bash"
> -RDEPENDS:${PN}-ptest += "bash e2fsprogs-mke2fs util-linux-lsblk util-linux-losetup strace"
> +RDEPENDS:${PN}-ptest += " \
> +    bash \
> +    e2fsprogs-mke2fs \
> +    util-linux-lsblk \
> +    util-linux-losetup \
> +    util-linux-blockdev \
> +    strace \
> +"
>  RRECOMMENDS:${PN}-ptest += " \
>      coreutils \
>      kernel-module-loop \
> --
> 2.39.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#184682): https://lists.openembedded.org/g/openembedded-core/message/184682
> Mute This Topic: https://lists.openembedded.org/mt/100274537/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Ovidiu Panait July 23, 2023, 2:39 p.m. UTC | #2
On 7/23/23 15:08, Alexander Kanavin wrote:
> CAUTION: This email comes from a non Wind River email account!
> Do not click links or open attachments unless you recognize the sender and know the content is safe.
>
> Can you please check why the test doesn't fail with the dependency absent?
The testcase fails intermittently:
https://bugzilla.yoctoproject.org/show_bug.cgi?id=15159

But it is not clear if it's related to the missing blockdev dependency, 
as I was unable to reproduce the failure manually and we can't get the 
logs from the autobuilder.

blockdev not being available doesn't make the testcase fail directly, 
but it affects some calculations, so I think it should be added as a 
dependency:
...
+++ /sbin/blockdev --getsize /dev/md0
/usr/lib/mdadm/ptest/tests/func.sh: line 334: /sbin/blockdev: No such 
file or directory
++ '[' -eq 0 ']'
/usr/lib/mdadm/ptest/tests/func.sh: line 334: [: -eq: unary operator 
expected
+++ /sbin/blockdev --getsize /dev/md0
/usr/lib/mdadm/ptest/tests/func.sh: line 335: /sbin/blockdev: No such 
file or directory
++ _sz=
++ '[' 119808 -lt -o 95846 -gt ']'
/usr/lib/mdadm/ptest/tests/func.sh: line 336: [: -o: integer expression 
expected

Ovidiu
> Alex
>
> On Fri, 21 Jul 2023 at 12:58, Ovidiu Panait via lists.openembedded.org
> <ovidiu.panait=windriver.com@lists.openembedded.org> wrote:
>> From: Ovidiu Panait <ovidiu.panait@windriver.com>
>>
>> 07revert-inplace test logs contain the following:
>> func.sh: line 335: /sbin/blockdev: No such file or directory
>>
>> Add the missing util-linux-blockdev dependency.
>>
>> Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
>> ---
>>   meta/recipes-extended/mdadm/mdadm_4.2.bb | 9 ++++++++-
>>   1 file changed, 8 insertions(+), 1 deletion(-)
>>
>> diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
>> index 50d9548747..fa50325f1f 100644
>> --- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
>> +++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
>> @@ -107,7 +107,14 @@ do_install_ptest() {
>>   }
>>
>>   RDEPENDS:${PN} += "bash"
>> -RDEPENDS:${PN}-ptest += "bash e2fsprogs-mke2fs util-linux-lsblk util-linux-losetup strace"
>> +RDEPENDS:${PN}-ptest += " \
>> +    bash \
>> +    e2fsprogs-mke2fs \
>> +    util-linux-lsblk \
>> +    util-linux-losetup \
>> +    util-linux-blockdev \
>> +    strace \
>> +"
>>   RRECOMMENDS:${PN}-ptest += " \
>>       coreutils \
>>       kernel-module-loop \
>> --
>> 2.39.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#184682): https://lists.openembedded.org/g/openembedded-core/message/184682
>> Mute This Topic: https://lists.openembedded.org/mt/100274537/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
index 50d9548747..fa50325f1f 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
@@ -107,7 +107,14 @@  do_install_ptest() {
 }
 
 RDEPENDS:${PN} += "bash"
-RDEPENDS:${PN}-ptest += "bash e2fsprogs-mke2fs util-linux-lsblk util-linux-losetup strace"
+RDEPENDS:${PN}-ptest += " \
+    bash \
+    e2fsprogs-mke2fs \
+    util-linux-lsblk \
+    util-linux-losetup \
+    util-linux-blockdev \
+    strace \
+"
 RRECOMMENDS:${PN}-ptest += " \
     coreutils \
     kernel-module-loop \