diff mbox series

[1/2] openssl: check the existence of the PERL5LIB path

Message ID 20230705180358.382955-1-jose.quaresma@foundries.io
State New
Headers show
Series [1/2] openssl: check the existence of the PERL5LIB path | expand

Commit Message

Jose Quaresma July 5, 2023, 6:03 p.m. UTC
When upstream change is better to fail or removing the PERL5LIB
if they are nott need anymore.

Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
---
 meta/recipes-connectivity/openssl/openssl_3.1.1.bb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Alexander Kanavin July 5, 2023, 6:24 p.m. UTC | #1
There is no need to export the other two variables, they can stay as they were.

Alex


On Wed, 5 Jul 2023 at 20:04, Jose Quaresma <quaresma.jose@gmail.com> wrote:
>
> When upstream change is better to fail or removing the PERL5LIB
> if they are nott need anymore.
>
> Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> ---
>  meta/recipes-connectivity/openssl/openssl_3.1.1.bb | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> index f5f3f32a97..0dce7f71bc 100644
> --- a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> +++ b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> @@ -137,7 +137,10 @@ do_configure () {
>         fi
>         # WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
>         # environment variables set by bitbake. Adjust the environment variables instead.
> -       HASHBANGPERL="/usr/bin/env perl" PERL=perl PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
> +       export HASHBANGPERL="/usr/bin/env perl"
> +       export PERL=perl
> +       export PERL5LIB="${S}/external/perl/Text-Template-1.46/lib"
> +       test -d "$PERL5LIB" || bberror "PERL5LIB '$PERL5LIB' not found!"
>         perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} ${DEPRECATED_CRYPTO_FLAGS} --prefix=$useprefix --openssldir=${libdir}/ssl-3 --libdir=${libdir} $target
>         perl ${B}/configdata.pm --dump
>  }
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#183900): https://lists.openembedded.org/g/openembedded-core/message/183900
> Mute This Topic: https://lists.openembedded.org/mt/99970131/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Jose Quaresma July 5, 2023, 6:30 p.m. UTC | #2
Alexander Kanavin <alex.kanavin@gmail.com> escreveu no dia quarta,
5/07/2023 à(s) 19:24:

> There is no need to export the other two variables, they can stay as they
> were.
>

I can add another one just to store the external path and do the check like
PERLEXTERNAL and use it on
PERL5LIB=$PERLEXTERNAL to be less invasive.
In fact we don't even need the PERL5LIB anymore because everything is
working without it as it
currently have a wrong value.

Jose


> Alex
>
>
> On Wed, 5 Jul 2023 at 20:04, Jose Quaresma <quaresma.jose@gmail.com>
> wrote:
> >
> > When upstream change is better to fail or removing the PERL5LIB
> > if they are nott need anymore.
> >
> > Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> > ---
> >  meta/recipes-connectivity/openssl/openssl_3.1.1.bb | 5 ++++-
> >  1 file changed, 4 insertions(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> > index f5f3f32a97..0dce7f71bc 100644
> > --- a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> > +++ b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> > @@ -137,7 +137,10 @@ do_configure () {
> >         fi
> >         # WARNING: do not set compiler/linker flags (-I/-D etc.) in
> EXTRA_OECONF, as they will fully replace the
> >         # environment variables set by bitbake. Adjust the environment
> variables instead.
> > -       HASHBANGPERL="/usr/bin/env perl" PERL=perl
> PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
> > +       export HASHBANGPERL="/usr/bin/env perl"
> > +       export PERL=perl
> > +       export PERL5LIB="${S}/external/perl/Text-Template-1.46/lib"
> > +       test -d "$PERL5LIB" || bberror "PERL5LIB '$PERL5LIB' not found!"
> >         perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS}
> ${DEPRECATED_CRYPTO_FLAGS} --prefix=$useprefix --openssldir=${libdir}/ssl-3
> --libdir=${libdir} $target
> >         perl ${B}/configdata.pm --dump
> >  }
> > --
> > 2.34.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#183900):
> https://lists.openembedded.org/g/openembedded-core/message/183900
> > Mute This Topic: https://lists.openembedded.org/mt/99970131/1686489
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
index f5f3f32a97..0dce7f71bc 100644
--- a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
@@ -137,7 +137,10 @@  do_configure () {
 	fi
 	# WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
 	# environment variables set by bitbake. Adjust the environment variables instead.
-	HASHBANGPERL="/usr/bin/env perl" PERL=perl PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
+	export HASHBANGPERL="/usr/bin/env perl"
+	export PERL=perl
+	export PERL5LIB="${S}/external/perl/Text-Template-1.46/lib"
+	test -d "$PERL5LIB" || bberror "PERL5LIB '$PERL5LIB' not found!"
 	perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} ${DEPRECATED_CRYPTO_FLAGS} --prefix=$useprefix --openssldir=${libdir}/ssl-3 --libdir=${libdir} $target
 	perl ${B}/configdata.pm --dump
 }