diff mbox series

[master] Upgrade flac 1.4.2 => 1.4.3

Message ID 20230626141908.97141-1-sdoshi@mvista.com
State New
Headers show
Series [master] Upgrade flac 1.4.2 => 1.4.3 | expand

Commit Message

Siddharth June 26, 2023, 2:19 p.m. UTC
From: Siddharth Doshi <sdoshi@mvista.com>

Changes:

As there have been additions to the libFLAC interfaces, the libFLAC version number is incremented to 13. The libFLAC++ version number stays at 10.

* General
	* All PowerPC-specific code has been removed, as it turned out those improvements didn't actually improve anything
	* Large improvements in encoder speed for all presets. The largest change is for the fastest presets and for 24-bit and 32-bit inputs.
	* Small improvement in decoder speed for BMI2-capable CPUs
	* Various documentation fixes and cleanups (Mark Grassi, Jake Schmidt)
	* Various fixes (Ozkan Sezer, Zhipeng Xue, orbea, Sam James, Harish Mahendrakar)
	* Fix building on Universal Windows Platform (Dmitry Kostjučenko)
* flac
	* A lot of small fixes for bugs found by fuzzing
	* Various improvements to the --keep-foreign-metadata and --keep-foreign-metadata-if-present options on decoding
		* The output format (WAV/AIFF/RF64 etc.) is now automatically selected based on what kind of foreign metadata is stored
		* Decoded file is checked afterwards, to see whether stored foreign format data agrees with FLAC audio properties
		* AIFF-C sowt data can now be restored
	* Add --force-legacy-wave-format option, to decode to WAV with WAVEFORMATPCM where WAVE_FORMAT_EXTENSIBLE would be more appropriate
	* Add --force-aiff-c-none-format and --force-aiff-c-sowt-format to decode to AIFF-C
	* The storage of WAVEFORMATEXTENSIBLE_CHANNEL_MASK is no longer restricted to known channel orderings
	* Throw an error when WAV or AIFF files are over 4GiB in length and the --ignore-chunk-sizes option is not set
	* Warn on testing files when ID3v2 tags are found
	* Warn when data trails the audio data of a WAV/AIFF/RF64/W64 file
	* Fix output file not being deleted after error on Windows
	* Removal of the --sector--align option
* metaflac
	* A lot of small fixes for bugs found by fuzzing
	* Added options --append and --data-format, which makes it possible to copy metadata blocks from one FLAC file to another
	* Added option --remove-all-tags-except
	* Added option --show-all-tags (harridu, Martijn van Beurden)
* libFLAC
	* No longer write seektables to Ogg, even when specifically asked for. Seektables in Ogg are not defined
	* Add functions FLAC__metadata_object_set_raw and FLAC__metadata_object_get_raw to convert between blob and FLAC__StreamMetadata
* Build system
	* Autoconf (configure)
		* The option --enable-64-bit-words is now on by default
	* CMake
		* The option ENABLE_64_BIT_WORDS is now on by default
* Testing/validation
	* Fuzzers were added for the flac and metaflac command line tools
	* Fuzzer coverage was improved

Signed-off-by: Siddharth Doshi <sdoshi@mvista.com>
---
 .../flac/{flac_1.4.2.bb => flac_1.4.3.bb}              | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)
 rename meta/recipes-multimedia/flac/{flac_1.4.2.bb => flac_1.4.3.bb} (80%)

Comments

Alexander Kanavin June 26, 2023, 9:13 p.m. UTC | #1
On Mon, 26 Jun 2023 at 16:21, Siddharth <sdoshi@mvista.com> wrote:
>  LICENSE = "GFDL-1.2 & GPL-2.0-or-later & LGPL-2.1-or-later & BSD-3-Clause"
>  LIC_FILES_CHKSUM = "file://COPYING.FDL;md5=ad1419ecc56e060eccf8184a87c4285f \
> -                    file://src/Makefile.am;beginline=1;endline=17;md5=146d2c8c2fd287545cc1bd81f31e8758 \
> +                    file://src/Makefile.am;beginline=1;endline=17;md5=b1dab2704be7f01bfbd9b7f6d5f000a9 \
>                      file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> -                    file://src/flac/main.c;beginline=1;endline=18;md5=893456854ce6bf14a1a7ea77266eebab \
> +                    file://src/flac/main.c;beginline=1;endline=18;md5=23099119c034d894bd1bf7ef5bd22101 \
>                      file://COPYING.LGPL;md5=fbc093901857fcd118f065f900982c24 \
> -                    file://COPYING.Xiph;md5=3d6da238b5b57a0965d6730291119f65 \
> +                    file://COPYING.Xiph;md5=0c90e41ab2fa7e69ca9391330d870221 \
>                      file://include/FLAC/all.h;beginline=65;endline=70;md5=39aaf5e03c7364363884c8b8ddda8eea"

If something in license files has changed, the changes need to be
documented in the commit message, and LICENSE needs to be updated if
necessary. Checksums are tracked for that reason: to be able to catch
important changes in upstream licensing terms.

Alex
diff mbox series

Patch

diff --git a/meta/recipes-multimedia/flac/flac_1.4.2.bb b/meta/recipes-multimedia/flac/flac_1.4.3.bb
similarity index 80%
rename from meta/recipes-multimedia/flac/flac_1.4.2.bb
rename to meta/recipes-multimedia/flac/flac_1.4.3.bb
index d3ece3f3cf..9ef9ca75ef 100644
--- a/meta/recipes-multimedia/flac/flac_1.4.2.bb
+++ b/meta/recipes-multimedia/flac/flac_1.4.3.bb
@@ -5,15 +5,15 @@  BUGTRACKER = "https://github.com/xiph/flac/issues"
 SECTION = "libs"
 LICENSE = "GFDL-1.2 & GPL-2.0-or-later & LGPL-2.1-or-later & BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://COPYING.FDL;md5=ad1419ecc56e060eccf8184a87c4285f \
-                    file://src/Makefile.am;beginline=1;endline=17;md5=146d2c8c2fd287545cc1bd81f31e8758 \
+                    file://src/Makefile.am;beginline=1;endline=17;md5=b1dab2704be7f01bfbd9b7f6d5f000a9 \
                     file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
-                    file://src/flac/main.c;beginline=1;endline=18;md5=893456854ce6bf14a1a7ea77266eebab \
+                    file://src/flac/main.c;beginline=1;endline=18;md5=23099119c034d894bd1bf7ef5bd22101 \
                     file://COPYING.LGPL;md5=fbc093901857fcd118f065f900982c24 \
-                    file://COPYING.Xiph;md5=3d6da238b5b57a0965d6730291119f65 \
+                    file://COPYING.Xiph;md5=0c90e41ab2fa7e69ca9391330d870221 \
                     file://include/FLAC/all.h;beginline=65;endline=70;md5=39aaf5e03c7364363884c8b8ddda8eea"
 
 SRC_URI = "http://downloads.xiph.org/releases/flac/${BP}.tar.xz"
-SRC_URI[sha256sum] = "e322d58a1f48d23d9dd38f432672865f6f79e73a6f9cc5a5f57fcaa83eb5a8e4"
+SRC_URI[sha256sum] = "6c58e69cd22348f441b861092b825e591d0b822e106de6eb0ee4d05d27205b70"
 
 CVE_PRODUCT = "libflac flac"
 
@@ -28,8 +28,6 @@  PACKAGECONFIG ??= " \
     ${@bb.utils.filter("TUNE_FEATURES", "altivec vsx", d)} \
     ogg \
 "
-PACKAGECONFIG[altivec] = "--enable-altivec,--disable-altivec"
-PACKAGECONFIG[vsx] = "--enable-vsx,--disable-vsx"
 PACKAGECONFIG[avx] = "--enable-avx,--disable-avx"
 PACKAGECONFIG[ogg] = "--enable-ogg --with-ogg-libraries=${STAGING_LIBDIR} --with-ogg-includes=${STAGING_INCDIR},--disable-ogg,libogg"