diff mbox series

[20/21] libproxy: update 0.4.18 -> 0.5.2

Message ID 20230625212241.915739-20-alex@linutronix.de
State Accepted, archived
Commit bbcfef76c3d412f1a79c77f8712aff36190bf7fa
Headers show
Series [01/21] libxcrypt: upgrade 4.4.34 -> 4.4.35 | expand

Commit Message

Alexander Kanavin June 25, 2023, 9:22 p.m. UTC
License-update: formatting, years

Upstream has completely overhauled the build system
(cmake -> meson) and available options. Add the most
important ones that require external dependencies;
there's plenty more if someone finds them useful.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/lib/oeqa/selftest/cases/bblayers.py      |  3 +-
 .../{libproxy_0.4.18.bb => libproxy_0.5.2.bb} | 29 ++++++-------------
 2 files changed, 11 insertions(+), 21 deletions(-)
 rename meta/recipes-support/libproxy/{libproxy_0.4.18.bb => libproxy_0.5.2.bb} (50%)
diff mbox series

Patch

diff --git a/meta/lib/oeqa/selftest/cases/bblayers.py b/meta/lib/oeqa/selftest/cases/bblayers.py
index b0489483869..8faa0602348 100644
--- a/meta/lib/oeqa/selftest/cases/bblayers.py
+++ b/meta/lib/oeqa/selftest/cases/bblayers.py
@@ -85,8 +85,9 @@  class BitbakeLayers(OESelftestTestCase):
         result = runCmd('bitbake-layers show-recipes -i image')
         self.assertIn('core-image-minimal', result.output)
         self.assertNotIn('mtd-utils:', result.output)
-        result = runCmd('bitbake-layers show-recipes -i cmake,pkgconfig')
+        result = runCmd('bitbake-layers show-recipes -i meson,pkgconfig')
         self.assertIn('libproxy:', result.output)
+        result = runCmd('bitbake-layers show-recipes -i cmake,pkgconfig')
         self.assertNotIn('mtd-utils:', result.output) # doesn't inherit either
         self.assertNotIn('wget:', result.output) # doesn't inherit cmake
         self.assertNotIn('waffle:', result.output) # doesn't inherit pkgconfig
diff --git a/meta/recipes-support/libproxy/libproxy_0.4.18.bb b/meta/recipes-support/libproxy/libproxy_0.5.2.bb
similarity index 50%
rename from meta/recipes-support/libproxy/libproxy_0.4.18.bb
rename to meta/recipes-support/libproxy/libproxy_0.5.2.bb
index 748b1bd2c04..7faec2d3d68 100644
--- a/meta/recipes-support/libproxy/libproxy_0.4.18.bb
+++ b/meta/recipes-support/libproxy/libproxy_0.5.2.bb
@@ -8,32 +8,21 @@  BUGTRACKER = "https://github.com/libproxy/libproxy/issues"
 SECTION = "libs"
 LICENSE = "LGPL-2.1-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
-                    file://utils/proxy.c;beginline=1;endline=18;md5=55152a1006d7dafbef32baf9c30a99c0"
+                    file://src/libproxy/proxy.c;beginline=1;endline=20;md5=bb9a177ef1c995311070f34c5638a402 \
+                   "
 
 DEPENDS = "glib-2.0"
 
 SRC_URI = "git://github.com/libproxy/libproxy;protocol=https;branch=main"
-SRCREV = "caccaf28e3df6ea612d2d4b39f781c4324019fdb"
+SRCREV = "e4f467b05c8adf25e5a2d5464914fc7e92bb7990"
 S = "${WORKDIR}/git"
 
-inherit cmake pkgconfig
+inherit meson pkgconfig gobject-introspection vala gi-docgen
+GIDOCGEN_MESON_OPTION = 'docs'
 
-PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gnome', '', d)} gnome3"
-PACKAGECONFIG[gnome] = "-DWITH_GNOME=yes,-DWITH_GNOME=no,gconf"
-PACKAGECONFIG[gnome3] = "-DWITH_GNOME3=yes,-DWITH_GNOME3=no"
-
-EXTRA_OECMAKE += " \
-    -DWITH_KDE=no \
-    -DWITH_MOZJS=no \
-    -DWITH_NM=no \
-    -DWITH_PERL=no \
-    -DWITH_PYTHON2=no \
-    -DWITH_PYTHON3=no \
-    -DWITH_WEBKIT=no \
-    -DWITH_SYSCONFIG=no \
-    -DLIB_INSTALL_DIR=${libdir} \
-    -DLIBEXEC_INSTALL_DIR=${libexecdir} \
-"
-SECURITY_PIE_CFLAGS:remove = "-fPIE -pie"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[curl] = "-Dcurl=true,-Dcurl=false,curl"
+PACKAGECONFIG[config-gnome] = "-Dconfig-gnome=true,-Dconfig-gnome=false,gsettings-desktop-schemas"
+PACKAGECONFIG[pacrunner-duktape] = "-Dpacrunner-duktape=true,-Dpacrunner-duktape=false,duktape"
 
 FILES:${PN} += "${libdir}/${BPN}/${PV}/modules"