diff mbox series

python3-pygobject: disable features_check for class-native

Message ID 20230623175013.103510-1-f_l_k@t-online.de
State New
Headers show
Series python3-pygobject: disable features_check for class-native | expand

Commit Message

Markus Volk June 23, 2023, 5:50 p.m. UTC
https://git.yoctoproject.org/poky/commit/?id=1ee93dc114df26d94310682e6a632327e8bce062
mandates gobject-introspection-data DISTRO_FEATURE which is not availabe for native.
Thus python3-pygobject-native gets unbuildable

ERROR: Nothing PROVIDES 'python3-pygobject-native'
python3-pygobject-native was skipped: missing required distro feature 'gobject-introspection-data' (not in DISTRO_FEATURES)

Limit the requirement for gobject-introspection-data to class-target

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-devtools/python/python3-pygobject_3.44.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ross Burton June 23, 2023, 6:44 p.m. UTC | #1
On 23 Jun 2023, at 18:50, Markus Volk via lists.openembedded.org <f_l_k=t-online.de@lists.openembedded.org> wrote:
> 
> https://git.yoctoproject.org/poky/commit/?id=1ee93dc114df26d94310682e6a632327e8bce062
> mandates gobject-introspection-data DISTRO_FEATURE which is not availabe for native.
> Thus python3-pygobject-native gets unbuildable
> 
> ERROR: Nothing PROVIDES 'python3-pygobject-native'
> python3-pygobject-native was skipped: missing required distro feature 'gobject-introspection-data' (not in DISTRO_FEATURES)

pygobject can’t work without g-i so this indicates that you need to fix a DEPENDS, not enable the building of an unusable recipe.

Ross
Markus Volk June 24, 2023, 6:48 a.m. UTC | #2
4 recipes in meta-gnome add 'python3-pygobject-native' to DEPENDS.
./meta-networking/recipes-connectivity/networkmanager/networkmanager_1.42.6.bb: 
   python3-pygobject-native \
./meta-gnome/recipes-gnome/gexiv2/gexiv2_0.14.0.bb:DEPENDS = "exiv2 
python3-pygobject-native"
./meta-gnome/recipes-gnome/tracker/tracker_3.5.1.bb:    
python3-pygobject-native \
./meta-gnome/recipes-gnome/libgweather/libgweather4_4.2.0.bb:    
python3-pygobject-native \

Though it seems to me that only the build of libgweather really needs 
it.
<https://gitlab.gnome.org/GNOME/libgweather/-/blob/main/build-aux/meson/gen_locations_variant.py#L7>
<https://gitlab.gnome.org/GNOME/libgweather/-/blob/main/meson.build#L50>


However, I have found that I can build 'python3-pygobject-native' 
without error using DISTRO = "poky". It seems that I have a local 
problem that has caused it to stop working. I will take this 
opportunity to clean up my local.conf and look for the bug. Sorry for 
the noise

Am Fr, 23. Jun 2023 um 18:44:49 +0000 schrieb Ross Burton 
<Ross.Burton@arm.com>:
> On 23 Jun 2023, at 18:50, Markus Volk via lists.openembedded.org 
> <f_l_k=t-online.de@lists.openembedded.org 
> <mailto:f_l_k=t-online.de@lists.openembedded.org>> wrote:
>> 
>>  
>> <https://git.yoctoproject.org/poky/commit/?id=1ee93dc114df26d94310682e6a632327e8bce062>
>>  mandates gobject-introspection-data DISTRO_FEATURE which is not 
>> availabe for native.
>>  Thus python3-pygobject-native gets unbuildable
>> 
>>  ERROR: Nothing PROVIDES 'python3-pygobject-native'
>>  python3-pygobject-native was skipped: missing required distro 
>> feature 'gobject-introspection-data' (not in DISTRO_FEATURES)
> 
> pygobject can’t work without g-i so this indicates that you need to 
> fix a DEPENDS, not enable the building of an unusable recipe.
> 
> Ross
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
index 6f7d9a09ec..f6fb9688ca 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
@@ -10,7 +10,7 @@  GIR_MESON_OPTION = ""
 
 inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even features_check
 
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+REQUIRED_DISTRO_FEATURES:class-target = "gobject-introspection-data"
 
 DEPENDS += "python3 glib-2.0"