diff mbox series

[mickledore] gcc : upgrade to v12.3

Message ID 20230623164055.89846-1-sundeep.kokkonda@windriver.com
State New
Headers show
Series [mickledore] gcc : upgrade to v12.3 | expand

Commit Message

Sundeep KOKKONDA June 23, 2023, 4:40 p.m. UTC
gcc stable version upgraded from v12.2 to v12.3

Below is the bug fix list for v12.3
https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&resolution=FIXED&target_milestone=12.3

Signed-off-by: Sundeep KOKKONDA <sundeep.kokkonda@windriver.com>
---
 meta/recipes-devtools/gcc/{gcc-12.2.inc => gcc-12.3.inc}    | 6 +++---
 ...cc-cross-canadian_12.2.bb => gcc-cross-canadian_12.3.bb} | 0
 .../gcc/{gcc-cross_12.2.bb => gcc-cross_12.3.bb}            | 0
 .../gcc/{gcc-crosssdk_12.2.bb => gcc-crosssdk_12.3.bb}      | 0
 .../gcc/{gcc-runtime_12.2.bb => gcc-runtime_12.3.bb}        | 0
 .../gcc/{gcc-sanitizers_12.2.bb => gcc-sanitizers_12.3.bb}  | 0
 .../gcc/{gcc-source_12.2.bb => gcc-source_12.3.bb}          | 0
 meta/recipes-devtools/gcc/{gcc_12.2.bb => gcc_12.3.bb}      | 0
 .../gcc/{libgcc-initial_12.2.bb => libgcc-initial_12.3.bb}  | 0
 .../recipes-devtools/gcc/{libgcc_12.2.bb => libgcc_12.3.bb} | 0
 .../gcc/{libgfortran_12.2.bb => libgfortran_12.3.bb}        | 0
 11 files changed, 3 insertions(+), 3 deletions(-)
 rename meta/recipes-devtools/gcc/{gcc-12.2.inc => gcc-12.3.inc} (97%)
 rename meta/recipes-devtools/gcc/{gcc-cross-canadian_12.2.bb => gcc-cross-canadian_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-cross_12.2.bb => gcc-cross_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-crosssdk_12.2.bb => gcc-crosssdk_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-runtime_12.2.bb => gcc-runtime_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-sanitizers_12.2.bb => gcc-sanitizers_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-source_12.2.bb => gcc-source_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc_12.2.bb => gcc_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{libgcc-initial_12.2.bb => libgcc-initial_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{libgcc_12.2.bb => libgcc_12.3.bb} (100%)
 rename meta/recipes-devtools/gcc/{libgfortran_12.2.bb => libgfortran_12.3.bb} (100%)

Comments

Randy MacLeod June 24, 2023, 6:06 p.m. UTC | #1
Add Khem since he may want to test meta-oe with the updated toolchain.

On 2023-06-23 12:40, Sundeep KOKKONDA wrote:
> gcc stable version upgraded from v12.2 to v12.3
>
> Below is the bug fix list for v12.3
> https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&resolution=FIXED&target_milestone=12.3

Thanks Sundeep.


Did you run a toochain regression test and if so what are the before, 
after, delta stats
and your summary/analysis of the results?


It isn't a strict requirement but if it's easy, then it's good to copy 
data into the commit log rather than link it.

In this case, there are 129 bugs so that's too much info and a link is 
sensible but
it's nice if it's accompanied with a summary.
I don't think we need a commit log update but I'll summarize what I 
noticed below
to give you an indication of what I'd like to see in future commits.

Most of the bugs linked are "Regression" fixes leaving:

https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3

ID        Product     Comp     Assignee             Summary
103387     gcc     libstdc+    redi                  powerpc64le: 
segmentation fault on std::cout with ieee128 long doubl
109094     gcc     analyzer    dmalcolm        Uninit false positive 
from -fanalyzer when longjmp unwinds frames
106721     gcc     target        jakub               Error: invalid 
character '<' in mnemonic since r13-2122-g86c0d98620e
100103     gcc     fortran       jrfsousa           Automatic 
reallocation fails inside select rank
107551     gcc     target        marxin __builtin_cpu_supports returns a 
negative integer for "x86-64"
98487       gcc     c                 mpolacek       ICE: tree check: 
expected identifier_node, have tree_list in is_attribut
109427     gcc     tree-opt     pinskia param=vect-induction-float= has 
a typo for IntegerRange
103081     gcc     c++           ppalka             [ICE] with "using enum"
107417     gcc     c++           ppalka             g++ fails to 
recognize parameter pack in requires-expression
107542     gcc     c++           ppalka             ICE in 
spaceship_comp_cat, at cp/method.cc:1055
108104     gcc     c++           ppalka             ICE in unify, at 
cp/pt.c:24333 with template partial specialization an
108362     gcc     libstdc+     ppalka            views::istream is 
SFINAE-unfriendly
103755     gcc     libstdc+    redi {has,use}_facet() and iostream 
constructor performance
105678     gcc     libstdc+    redi                  Undefined reference 
to stacktrace standard library
109165     gcc     libstdc+    redi 
std::hash<coroutine_handle<>>::operator() should be const
109182     gcc     libstdc+    redi                  unused parameter 
pack is in expected(in_place_t)
109242     gcc     libstdc+    redi                  C++2b 
std::optional::transform omits required std::remove_cv_t from
99417       gcc     libstdc+    unassigned      [C++17] std::variant 
assignment fails to compile
103325     gcc     tree-opt     unassigned     1 << -1 is never reduced 
to a constant during gimple
106714     gcc     target        unassigned     Incorrect casts in 
macros in amxtileintrin.h
107121     gcc     tree-opt     unassigned     DEFERRED_INIT misspelled 
in error message
107206     gcc     tree-opt     unassigned     Bogus -Wuninitialized in 
std::optional
107713     gcc     target        unassigned     Wrong implementation 
atomic_exchange<short> on LoongArch
108097     gcc     libstdc+    unassigned     std::stacktrace 
AddressSanitizer: new-delete-type-mismatch on 0
109000     gcc     target        xry111            LoongArch: 
"unmatched" -mabi and -mfpu setting can break ABI silent
104554     gcc     fortran       anlauf             ICE in 
check_assumed_size_reference, at fortran/resolv

The idea is to show that you've looked at what changed and though about 
it a bit even if it's
just bug review like I have above.


Html table below for those interested.


Also the release notes are not very helpful ( 
https://gcc.gnu.org/gcc-12/changes.html ):


    GCC 12.3


      Target Specific Changes


      x86-64

  * GCC now supports AMD CPUs based on the |znver4| core via
    |-march=znver4|. The switch makes GCC consider using 512 bit vectors
    when auto-vectorizing.

This is the list of problem reports (PRs) 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&resolution=FIXED&target_milestone=12.3> 
from GCC's bug tracking system that are known to be fixed in the 12.3 
release. This list might not be complete (that is, it is possible that 
some PRs that have been fixed are not listed here).


../Randy


ID 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=bug_id%20DESC&query_based_on=> 
	Product 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=product%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&query_based_on=> 
	Comp 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=component%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&query_based_on=> 
	Assignee▲ 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=assigned_to%20DESC%2Cbug_status%2Cpriority%2Cbug_id&query_based_on=> 
	Status▲ 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=bug_status%20DESC%2Cpriority%2Cassigned_to%2Cbug_id&query_based_on=> 
	Resolution 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=resolution%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&query_based_on=> 
	Summary 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=short_desc%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&query_based_on=> 
	Changed 
<https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&cf_known_to_fail_type=allwords&cf_known_to_work_type=allwords&product=gcc&query_format=advanced&resolution=FIXED&short_desc=Regression&short_desc_type=notregexp&target_milestone=12.3&order=changeddate%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&query_based_on=> 

103387 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103387> 	gcc 
libstdc+ 	redi 	RESO 	FIXE 	powerpc64le: segmentation fault on std::cout 
with ieee128 long double variable 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103387> 	2023-04-21
109094 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109094> 	gcc 
analyzer 	dmalcolm 	RESO 	FIXE 	Uninit false positive from -fanalyzer 
when longjmp unwinds frames with return stmts 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109094> 	2023-03-29
106721 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106721> 	gcc 
target 	jakub 	RESO 	FIXE 	Error: invalid character '<' in mnemonic 
since r13-2122-g86c0d98620ee3a 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106721> 	2023-03-20
100103 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100103> 	gcc 
fortran 	jrfsousa 	RESO 	FIXE 	Automatic reallocation fails inside 
select rank <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100103> 
2022-10-01
107551 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107551> 	gcc 
target 	marxin 	RESO 	FIXE 	__builtin_cpu_supports returns a negative 
integer for "x86-64" 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107551> 	2022-12-09
98487 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=98487> 	gcc 	c 
mpolacek 	RESO 	FIXE 	ICE: tree check: expected identifier_node, have 
tree_list in is_attribute_p, at attribs.h:155 [C2X or C++11 attribute 
syntax, gnu::format and -Wsuggest-attribute=format] or a suggest warning 
(release checking) <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=98487> 
2022-12-19
109427 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109427> 	gcc 
tree-opt 	pinskia 	RESO 	FIXE 	param=vect-induction-float= has a typo 
for IntegerRange <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109427> 
2023-04-06
103081 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103081> 	gcc 	c++ 
ppalka 	RESO 	FIXE 	[ICE] with "using enum" 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103081> 	2022-12-19
107417 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107417> 	gcc 	c++ 
ppalka 	RESO 	FIXE 	g++ fails to recognize parameter pack in 
requires-expression 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107417> 	2022-12-19
107542 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107542> 	gcc 	c++ 
ppalka 	RESO 	FIXE 	ICE in spaceship_comp_cat, at cp/method.cc:1055 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107542> 	2022-12-19
108104 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=108104> 	gcc 	c++ 
ppalka 	RESO 	FIXE 	ICE in unify, at cp/pt.c:24333 with template partial 
specialization and pointer to memeber function and nullptr 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=108104> 	2022-12-19
108362 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=108362> 	gcc 
libstdc+ 	ppalka 	RESO 	FIXE 	views::istream is SFINAE-unfriendly 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=108362> 	2023-04-29
103755 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103755> 	gcc 
libstdc+ 	redi 	RESO 	FIXE 	{has,use}_facet() and iostream constructor 
performance <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103755> 
2023-04-21
105678 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105678> 	gcc 
libstdc+ 	redi 	RESO 	FIXE 	Undefined reference to stacktrace standard 
library <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105678> 	2022-08-23
109165 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109165> 	gcc 
libstdc+ 	redi 	RESO 	FIXE 	std::hash<coroutine_handle<>>::operator() 
should be const <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109165> 
2023-03-20
109182 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109182> 	gcc 
libstdc+ 	redi 	RESO 	FIXE 	unused parameter pack is in 
expected(in_place_t) 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109182> 	2023-03-20
109242 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109242> 	gcc 
libstdc+ 	redi 	RESO 	FIXE 	C++2b std::optional::transform omits 
required std::remove_cv_t from return optional type 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109242> 	2023-03-30
99417 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99417> 	gcc 
libstdc+ 	unassigned 	RESO 	FIXE 	[C++17] std::variant assignment fails 
to compile <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99417> 	2023-05-16
103325 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103325> 	gcc 
tree-opt 	unassigned 	RESO 	FIXE 	1 << -1 is never reduced to a constant 
during gimple <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103325> 
2023-05-28
106714 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106714> 	gcc 
target 	unassigned 	RESO 	FIXE 	Incorrect casts in macros in 
amxtileintrin.h <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106714> 
2022-08-29
107121 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107121> 	gcc 
tree-opt 	unassigned 	RESO 	FIXE 	DEFERRED_INIT misspelled in error 
message <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107121> 	2022-11-28
107206 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107206> 	gcc 
tree-opt 	unassigned 	RESO 	FIXE 	Bogus -Wuninitialized in std::optional 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107206> 	2022-11-28
107713 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107713> 	gcc 
target 	unassigned 	RESO 	FIXE 	Wrong implementation 
atomic_exchange<short> on LoongArch 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107713> 	2022-11-20
108097 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=108097> 	gcc 
libstdc+ 	unassigned 	RESO 	FIXE 	std::stacktrace AddressSanitizer: 
new-delete-type-mismatch on 0x615000000080 in thread T0 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=108097> 	2022-12-14
109000 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109000> 	gcc 
target 	xry111 	RESO 	FIXE 	LoongArch: "unmatched" -mabi and -mfpu 
setting can break ABI silently 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109000> 	2023-03-06
104554 <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104554> 	gcc 
fortran 	anlauf 	RESO 	FIXE 	ICE in check_assumed_size_reference, at 
fortran/resolve.cc:1650 
<https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104554>


Sorry for the HTML table but hopefully people can read it.


>
> Signed-off-by: Sundeep KOKKONDA<sundeep.kokkonda@windriver.com>
> ---
>   meta/recipes-devtools/gcc/{gcc-12.2.inc => gcc-12.3.inc}    | 6 +++---
>   ...cc-cross-canadian_12.2.bb => gcc-cross-canadian_12.3.bb} | 0
>   .../gcc/{gcc-cross_12.2.bb => gcc-cross_12.3.bb}            | 0
>   .../gcc/{gcc-crosssdk_12.2.bb => gcc-crosssdk_12.3.bb}      | 0
>   .../gcc/{gcc-runtime_12.2.bb => gcc-runtime_12.3.bb}        | 0
>   .../gcc/{gcc-sanitizers_12.2.bb => gcc-sanitizers_12.3.bb}  | 0
>   .../gcc/{gcc-source_12.2.bb => gcc-source_12.3.bb}          | 0
>   meta/recipes-devtools/gcc/{gcc_12.2.bb => gcc_12.3.bb}      | 0
>   .../gcc/{libgcc-initial_12.2.bb => libgcc-initial_12.3.bb}  | 0
>   .../recipes-devtools/gcc/{libgcc_12.2.bb => libgcc_12.3.bb} | 0
>   .../gcc/{libgfortran_12.2.bb => libgfortran_12.3.bb}        | 0
>   11 files changed, 3 insertions(+), 3 deletions(-)
>   rename meta/recipes-devtools/gcc/{gcc-12.2.inc => gcc-12.3.inc} (97%)
>   rename meta/recipes-devtools/gcc/{gcc-cross-canadian_12.2.bb => gcc-cross-canadian_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{gcc-cross_12.2.bb => gcc-cross_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{gcc-crosssdk_12.2.bb => gcc-crosssdk_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{gcc-runtime_12.2.bb => gcc-runtime_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{gcc-sanitizers_12.2.bb => gcc-sanitizers_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{gcc-source_12.2.bb => gcc-source_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{gcc_12.2.bb => gcc_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{libgcc-initial_12.2.bb => libgcc-initial_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{libgcc_12.2.bb => libgcc_12.3.bb} (100%)
>   rename meta/recipes-devtools/gcc/{libgfortran_12.2.bb => libgfortran_12.3.bb} (100%)
>
> diff --git a/meta/recipes-devtools/gcc/gcc-12.2.inc b/meta/recipes-devtools/gcc/gcc-12.3.inc
> similarity index 97%
> rename from meta/recipes-devtools/gcc/gcc-12.2.inc
> rename to meta/recipes-devtools/gcc/gcc-12.3.inc
> index 0dbbecad4a..4ec03f925c 100644
> --- a/meta/recipes-devtools/gcc/gcc-12.2.inc
> +++ b/meta/recipes-devtools/gcc/gcc-12.3.inc
> @@ -2,11 +2,11 @@ require gcc-common.inc
>   
>   # Third digit in PV should be incremented after a minor release
>   
> -PV = "12.2.0"
> +PV = "12.3.0"
>   
>   # BINV should be incremented to a revision after a minor gcc release
>   
> -BINV = "12.2.0"
> +BINV = "12.3.0"
>   
>   FILESEXTRAPATHS =. "${FILE_DIRNAME}/gcc:${FILE_DIRNAME}/gcc/backport:"
>   
> @@ -64,7 +64,7 @@ SRC_URI = "${BASEURI} \
>              file://prefix-map-realpath.patch  \
>              file://hardcoded-paths.patch  \
>   "
> -SRC_URI[sha256sum] = "e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff"
> +SRC_URI[sha256sum] = "949a5d4f99e786421a93b532b22ffab5578de7321369975b91aec97adfda8c3b"
>   
>   S = "${TMPDIR}/work-shared/gcc-${PV}-${PR}/${SOURCEDIR}"
>   B = "${WORKDIR}/gcc-${PV}/build.${HOST_SYS}.${TARGET_SYS}"
> diff --git a/meta/recipes-devtools/gcc/gcc-cross-canadian_12.2.bb b/meta/recipes-devtools/gcc/gcc-cross-canadian_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/gcc-cross-canadian_12.2.bb
> rename to meta/recipes-devtools/gcc/gcc-cross-canadian_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/gcc-cross_12.2.bb b/meta/recipes-devtools/gcc/gcc-cross_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/gcc-cross_12.2.bb
> rename to meta/recipes-devtools/gcc/gcc-cross_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk_12.2.bb b/meta/recipes-devtools/gcc/gcc-crosssdk_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/gcc-crosssdk_12.2.bb
> rename to meta/recipes-devtools/gcc/gcc-crosssdk_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/gcc-runtime_12.2.bb b/meta/recipes-devtools/gcc/gcc-runtime_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/gcc-runtime_12.2.bb
> rename to meta/recipes-devtools/gcc/gcc-runtime_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/gcc-sanitizers_12.2.bb b/meta/recipes-devtools/gcc/gcc-sanitizers_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/gcc-sanitizers_12.2.bb
> rename to meta/recipes-devtools/gcc/gcc-sanitizers_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/gcc-source_12.2.bb b/meta/recipes-devtools/gcc/gcc-source_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/gcc-source_12.2.bb
> rename to meta/recipes-devtools/gcc/gcc-source_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/gcc_12.2.bb b/meta/recipes-devtools/gcc/gcc_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/gcc_12.2.bb
> rename to meta/recipes-devtools/gcc/gcc_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/libgcc-initial_12.2.bb b/meta/recipes-devtools/gcc/libgcc-initial_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/libgcc-initial_12.2.bb
> rename to meta/recipes-devtools/gcc/libgcc-initial_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/libgcc_12.2.bb b/meta/recipes-devtools/gcc/libgcc_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/libgcc_12.2.bb
> rename to meta/recipes-devtools/gcc/libgcc_12.3.bb
> diff --git a/meta/recipes-devtools/gcc/libgfortran_12.2.bb b/meta/recipes-devtools/gcc/libgfortran_12.3.bb
> similarity index 100%
> rename from meta/recipes-devtools/gcc/libgfortran_12.2.bb
> rename to meta/recipes-devtools/gcc/libgfortran_12.3.bb
diff mbox series

Patch

diff --git a/meta/recipes-devtools/gcc/gcc-12.2.inc b/meta/recipes-devtools/gcc/gcc-12.3.inc
similarity index 97%
rename from meta/recipes-devtools/gcc/gcc-12.2.inc
rename to meta/recipes-devtools/gcc/gcc-12.3.inc
index 0dbbecad4a..4ec03f925c 100644
--- a/meta/recipes-devtools/gcc/gcc-12.2.inc
+++ b/meta/recipes-devtools/gcc/gcc-12.3.inc
@@ -2,11 +2,11 @@  require gcc-common.inc
 
 # Third digit in PV should be incremented after a minor release
 
-PV = "12.2.0"
+PV = "12.3.0"
 
 # BINV should be incremented to a revision after a minor gcc release
 
-BINV = "12.2.0"
+BINV = "12.3.0"
 
 FILESEXTRAPATHS =. "${FILE_DIRNAME}/gcc:${FILE_DIRNAME}/gcc/backport:"
 
@@ -64,7 +64,7 @@  SRC_URI = "${BASEURI} \
            file://prefix-map-realpath.patch \
            file://hardcoded-paths.patch \
 "
-SRC_URI[sha256sum] = "e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff"
+SRC_URI[sha256sum] = "949a5d4f99e786421a93b532b22ffab5578de7321369975b91aec97adfda8c3b"
 
 S = "${TMPDIR}/work-shared/gcc-${PV}-${PR}/${SOURCEDIR}"
 B = "${WORKDIR}/gcc-${PV}/build.${HOST_SYS}.${TARGET_SYS}"
diff --git a/meta/recipes-devtools/gcc/gcc-cross-canadian_12.2.bb b/meta/recipes-devtools/gcc/gcc-cross-canadian_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-cross-canadian_12.2.bb
rename to meta/recipes-devtools/gcc/gcc-cross-canadian_12.3.bb
diff --git a/meta/recipes-devtools/gcc/gcc-cross_12.2.bb b/meta/recipes-devtools/gcc/gcc-cross_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-cross_12.2.bb
rename to meta/recipes-devtools/gcc/gcc-cross_12.3.bb
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk_12.2.bb b/meta/recipes-devtools/gcc/gcc-crosssdk_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-crosssdk_12.2.bb
rename to meta/recipes-devtools/gcc/gcc-crosssdk_12.3.bb
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_12.2.bb b/meta/recipes-devtools/gcc/gcc-runtime_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-runtime_12.2.bb
rename to meta/recipes-devtools/gcc/gcc-runtime_12.3.bb
diff --git a/meta/recipes-devtools/gcc/gcc-sanitizers_12.2.bb b/meta/recipes-devtools/gcc/gcc-sanitizers_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-sanitizers_12.2.bb
rename to meta/recipes-devtools/gcc/gcc-sanitizers_12.3.bb
diff --git a/meta/recipes-devtools/gcc/gcc-source_12.2.bb b/meta/recipes-devtools/gcc/gcc-source_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-source_12.2.bb
rename to meta/recipes-devtools/gcc/gcc-source_12.3.bb
diff --git a/meta/recipes-devtools/gcc/gcc_12.2.bb b/meta/recipes-devtools/gcc/gcc_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc_12.2.bb
rename to meta/recipes-devtools/gcc/gcc_12.3.bb
diff --git a/meta/recipes-devtools/gcc/libgcc-initial_12.2.bb b/meta/recipes-devtools/gcc/libgcc-initial_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/libgcc-initial_12.2.bb
rename to meta/recipes-devtools/gcc/libgcc-initial_12.3.bb
diff --git a/meta/recipes-devtools/gcc/libgcc_12.2.bb b/meta/recipes-devtools/gcc/libgcc_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/libgcc_12.2.bb
rename to meta/recipes-devtools/gcc/libgcc_12.3.bb
diff --git a/meta/recipes-devtools/gcc/libgfortran_12.2.bb b/meta/recipes-devtools/gcc/libgfortran_12.3.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/libgfortran_12.2.bb
rename to meta/recipes-devtools/gcc/libgfortran_12.3.bb