diff mbox series

linux-yocto/6.1: fix intermittent x86 boot hangs

Message ID 20230615031608.29371-1-bruce.ashfield@gmail.com
State New
Headers show
Series linux-yocto/6.1: fix intermittent x86 boot hangs | expand

Commit Message

Bruce Ashfield June 15, 2023, 3:16 a.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

The commit in question appeared as -stable backport in 6.1.28, which is
where we started to see intermittent boot hangs on x86.

Richard noted that others are seeing this is well, as can be seen in
this thread:

    https://lkml.org/lkml/2023/6/13/1460

We bump our SRCREVs to pick up the revert:

    947f660bde07 Revert "tick/common: Align tick period with the HZ tick."

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---

Richard,

As requested here is the revert of the x86 clock fix that is suspect.

You'll need to restore the other dropped linux-yocto version bumps
to apply this patch.

Bruce

 .../linux/linux-yocto-rt_6.1.bb               |  4 ++--
 .../linux/linux-yocto-tiny_6.1.bb             |  4 ++--
 meta/recipes-kernel/linux/linux-yocto_6.1.bb  | 24 +++++++++----------
 3 files changed, 16 insertions(+), 16 deletions(-)

Comments

Richard Purdie June 15, 2023, 6:59 a.m. UTC | #1
On Wed, 2023-06-14 at 23:16 -0400, bruce.ashfield@gmail.com wrote:
> From: Bruce Ashfield <bruce.ashfield@gmail.com>
> 
> The commit in question appeared as -stable backport in 6.1.28, which is
> where we started to see intermittent boot hangs on x86.
> 
> Richard noted that others are seeing this is well, as can be seen in
> this thread:
> 
>     https://lkml.org/lkml/2023/6/13/1460
> 
> We bump our SRCREVs to pick up the revert:
> 
>     947f660bde07 Revert "tick/common: Align tick period with the HZ tick."
> 
> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
> 
> Richard,
> 
> As requested here is the revert of the x86 clock fix that is suspect.
> 
> You'll need to restore the other dropped linux-yocto version bumps
> to apply this patch.

Thanks!

I don't think 6.1.33 was sent out publicly and isn't in OE-Core yet.  I
couldn't see it in your public branches either, only 6.1.30 is there.

I hacked this patch to apply against 6.1.32 for testing purposes (and
included a version bump to hopefully let it build). We can work out
what I suspect is a missing patch later today, this hack is only for
testing.

Cheers,

Richard
Bruce Ashfield June 15, 2023, 11:56 a.m. UTC | #2
On Thu, Jun 15, 2023 at 2:59 AM Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
>
> On Wed, 2023-06-14 at 23:16 -0400, bruce.ashfield@gmail.com wrote:
> > From: Bruce Ashfield <bruce.ashfield@gmail.com>
> >
> > The commit in question appeared as -stable backport in 6.1.28, which is
> > where we started to see intermittent boot hangs on x86.
> >
> > Richard noted that others are seeing this is well, as can be seen in
> > this thread:
> >
> >     https://lkml.org/lkml/2023/6/13/1460
> >
> > We bump our SRCREVs to pick up the revert:
> >
> >     947f660bde07 Revert "tick/common: Align tick period with the HZ tick."
> >
> > Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
> > ---
> >
> > Richard,
> >
> > As requested here is the revert of the x86 clock fix that is suspect.
> >
> > You'll need to restore the other dropped linux-yocto version bumps
> > to apply this patch.
>
> Thanks!
>
> I don't think 6.1.33 was sent out publicly and isn't in OE-Core yet.  I
> couldn't see it in your public branches either, only 6.1.30 is there.
>

I realized that as soon as I woke up this morning. I'm about to send
the .33 patch
(I obviously had it here). I was sitting on it, once it was clear a new -stable
wasn't going to magically fix it for us.

Bruce

> I hacked this patch to apply against 6.1.32 for testing purposes (and
> included a version bump to hopefully let it build). We can work out
> what I suspect is a missing patch later today, this hack is only for
> testing.
>
> Cheers,
>
> Richard
Steve Sakoman July 16, 2023, 7:35 p.m. UTC | #3
On Wed, Jun 14, 2023 at 5:16 PM Bruce Ashfield <bruce.ashfield@gmail.com> wrote:
>
> From: Bruce Ashfield <bruce.ashfield@gmail.com>
>
> The commit in question appeared as -stable backport in 6.1.28, which is
> where we started to see intermittent boot hangs on x86.
>
> Richard noted that others are seeing this is well, as can be seen in
> this thread:
>
>     https://lkml.org/lkml/2023/6/13/1460
>
> We bump our SRCREVs to pick up the revert:
>
>     947f660bde07 Revert "tick/common: Align tick period with the HZ tick."
>

Unfortunately I am seeing something quite similar on Kirkstone with 5.15.118:

[    0.222916] Freeing SMP alternatives memory: 48K
[274824.332965] smpboot: CPU0: Intel Xeon E3-12xx v2 (Ivy Bridge)
(family: 0x6, model: 0x3a, stepping: 0x9)

Full log:

https://errors.yoctoproject.org/Errors/Details/716736/

So I suspect we will need the same fix there too :-(

Steve

>
> As requested here is the revert of the x86 clock fix that is suspect.
>
> You'll need to restore the other dropped linux-yocto version bumps
> to apply this patch.
>
> Bruce
>
>  .../linux/linux-yocto-rt_6.1.bb               |  4 ++--
>  .../linux/linux-yocto-tiny_6.1.bb             |  4 ++--
>  meta/recipes-kernel/linux/linux-yocto_6.1.bb  | 24 +++++++++----------
>  3 files changed, 16 insertions(+), 16 deletions(-)
>
> diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
> index 4a2a3ca4ab..1033d307f4 100644
> --- a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
> @@ -14,8 +14,8 @@ python () {
>          raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
>  }
>
> -SRCREV_machine ?= "6871194107bd40397162bfca0a9ef06661057c50"
> -SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
> +SRCREV_machine ?= "2993cbe41f0f859331c81d6ec8001b094f53cb9e"
> +SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
>
>  SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
>             git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"
> diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
> index bfc1c7652c..2be9eb9c36 100644
> --- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
> @@ -17,8 +17,8 @@ DEPENDS += "openssl-native util-linux-native"
>  KMETA = "kernel-meta"
>  KCONF_BSP_AUDIT_LEVEL = "2"
>
> -SRCREV_machine ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
> +SRCREV_machine ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
>
>  PV = "${LINUX_VERSION}+git${SRCPV}"
>
> diff --git a/meta/recipes-kernel/linux/linux-yocto_6.1.bb b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
> index 53a583e0a3..f5554e26db 100644
> --- a/meta/recipes-kernel/linux/linux-yocto_6.1.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
> @@ -20,18 +20,18 @@ KBRANCH:qemux86-64 ?= "v6.1/standard/base"
>  KBRANCH:qemuloongarch64  ?= "v6.1/standard/base"
>  KBRANCH:qemumips64 ?= "v6.1/standard/mti-malta64"
>
> -SRCREV_machine:qemuarm ?= "cff918ff5ee0001dec6493620535d8804f02cd8b"
> -SRCREV_machine:qemuarm64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_machine:qemuloongarch64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_machine:qemumips ?= "7a59adc4cd39bea852101be2873855cfc835ef45"
> -SRCREV_machine:qemuppc ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_machine:qemuriscv64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_machine:qemuriscv32 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_machine:qemux86 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_machine:qemux86-64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_machine:qemumips64 ?= "273e099163a72247262a495cb73889d2e0ed6d2c"
> -SRCREV_machine ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> -SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
> +SRCREV_machine:qemuarm ?= "93797f49c15b6ce9656a607626437e76a3b6c6da"
> +SRCREV_machine:qemuarm64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_machine:qemuloongarch64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_machine:qemumips ?= "1279631d08d52a5b20044404da4b01205ba4b725"
> +SRCREV_machine:qemuppc ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_machine:qemuriscv64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_machine:qemuriscv32 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_machine:qemux86 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_machine:qemux86-64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_machine:qemumips64 ?= "3b25f845f704021fbe223ef48ab22ff5fa3886b9"
> +SRCREV_machine ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> +SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
>
>  # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
>  # get the <version>/base branch, which is pure upstream -stable, and the same
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#182828): https://lists.openembedded.org/g/openembedded-core/message/182828
> Mute This Topic: https://lists.openembedded.org/mt/99542122/3620601
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [steve@sakoman.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Bruce Ashfield July 16, 2023, 9:42 p.m. UTC | #4
On Sun, Jul 16, 2023 at 3:35 PM Steve Sakoman <steve@sakoman.com> wrote:
>
> On Wed, Jun 14, 2023 at 5:16 PM Bruce Ashfield <bruce.ashfield@gmail.com> wrote:
> >
> > From: Bruce Ashfield <bruce.ashfield@gmail.com>
> >
> > The commit in question appeared as -stable backport in 6.1.28, which is
> > where we started to see intermittent boot hangs on x86.
> >
> > Richard noted that others are seeing this is well, as can be seen in
> > this thread:
> >
> >     https://lkml.org/lkml/2023/6/13/1460
> >
> > We bump our SRCREVs to pick up the revert:
> >
> >     947f660bde07 Revert "tick/common: Align tick period with the HZ tick."
> >
>
> Unfortunately I am seeing something quite similar on Kirkstone with 5.15.118:
>
> [    0.222916] Freeing SMP alternatives memory: 48K
> [274824.332965] smpboot: CPU0: Intel Xeon E3-12xx v2 (Ivy Bridge)
> (family: 0x6, model: 0x3a, stepping: 0x9)
>
> Full log:
>
> https://errors.yoctoproject.org/Errors/Details/716736/
>
> So I suspect we will need the same fix there too :-(

That fix is obselete.

There's a proper upstream fix for it and going through the -stable trees now.

5.15.119+ has the fix, and I'll get to those updates shortly.

Bruce

>
> Steve
>
> >
> > As requested here is the revert of the x86 clock fix that is suspect.
> >
> > You'll need to restore the other dropped linux-yocto version bumps
> > to apply this patch.
> >
> > Bruce
> >
> >  .../linux/linux-yocto-rt_6.1.bb               |  4 ++--
> >  .../linux/linux-yocto-tiny_6.1.bb             |  4 ++--
> >  meta/recipes-kernel/linux/linux-yocto_6.1.bb  | 24 +++++++++----------
> >  3 files changed, 16 insertions(+), 16 deletions(-)
> >
> > diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
> > index 4a2a3ca4ab..1033d307f4 100644
> > --- a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
> > +++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
> > @@ -14,8 +14,8 @@ python () {
> >          raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
> >  }
> >
> > -SRCREV_machine ?= "6871194107bd40397162bfca0a9ef06661057c50"
> > -SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
> > +SRCREV_machine ?= "2993cbe41f0f859331c81d6ec8001b094f53cb9e"
> > +SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
> >
> >  SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
> >             git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"
> > diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
> > index bfc1c7652c..2be9eb9c36 100644
> > --- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
> > +++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
> > @@ -17,8 +17,8 @@ DEPENDS += "openssl-native util-linux-native"
> >  KMETA = "kernel-meta"
> >  KCONF_BSP_AUDIT_LEVEL = "2"
> >
> > -SRCREV_machine ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
> > +SRCREV_machine ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
> >
> >  PV = "${LINUX_VERSION}+git${SRCPV}"
> >
> > diff --git a/meta/recipes-kernel/linux/linux-yocto_6.1.bb b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
> > index 53a583e0a3..f5554e26db 100644
> > --- a/meta/recipes-kernel/linux/linux-yocto_6.1.bb
> > +++ b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
> > @@ -20,18 +20,18 @@ KBRANCH:qemux86-64 ?= "v6.1/standard/base"
> >  KBRANCH:qemuloongarch64  ?= "v6.1/standard/base"
> >  KBRANCH:qemumips64 ?= "v6.1/standard/mti-malta64"
> >
> > -SRCREV_machine:qemuarm ?= "cff918ff5ee0001dec6493620535d8804f02cd8b"
> > -SRCREV_machine:qemuarm64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_machine:qemuloongarch64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_machine:qemumips ?= "7a59adc4cd39bea852101be2873855cfc835ef45"
> > -SRCREV_machine:qemuppc ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_machine:qemuriscv64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_machine:qemuriscv32 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_machine:qemux86 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_machine:qemux86-64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_machine:qemumips64 ?= "273e099163a72247262a495cb73889d2e0ed6d2c"
> > -SRCREV_machine ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
> > -SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
> > +SRCREV_machine:qemuarm ?= "93797f49c15b6ce9656a607626437e76a3b6c6da"
> > +SRCREV_machine:qemuarm64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_machine:qemuloongarch64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_machine:qemumips ?= "1279631d08d52a5b20044404da4b01205ba4b725"
> > +SRCREV_machine:qemuppc ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_machine:qemuriscv64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_machine:qemuriscv32 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_machine:qemux86 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_machine:qemux86-64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_machine:qemumips64 ?= "3b25f845f704021fbe223ef48ab22ff5fa3886b9"
> > +SRCREV_machine ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
> > +SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
> >
> >  # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
> >  # get the <version>/base branch, which is pure upstream -stable, and the same
> > --
> > 2.34.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#182828): https://lists.openembedded.org/g/openembedded-core/message/182828
> > Mute This Topic: https://lists.openembedded.org/mt/99542122/3620601
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [steve@sakoman.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
index 4a2a3ca4ab..1033d307f4 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
@@ -14,8 +14,8 @@  python () {
         raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "6871194107bd40397162bfca0a9ef06661057c50"
-SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
+SRCREV_machine ?= "2993cbe41f0f859331c81d6ec8001b094f53cb9e"
+SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
index bfc1c7652c..2be9eb9c36 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
@@ -17,8 +17,8 @@  DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
+SRCREV_machine ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.1.bb b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
index 53a583e0a3..f5554e26db 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
@@ -20,18 +20,18 @@  KBRANCH:qemux86-64 ?= "v6.1/standard/base"
 KBRANCH:qemuloongarch64  ?= "v6.1/standard/base"
 KBRANCH:qemumips64 ?= "v6.1/standard/mti-malta64"
 
-SRCREV_machine:qemuarm ?= "cff918ff5ee0001dec6493620535d8804f02cd8b"
-SRCREV_machine:qemuarm64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_machine:qemuloongarch64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_machine:qemumips ?= "7a59adc4cd39bea852101be2873855cfc835ef45"
-SRCREV_machine:qemuppc ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_machine:qemuriscv64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_machine:qemuriscv32 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_machine:qemux86 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_machine:qemux86-64 ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_machine:qemumips64 ?= "273e099163a72247262a495cb73889d2e0ed6d2c"
-SRCREV_machine ?= "6034b10d39687bbd6769e4adb2a792524e6b4f16"
-SRCREV_meta ?= "1dd270d3231f82d94d2123b95e4eb576019440a3"
+SRCREV_machine:qemuarm ?= "93797f49c15b6ce9656a607626437e76a3b6c6da"
+SRCREV_machine:qemuarm64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_machine:qemuloongarch64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_machine:qemumips ?= "1279631d08d52a5b20044404da4b01205ba4b725"
+SRCREV_machine:qemuppc ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_machine:qemuriscv64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_machine:qemuriscv32 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_machine:qemux86 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_machine:qemux86-64 ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_machine:qemumips64 ?= "3b25f845f704021fbe223ef48ab22ff5fa3886b9"
+SRCREV_machine ?= "947f660bde07ee4111bc96d08b142a6ce3753d38"
+SRCREV_meta ?= "db25e51e2006721528f5e7bcd8f4501592bd74fe"
 
 # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
 # get the <version>/base branch, which is pure upstream -stable, and the same