diff mbox series

python3-psutil: Drop nativesdk class extension due to breakage

Message ID 20230502214430.2927913-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit e1c9cbe8b14c259c30df375d3f8c1bd9b3a818fa
Headers show
Series python3-psutil: Drop nativesdk class extension due to breakage | expand

Commit Message

Richard Purdie May 2, 2023, 9:44 p.m. UTC
We're seeing warnings like:

WARNING: Nothing RPROVIDES 'nativesdk-procps' (but virtual:nativesdk:XXX/python3-psutil_5.9.4.bb RDEPENDS on or otherwise requires it)
WARNING: Nothing RPROVIDES 'nativesdk-python3-psutil-dev' (but virtual:nativesdk:XXX/python3-psutil_5.9.4.bb RDEPENDS on or otherwise requires it)
WARNING: Nothing RPROVIDES 'nativesdk-python3-psutil' (but virtual:nativesdk:XXX/python3-psutil_5.9.4.bb RDEPENDS on or otherwise requires it)

which means this likely has never been working in the first place. Drop it
until it is needed and fixed to work.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/python/python3-psutil_5.9.4.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-psutil_5.9.4.bb b/meta/recipes-devtools/python/python3-psutil_5.9.4.bb
index c0977c74d30..019ea2dec15 100644
--- a/meta/recipes-devtools/python/python3-psutil_5.9.4.bb
+++ b/meta/recipes-devtools/python/python3-psutil_5.9.4.bb
@@ -38,4 +38,4 @@  RDEPENDS:${PN}-tests += " \
 
 INSANE_SKIP:${PN}-tests += "dev-deps"
 
-BBCLASSEXTEND = "native nativesdk"
+BBCLASSEXTEND = "native"