diff mbox series

[1/5] python3-pyproject-hooks: add missing run-time dependencies

Message ID 20230413091557.10659-2-brgl@bgdev.pl
State Accepted, archived
Commit f886fe227fe91d0d1566e3ddb01856d7e67a8a2d
Headers show
Series python3: fix run-time availability of python3-build | expand

Commit Message

Bartosz Golaszewski April 13, 2023, 9:15 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

JSON module is required at run-time by pyproject-hooks.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb b/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb
index 9aca5918ec..e3893d51cb 100644
--- a/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb
+++ b/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb
@@ -14,6 +14,8 @@  BBCLASSEXTEND = "native nativesdk"
 # Bootstrap the native build
 DEPENDS:remove:class-native = "python3-build-native"
 
+RDEPENDS:${PN} += "python3-json"
+
 do_compile:class-native () {
     python_flit_core_do_manual_build
 }