diff mbox series

cve-update-nvd2-native: added the missing http import

Message ID 20230412101926.1135184-1-jan.vermaete@gmail.com
State New
Headers show
Series cve-update-nvd2-native: added the missing http import | expand

Commit Message

Jan Vermaete April 12, 2023, 10:19 a.m. UTC
Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 meta/recipes-core/meta/cve-update-nvd2-native.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Yoann Congal April 12, 2023, 11:36 a.m. UTC | #1
Hi,

On 4/12/23 12:19, Jan Vermaete wrote:
> Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
> ---
>  meta/recipes-core/meta/cve-update-nvd2-native.bb | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-core/meta/cve-update-nvd2-native.bb b/meta/recipes-core/meta/cve-update-nvd2-native.bb
> index 1c14481c21..2b585983ac 100644
> --- a/meta/recipes-core/meta/cve-update-nvd2-native.bb
> +++ b/meta/recipes-core/meta/cve-update-nvd2-native.bb
> @@ -118,6 +118,7 @@ def nvd_request_next(url, api_key, args):
>      import urllib.request
>      import urllib.parse
>      import gzip
> +    import http

If this is only for the "except http.client.IncompleteRead:" line 146[1], wouldn't it be better to fix the catched exception to match what urllib can
 throw or to remove the except block entirely?

I've triggered the same error as you but chose to remove the except block to get my code running.

[1]: https://git.yoctoproject.org/poky/tree/meta/recipes-core/meta/cve-update-nvd2-native.bb#n146

>  
>      headers = {}
>      if api_key:

Regards,
Jan Vermaete April 12, 2023, 11:45 a.m. UTC | #2
Hi,

I have no preference on how to fix it.
I intended to stay as close as possible to the code of Marta

Br.

On Wed, Apr 12, 2023 at 1:36 PM Yoann Congal <yoann.congal@smile.fr> wrote:
>
> Hi,
>
> On 4/12/23 12:19, Jan Vermaete wrote:
> > Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
> > ---
> >  meta/recipes-core/meta/cve-update-nvd2-native.bb | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/meta/recipes-core/meta/cve-update-nvd2-native.bb b/meta/recipes-core/meta/cve-update-nvd2-native.bb
> > index 1c14481c21..2b585983ac 100644
> > --- a/meta/recipes-core/meta/cve-update-nvd2-native.bb
> > +++ b/meta/recipes-core/meta/cve-update-nvd2-native.bb
> > @@ -118,6 +118,7 @@ def nvd_request_next(url, api_key, args):
> >      import urllib.request
> >      import urllib.parse
> >      import gzip
> > +    import http
>
> If this is only for the "except http.client.IncompleteRead:" line 146[1], wouldn't it be better to fix the catched exception to match what urllib can
>  throw or to remove the except block entirely?
>
> I've triggered the same error as you but chose to remove the except block to get my code running.
>
> [1]: https://git.yoctoproject.org/poky/tree/meta/recipes-core/meta/cve-update-nvd2-native.bb#n146
>
> >
> >      headers = {}
> >      if api_key:
>
> Regards,
> --
> Yoann Congal
> Smile ECS - Tech Expert
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#179946): https://lists.openembedded.org/g/openembedded-core/message/179946
> Mute This Topic: https://lists.openembedded.org/mt/98216121/2167232
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [jan.vermaete@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Yoann Congal April 12, 2023, 1:19 p.m. UTC | #3
On 4/12/23 13:45, jan vermaete wrote:
> Hi,
> 
> I have no preference on how to fix it.
> I intended to stay as close as possible to the code of Marta

Yes, I see that. I'm okay with your patch as-is since the current code is not coherent.

But, I don't see how we can get this exception from urllib... Maybe someone with more knowledge in urllib can tell us?

Regards,

> Br.
> 
> On Wed, Apr 12, 2023 at 1:36 PM Yoann Congal <yoann.congal@smile.fr> wrote:
>>
>> Hi,
>>
>> On 4/12/23 12:19, Jan Vermaete wrote:
>>> Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
>>> ---
>>>  meta/recipes-core/meta/cve-update-nvd2-native.bb | 1 +
>>>  1 file changed, 1 insertion(+)
>>>
>>> diff --git a/meta/recipes-core/meta/cve-update-nvd2-native.bb b/meta/recipes-core/meta/cve-update-nvd2-native.bb
>>> index 1c14481c21..2b585983ac 100644
>>> --- a/meta/recipes-core/meta/cve-update-nvd2-native.bb
>>> +++ b/meta/recipes-core/meta/cve-update-nvd2-native.bb
>>> @@ -118,6 +118,7 @@ def nvd_request_next(url, api_key, args):
>>>      import urllib.request
>>>      import urllib.parse
>>>      import gzip
>>> +    import http
>>
>> If this is only for the "except http.client.IncompleteRead:" line 146[1], wouldn't it be better to fix the catched exception to match what urllib can
>>  throw or to remove the except block entirely?
>>
>> I've triggered the same error as you but chose to remove the except block to get my code running.
>>
>> [1]: https://git.yoctoproject.org/poky/tree/meta/recipes-core/meta/cve-update-nvd2-native.bb#n146
>>
>>>
>>>      headers = {}
>>>      if api_key:
>>
>> Regards,
>> --
>> Yoann Congal
>> Smile ECS - Tech Expert
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#179946): https://lists.openembedded.org/g/openembedded-core/message/179946
>> Mute This Topic: https://lists.openembedded.org/mt/98216121/2167232
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [jan.vermaete@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
> 
>
Marta Rybczynska April 13, 2023, 12:35 a.m. UTC | #4
On Wed, Apr 12, 2023 at 3:19 PM Yoann Congal <yoann.congal@smile.fr> wrote:

> On 4/12/23 13:45, jan vermaete wrote:
> > Hi,
> >
> > I have no preference on how to fix it.
> > I intended to stay as close as possible to the code of Marta
>
> Yes, I see that. I'm okay with your patch as-is since the current code is
> not coherent.
>
> But, I don't see how we can get this exception from urllib... Maybe
> someone with more knowledge in urllib can tell us?
>
>
I'm OK to add the import http. If you remove the except block, you will get
errors from time to time (in my setup most of the time when you do a
complete download).

Kind regards,
Marta
diff mbox series

Patch

diff --git a/meta/recipes-core/meta/cve-update-nvd2-native.bb b/meta/recipes-core/meta/cve-update-nvd2-native.bb
index 1c14481c21..2b585983ac 100644
--- a/meta/recipes-core/meta/cve-update-nvd2-native.bb
+++ b/meta/recipes-core/meta/cve-update-nvd2-native.bb
@@ -118,6 +118,7 @@  def nvd_request_next(url, api_key, args):
     import urllib.request
     import urllib.parse
     import gzip
+    import http
 
     headers = {}
     if api_key: