diff mbox series

musl: Update to latest trunk

Message ID 20230409023933.429449-1-raj.khem@gmail.com
State Accepted, archived
Commit bb591e83e3d203d60d59a36f1ff0b2ce437dc7a2
Headers show
Series musl: Update to latest trunk | expand

Commit Message

Khem Raj April 9, 2023, 2:39 a.m. UTC
Brings these changes

* 1d5750b9 fix swprintf handling of nul character in output
* 0e523480 in printf, use ferror macro rather than directly inspecting flags bit
* 868c9643 remove wide printf dependency on ugly hack in vfprintf
* 3a051769 fix (normal, narrow) printf erroneously processing %n after output errors
* 0440ed69 fix wide printf continuation after output or encoding errors
* d055e6a4 fix wide printf forms ignoring width for %lc format specifier
* b6811019 poll: fix misuse of timespec type on 32-bit archs without poll syscall
* 8949da7a select: fix 64-bit timeout truncation on pre-time64 kernels
* 3281047c dup3: don't set FD_CLOEXEC on failure on kernels without dup3 syscall
* c99b7daa fix dup3 ignoring all flags but O_CLOEXEC on archs with SYS_dup2 syscall
* fb7fb5e4 fix pipe2 silently ignoring unknown flags on old kernels
* b1dfb734 getservbyport_r: fix wrong result if getnameinfo fails with EAI_OVERFLOW
* 595416b1 getservbyport_r: fix out-of-bounds buffer read
* 1a708ece getifaddrs: fix UB via taking address of null pointer union dereference
* c499c108 accept4: don't fall back to accept if we got unknown flags
* 523d9b96 fix potential read past end of buffer in getnameinfo host name lookup
* d0b7f976 dns: fix workaround for systems defaulting to ipv6-only sockets
* bec42ef3 dns: handle early eof in tcp fallback
* 9b132e55 prevent CNAME/PTR parsing from reading data past the response end
* 12590c8b fix out-of-bounds reads in __dns_parse
* bc695a5a fix incorrect unit for CPU_SETSIZE macro

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 39f6dd8219..531f337e82 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "7d756e1c04de6eb3f2b3d3e1141a218bb329fcfb"
+SRCREV = "1d5750b95c06913a1f18a995481276d698d20fae"
 
 BASEVER = "1.2.3"