diff mbox series

mc: set ac_cv_path_PERL_FOR_BUILD

Message ID 20230223073047.829258-1-mingli.yu@eng.windriver.com
State Accepted, archived
Commit 33d91a2434eeb20076c8226340b224b1d606c40f
Headers show
Series mc: set ac_cv_path_PERL_FOR_BUILD | expand

Commit Message

mingli.yu@eng.windriver.com Feb. 23, 2023, 7:30 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

After mc upgrade to 4.8.29, it introduces PERL_FOR_BUILD [1] and will
result in the below build failure on some system when we build under
a project with long path.
 | make[4]: Entering directory '/buildarea2/WTEST_Regression/Rerun/build_dir/02161802-multilib_pkgs_conflict/qemux86-64-standard-std-OE/build1/tmp-glibc/work/core2-64-wrs-linux/mc/4.8.29-r0/build/doc/hlp/es'
 make[4]: Nothing to be done for 'install-exec-am'.
 | ../../../src/man2hlp/man2hlp ../../../doc/man/es/mc.1 ../../../../mc-4.8.29/doc/hlp/es/xnc.hlp mc.hlp.es
 | ../../../src/man2hlp/man2hlp: line 32: use: command not found
 | ../../../src/man2hlp/man2hlp: line 33: use: command not found
 | ../../../src/man2hlp/man2hlp: line 36: syntax error near unexpected token `('
 | ../../../src/man2hlp/man2hlp: line 36: `my %static = ('
 | make[4]: [Makefile:632: mc.hlp.es] Error 2 (ignored)

 $ head -n 5 tmp-glibc/work/core2-64-wrs-linux/mc/4.8.29-r0/build/src/man2hlp/man2hlp
 #! /buildarea2/WTEST_Regression/Rerun/build_dir/02161802-multilib_pkgs_conflict/qemux86-64-standard-std-OE/build1/tmp-glibc/hosttools/perl
 #
 #  Man page to help file converter
 #  Copyright (C) 1994, 1995, 1998, 2000, 2001, 2002, 2003, 2004, 2005,
 #  2007, 2010, 2011

It's beacause the shebang line exceeds 128 which is usually the max
length.

So set ac_cv_path_PERL_FOR_BUILD to fix the above issue and altogether
to remove the build path issue.

[1] https://github.com/MidnightCommander/mc/commit/6b67d231a2f447cf5f33180c618c2a67849e6d15

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta/recipes-extended/mc/mc_4.8.29.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-extended/mc/mc_4.8.29.bb b/meta/recipes-extended/mc/mc_4.8.29.bb
index c9db172183..7aac352ab5 100644
--- a/meta/recipes-extended/mc/mc_4.8.29.bb
+++ b/meta/recipes-extended/mc/mc_4.8.29.bb
@@ -32,6 +32,7 @@  EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-
 EXTRANATIVEPATH += "file-native"
 
 CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
+CACHED_CONFIGUREVARS += "ac_cv_path_PERL_FOR_BUILD='/usr/bin/env perl'"
 CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"
 CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'"
 CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes"