diff mbox series

libcgroup: clean up musl DEPENDS

Message ID 20230214164204.2792379-1-ross.burton@arm.com
State Accepted, archived
Commit 59be1d5a7e78c6fe6bf01e523439f91871be9718
Headers show
Series libcgroup: clean up musl DEPENDS | expand

Commit Message

Ross Burton Feb. 14, 2023, 4:42 p.m. UTC
libcgroup uses fts_* functions, but these are not implemented in musl so
we depend on the fts recipe and force a link to libfts.

However since 3.0.0 libcgroup will automatically look for fts_open in
both libc and libfts[1], so this can be simplified to just a conditional
DEPENDS.

[1] https://github.com/libcgroup/libcgroup/commit/27ba904355575153308bdc0fa48344ef1be55ca1

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-core/libcgroup/libcgroup_3.0.0.bb | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Khem Raj Feb. 14, 2023, 5:58 p.m. UTC | #1
On Tue, Feb 14, 2023 at 8:42 AM Ross Burton <ross.burton@arm.com> wrote:
>
> libcgroup uses fts_* functions, but these are not implemented in musl so
> we depend on the fts recipe and force a link to libfts.
>
> However since 3.0.0 libcgroup will automatically look for fts_open in
> both libc and libfts[1], so this can be simplified to just a conditional
> DEPENDS.
>
> [1] https://github.com/libcgroup/libcgroup/commit/27ba904355575153308bdc0fa48344ef1be55ca1
>

cool. LGTM

> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-core/libcgroup/libcgroup_3.0.0.bb | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb b/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
> index 9937a17fb51..457b965481d 100644
> --- a/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
> +++ b/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
> @@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4d794c5d710e5b3547a6cc6a6609a641"
>  inherit autotools pkgconfig github-releases
>
>  DEPENDS = "bison-native flex-native"
> +DEPENDS:append:libc-musl = " fts"
>
>  SRC_URI = "${GITHUB_BASE_URI}/download/v3.0/${BP}.tar.gz \
>             file://0001-api-Use-GNU-strerror_r-when-available.patch \
> @@ -18,9 +19,6 @@ UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/tags"
>
>  SRC_URI[sha256sum] = "8d284d896fca1c981b55850e92acd3ad9648a69227c028dda7ae3402af878edd"
>
> -DEPENDS:append:libc-musl = " fts "
> -EXTRA_OEMAKE:append:libc-musl = " LIBS=-lfts"
> -
>  PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
>  PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177157): https://lists.openembedded.org/g/openembedded-core/message/177157
> Mute This Topic: https://lists.openembedded.org/mt/96963828/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb b/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
index 9937a17fb51..457b965481d 100644
--- a/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
+++ b/meta/recipes-core/libcgroup/libcgroup_3.0.0.bb
@@ -10,6 +10,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=4d794c5d710e5b3547a6cc6a6609a641"
 inherit autotools pkgconfig github-releases
 
 DEPENDS = "bison-native flex-native"
+DEPENDS:append:libc-musl = " fts"
 
 SRC_URI = "${GITHUB_BASE_URI}/download/v3.0/${BP}.tar.gz \
            file://0001-api-Use-GNU-strerror_r-when-available.patch \
@@ -18,9 +19,6 @@  UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/tags"
 
 SRC_URI[sha256sum] = "8d284d896fca1c981b55850e92acd3ad9648a69227c028dda7ae3402af878edd"
 
-DEPENDS:append:libc-musl = " fts "
-EXTRA_OEMAKE:append:libc-musl = " LIBS=-lfts"
-
 PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
 PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"