diff mbox series

[PATCH-kirkstone/langdale] python3-pytest: depend on python3-tomli instead of python3-toml

Message ID 20230202124953.3402225-1-arnout@mind.be
State New, archived
Headers show
Series [PATCH-kirkstone/langdale] python3-pytest: depend on python3-tomli instead of python3-toml | expand

Commit Message

Arnout Vandecappelle Feb. 2, 2023, 12:49 p.m. UTC
Since version 7.0.0 [1], pytest switched from the toml package to the
tomli package for parsing pyproject.toml configuration files [2].

This change is not immediately noticable during tests, because the
toml/tomli module is only important if a pyproject.toml is actually
present in a project.

[1] https://docs.pytest.org/en/latest/changelog.html#pytest-7-0-0rc1-2021-12-06
[2] https://github.com/pytest-dev/pytest/issues/8789

Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
---
This patch only applies to kirkstone and langdale branches. On master,
Python 3.11 is used which no longer needs tomli at all. On dunfell,
pytest is still on 5.3.5.
---
 meta/recipes-devtools/python/python3-pytest_7.1.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pytest_7.1.1.bb b/meta/recipes-devtools/python/python3-pytest_7.1.1.bb
index 1cb2fb01c0..90a4787c17 100644
--- a/meta/recipes-devtools/python/python3-pytest_7.1.1.bb
+++ b/meta/recipes-devtools/python/python3-pytest_7.1.1.bb
@@ -26,7 +26,7 @@  RDEPENDS:${PN}:class-target += " \
     ${PYTHON_PN}-py \
     ${PYTHON_PN}-setuptools \
     ${PYTHON_PN}-six \
-    ${PYTHON_PN}-toml \
+    ${PYTHON_PN}-tomli \
     ${PYTHON_PN}-wcwidth \
 "