diff mbox series

[2/3] libtirpc: Check if file exists before operating on it

Message ID 20230119231817.1187300-2-raj.khem@gmail.com
State Accepted, archived
Commit 547f3a13ee9268bbdd439c96108ba1fe9ab78873
Headers show
Series [1/3] lttng-tools: Switch to alternative upstream submitted patch | expand

Commit Message

Khem Raj Jan. 19, 2023, 11:18 p.m. UTC
In some cases (e.g. mingw) this file may not be installed

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb b/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb
index 8c6c20733c..f55e0b0ed1 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb
@@ -22,7 +22,7 @@  inherit autotools pkgconfig
 EXTRA_OECONF = "--disable-gssapi"
 
 do_install:append() {
-	chown root:root ${D}${sysconfdir}/netconfig
+	test -e ${D}${sysconfdir}/netconfig && chown root:root ${D}${sysconfdir}/netconfig
 }
 
 BBCLASSEXTEND = "native nativesdk"