diff mbox series

[2/2] rpm: do not export MAGIC in SDK

Message ID 20230117040631.34966-2-Qi.Chen@windriver.com
State Accepted, archived
Commit 6e2147ab1d0f3aad2dfe8180a3896c9c9bcfdac8
Headers show
Series [1/2] file: export MAGIC in SDK | expand

Commit Message

ChenQi Jan. 17, 2023, 4:06 a.m. UTC
This MAGIC variable is used by libmagic (file), and should
be exported by the file recipe.

As the rpm recipe has 'file' in its DEPENDS, its sub-packages
which links to libmagic will be automatically added the 'file'
runtime dependency. More specifically, it's the rpm-build package.
So in case components in nativesdk-rpm-build package uses libmagic,
the nativesdk-file package will be installed and the MAGIC var
will be exported.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta/recipes-devtools/rpm/rpm_4.18.0.bb | 1 -
 1 file changed, 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rpm/rpm_4.18.0.bb b/meta/recipes-devtools/rpm/rpm_4.18.0.bb
index 8eb0ab207e..61e395a9d0 100644
--- a/meta/recipes-devtools/rpm/rpm_4.18.0.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.18.0.bb
@@ -123,7 +123,6 @@  do_install:append:class-nativesdk() {
 	cat <<- EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
 		export RPM_CONFIGDIR="$OECORE_NATIVE_SYSROOT${libdir}/rpm"
 		export RPM_ETCCONFIGDIR="$OECORE_NATIVE_SYSROOT${sysconfdir}"
-		export MAGIC="$OECORE_NATIVE_SYSROOT${datadir}/misc/magic.mgc"
 		export RPM_NO_CHROOT_FOR_SCRIPTS=1
 	EOF
 }