diff mbox series

libportal: add opengl to REQUIRED_DISTRO_FEATURES

Message ID 20230106100806.838732-1-mingli.yu@eng.windriver.com
State New
Headers show
Series libportal: add opengl to REQUIRED_DISTRO_FEATURES | expand

Commit Message

mingli.yu@eng.windriver.com Jan. 6, 2023, 10:08 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

libportal depends on gtk4 which needs opengl DISTRO_FEATURES, so
add opengl DISTRO_FEATURES requirement for libportal too.

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta/recipes-gnome/libportal/libportal_0.6.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Alexander Kanavin Jan. 6, 2023, 10:31 a.m. UTC | #1
Please stop. What problem does adding this solve?

Alex

On Fri 6. Jan 2023 at 11.08, Yu, Mingli <mingli.yu@eng.windriver.com> wrote:

> From: Mingli Yu <mingli.yu@windriver.com>
>
> libportal depends on gtk4 which needs opengl DISTRO_FEATURES, so
> add opengl DISTRO_FEATURES requirement for libportal too.
>
> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> ---
>  meta/recipes-gnome/libportal/libportal_0.6.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta/recipes-gnome/libportal/libportal_0.6.bb
> b/meta/recipes-gnome/libportal/libportal_0.6.bb
> index ca58ef4138..cb3c5631d9 100644
> --- a/meta/recipes-gnome/libportal/libportal_0.6.bb
> +++ b/meta/recipes-gnome/libportal/libportal_0.6.bb
> @@ -14,6 +14,7 @@ inherit meson gi-docgen gobject-introspection vala
> features_check pkgconfig
>  GIDOCGEN_MESON_OPTION = 'docs'
>
>  ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
> +REQUIRED_DISTRO_FEATURES = "opengl"
>
>  DEPENDS += "glib-2.0 glib-2.0-native gtk+3 gtk4"
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175568):
> https://lists.openembedded.org/g/openembedded-core/message/175568
> Mute This Topic: https://lists.openembedded.org/mt/96090762/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Markus Volk Jan. 6, 2023, 2:09 p.m. UTC | #2
Maybe the REQUIRED_DISTRO_FEATURES = "opengl" line should just be 
removed from gtk4.bb ?

Am Fr, 6. Jan 2023 um 11:31:30 +0100 schrieb Alexander Kanavin 
<alex.kanavin@gmail.com>:
> Please stop. What problem does adding this solve?
> 
> Alex
> 
> On Fri 6. Jan 2023 at 11.08, Yu, Mingli <mingli.yu@eng.windriver.com 
> <mailto:mingli.yu@eng.windriver.com>> wrote:
>> From: Mingli Yu <mingli.yu@windriver.com 
>> <mailto:mingli.yu@windriver.com>>
>> 
>>  libportal depends on gtk4 which needs opengl DISTRO_FEATURES, so
>>  add opengl DISTRO_FEATURES requirement for libportal too.
>> 
>>  Signed-off-by: Mingli Yu <mingli.yu@windriver.com 
>> <mailto:mingli.yu@windriver.com>>
>>  ---
>>   meta/recipes-gnome/libportal/libportal_0.6.bb 
>> <http://libportal_0.6.bb/> | 1 +
>>   1 file changed, 1 insertion(+)
>> 
>>  diff --git a/meta/recipes-gnome/libportal/libportal_0.6.bb 
>> <http://libportal_0.6.bb/> 
>> b/meta/recipes-gnome/libportal/libportal_0.6.bb 
>> <http://libportal_0.6.bb/>
>>  index ca58ef4138..cb3c5631d9 100644
>>  --- a/meta/recipes-gnome/libportal/libportal_0.6.bb 
>> <http://libportal_0.6.bb/>
>>  +++ b/meta/recipes-gnome/libportal/libportal_0.6.bb 
>> <http://libportal_0.6.bb/>
>>  @@ -14,6 +14,7 @@ inherit meson gi-docgen gobject-introspection 
>> vala features_check pkgconfig
>>   GIDOCGEN_MESON_OPTION = 'docs'
>> 
>>   ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
>>  +REQUIRED_DISTRO_FEATURES = "opengl"
>> 
>>   DEPENDS += "glib-2.0 glib-2.0-native gtk+3 gtk4"
>> 
>>  --
>>  2.25.1
>> 
>> 
>> 
>>
Alexander Kanavin Jan. 6, 2023, 4:24 p.m. UTC | #3
Only if you can configure it in a way that doesn’t pull in Mesa, and I
don’t think it’s possible.

Alex

On Fri 6. Jan 2023 at 15.09, Markus Volk <f_l_k@t-online.de> wrote:

> Maybe the REQUIRED_DISTRO_FEATURES = "opengl" line should just be removed
> from gtk4.bb ?
>
> Am Fr, 6. Jan 2023 um 11:31:30 +0100 schrieb Alexander Kanavin <
> alex.kanavin@gmail.com>:
>
> Please stop. What problem does adding this solve?
>
> Alex
>
> On Fri 6. Jan 2023 at 11.08, Yu, Mingli <mingli.yu@eng.windriver.com>
> wrote:
>
>> From: Mingli Yu <mingli.yu@windriver.com>
>>
>> libportal depends on gtk4 which needs opengl DISTRO_FEATURES, so
>> add opengl DISTRO_FEATURES requirement for libportal too.
>>
>> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
>> ---
>>  meta/recipes-gnome/libportal/libportal_0.6.bb | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/meta/recipes-gnome/libportal/libportal_0.6.bb
>> b/meta/recipes-gnome/libportal/libportal_0.6.bb
>> index ca58ef4138..cb3c5631d9 100644
>> --- a/meta/recipes-gnome/libportal/libportal_0.6.bb
>> +++ b/meta/recipes-gnome/libportal/libportal_0.6.bb
>> @@ -14,6 +14,7 @@ inherit meson gi-docgen gobject-introspection vala
>> features_check pkgconfig
>>  GIDOCGEN_MESON_OPTION = 'docs'
>>
>>  ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
>> +REQUIRED_DISTRO_FEATURES = "opengl"
>>
>>  DEPENDS += "glib-2.0 glib-2.0-native gtk+3 gtk4"
>>
>> --
>> 2.25.1
>>
>>
>>
>>
>>
Yu, Mingli Jan. 9, 2023, 9:02 a.m. UTC | #4
On 1/6/23 18:31, Alexander Kanavin wrote:
> **
> *CAUTION: This email comes from a non Wind River email account!*
> Do not click links or open attachments unless you recognize the sender 
> and know the content is safe.
> Please stop. What problem does adding this solve?

Sorry for noise!

Originally, the patch is used to fix the yocto compliance issue. The 
libportal depends on gtk4 and there is a line "REQUIRED_DISTRO_FEATURES 
= "opengl"" as [1] in gtk4_4.8.2.bb. If not make opengl mandatory for 
libportal, how to solve the below yocto compliance issue?  Any hints?


ERROR: Nothing PROVIDES 'gtk4' (but 
/build/layers/oe-core/meta/recipes-gnome/libportal/libportal_0.6.bb 
DEPENDS on or otherwise requires it)
gtk4 was skipped: missing required distro feature 'opengl' (not in 
DISTRO_FEATURES)
ERROR: Required build target 'meta-world-pkgdata' has no buildable 
providers.
Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 
'libportal', 'gtk4']


[1] 
https://git.openembedded.org/openembedded-core/tree/meta/recipes-gnome/gtk+/gtk4_4.8.2.bb#n55

Thanks,

> 
> Alex
> 
> On Fri 6. Jan 2023 at 11.08, Yu, Mingli <mingli.yu@eng.windriver.com 
> <mailto:mingli.yu@eng.windriver.com>> wrote:
> 
>     From: Mingli Yu <mingli.yu@windriver.com
>     <mailto:mingli.yu@windriver.com>>
> 
>     libportal depends on gtk4 which needs opengl DISTRO_FEATURES, so
>     add opengl DISTRO_FEATURES requirement for libportal too.
> 
>     Signed-off-by: Mingli Yu <mingli.yu@windriver.com
>     <mailto:mingli.yu@windriver.com>>
>     ---
>       meta/recipes-gnome/libportal/libportal_0.6.bb
>     <https://urldefense.com/v3/__http://libportal_0.6.bb__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnPQeCyHk$>
>     | 1 +
>       1 file changed, 1 insertion(+)
> 
>     diff --git a/meta/recipes-gnome/libportal/libportal_0.6.bb
>     <https://urldefense.com/v3/__http://libportal_0.6.bb__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnPQeCyHk$>
>     b/meta/recipes-gnome/libportal/libportal_0.6.bb
>     <https://urldefense.com/v3/__http://libportal_0.6.bb__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnPQeCyHk$>
>     index ca58ef4138..cb3c5631d9 100644
>     --- a/meta/recipes-gnome/libportal/libportal_0.6.bb
>     <https://urldefense.com/v3/__http://libportal_0.6.bb__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnPQeCyHk$>
>     +++ b/meta/recipes-gnome/libportal/libportal_0.6.bb
>     <https://urldefense.com/v3/__http://libportal_0.6.bb__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnPQeCyHk$>
>     @@ -14,6 +14,7 @@ inherit meson gi-docgen gobject-introspection vala
>     features_check pkgconfig
>       GIDOCGEN_MESON_OPTION = 'docs'
> 
>       ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
>     +REQUIRED_DISTRO_FEATURES = "opengl"
> 
>       DEPENDS += "glib-2.0 glib-2.0-native gtk+3 gtk4"
> 
>     -- 
>     2.25.1
> 
> 
>     -=-=-=-=-=-=-=-=-=-=-=-
>     Links: You receive all messages sent to this group.
>     View/Reply Online (#175568):
>     https://lists.openembedded.org/g/openembedded-core/message/175568
>     <https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/message/175568__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnKVvR6Xd$>
>     Mute This Topic: https://lists.openembedded.org/mt/96090762/1686489
>     <https://urldefense.com/v3/__https://lists.openembedded.org/mt/96090762/1686489__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnIi_Br3T$>
>     Group Owner: openembedded-core+owner@lists.openembedded.org
>     <mailto:openembedded-core%2Bowner@lists.openembedded.org>
>     Unsubscribe:
>     https://lists.openembedded.org/g/openembedded-core/unsub
>     <https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/unsub__;!!AjveYdw8EvQ!adBoiCcCJiSyEFxuSwv8UUtX2iXZn-b1eKQaopCuZ9qdhjna0B1gOcC8yDxUpHJNiEyo7h-j03gjmDPWlNRZnOpuie-v$>
>     [alex.kanavin@gmail.com <mailto:alex.kanavin@gmail.com>]
>     -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Jan. 9, 2023, 9:10 a.m. UTC | #5
On Mon, 9 Jan 2023 at 10:02, Yu, Mingli <mingli.yu@windriver.com> wrote:
> Sorry for noise!
>
> Originally, the patch is used to fix the yocto compliance issue. The
> libportal depends on gtk4 and there is a line "REQUIRED_DISTRO_FEATURES
> = "opengl"" as [1] in gtk4_4.8.2.bb. If not make opengl mandatory for
> libportal, how to solve the below yocto compliance issue?  Any hints?
>
>
> ERROR: Nothing PROVIDES 'gtk4' (but
> /build/layers/oe-core/meta/recipes-gnome/libportal/libportal_0.6.bb
> DEPENDS on or otherwise requires it)
> gtk4 was skipped: missing required distro feature 'opengl' (not in
> DISTRO_FEATURES)
> ERROR: Required build target 'meta-world-pkgdata' has no buildable
> providers.
> Missing or unbuildable dependency chain was: ['meta-world-pkgdata',
> 'libportal', 'gtk4']
>
>
> [1]
> https://git.openembedded.org/openembedded-core/tree/meta/recipes-gnome/gtk+/gtk4_4.8.2.bb#n55

Thanks for clarifying. Meanwhile there was a discussion in a different
thread about this, so the patch is fine.

Alex
Yu, Mingli Jan. 30, 2023, 9:30 a.m. UTC | #6
Ping.

Thanks,

On 1/9/23 17:10, Alexander Kanavin wrote:
> CAUTION: This email comes from a non Wind River email account!
> Do not click links or open attachments unless you recognize the sender and know the content is safe.
> 
> On Mon, 9 Jan 2023 at 10:02, Yu, Mingli <mingli.yu@windriver.com> wrote:
>> Sorry for noise!
>>
>> Originally, the patch is used to fix the yocto compliance issue. The
>> libportal depends on gtk4 and there is a line "REQUIRED_DISTRO_FEATURES
>> = "opengl"" as [1] in gtk4_4.8.2.bb. If not make opengl mandatory for
>> libportal, how to solve the below yocto compliance issue?  Any hints?
>>
>>
>> ERROR: Nothing PROVIDES 'gtk4' (but
>> /build/layers/oe-core/meta/recipes-gnome/libportal/libportal_0.6.bb
>> DEPENDS on or otherwise requires it)
>> gtk4 was skipped: missing required distro feature 'opengl' (not in
>> DISTRO_FEATURES)
>> ERROR: Required build target 'meta-world-pkgdata' has no buildable
>> providers.
>> Missing or unbuildable dependency chain was: ['meta-world-pkgdata',
>> 'libportal', 'gtk4']
>>
>>
>> [1]
>> https://git.openembedded.org/openembedded-core/tree/meta/recipes-gnome/gtk+/gtk4_4.8.2.bb#n55
> 
> Thanks for clarifying. Meanwhile there was a discussion in a different
> thread about this, so the patch is fine.
> 
> Alex
Yu, Mingli Feb. 20, 2023, 8:36 a.m. UTC | #7
Ping.

Thanks,

On 1/9/23 17:10, Alexander Kanavin wrote:
> CAUTION: This email comes from a non Wind River email account!
> Do not click links or open attachments unless you recognize the sender and know the content is safe.
> 
> On Mon, 9 Jan 2023 at 10:02, Yu, Mingli <mingli.yu@windriver.com> wrote:
>> Sorry for noise!
>>
>> Originally, the patch is used to fix the yocto compliance issue. The
>> libportal depends on gtk4 and there is a line "REQUIRED_DISTRO_FEATURES
>> = "opengl"" as [1] in gtk4_4.8.2.bb. If not make opengl mandatory for
>> libportal, how to solve the below yocto compliance issue?  Any hints?
>>
>>
>> ERROR: Nothing PROVIDES 'gtk4' (but
>> /build/layers/oe-core/meta/recipes-gnome/libportal/libportal_0.6.bb
>> DEPENDS on or otherwise requires it)
>> gtk4 was skipped: missing required distro feature 'opengl' (not in
>> DISTRO_FEATURES)
>> ERROR: Required build target 'meta-world-pkgdata' has no buildable
>> providers.
>> Missing or unbuildable dependency chain was: ['meta-world-pkgdata',
>> 'libportal', 'gtk4']
>>
>>
>> [1]
>> https://git.openembedded.org/openembedded-core/tree/meta/recipes-gnome/gtk+/gtk4_4.8.2.bb#n55
> 
> Thanks for clarifying. Meanwhile there was a discussion in a different
> thread about this, so the patch is fine.
> 
> Alex
Markus Volk Feb. 20, 2023, 1:18 p.m. UTC | #8
I guess this commit will fix the issue for libportal, because we would 
then be able to remove the gtk+3 and gtk4 dependency as both are now 
optional.

<https://github.com/flatpak/libportal/commit/333a299a3c7580de3a8fbbe882ab28f5666338bd>

Am Mo, 20. Feb 2023 um 16:36:53 +0800 schrieb "Yu, Mingli" 
<mingli.yu@eng.windriver.com>:
> Ping.
> 
> Thanks,
> 
> On 1/9/23 17:10, Alexander Kanavin wrote:
>> CAUTION: This email comes from a non Wind River email account!
>> Do not click links or open attachments unless you recognize the 
>> sender and know the content is safe.
>> 
>> On Mon, 9 Jan 2023 at 10:02, Yu, Mingli <mingli.yu@windriver.com 
>> <mailto:mingli.yu@windriver.com>> wrote:
>>> Sorry for noise!
>>> 
>>> Originally, the patch is used to fix the yocto compliance issue. The
>>> libportal depends on gtk4 and there is a line 
>>> "REQUIRED_DISTRO_FEATURES
>>> = "opengl"" as [1] in gtk4_4.8.2.bb. If not make opengl mandatory 
>>> for
>>> libportal, how to solve the below yocto compliance issue?  Any 
>>> hints?
>>> 
>>> 
>>> ERROR: Nothing PROVIDES 'gtk4' (but
>>> /build/layers/oe-core/meta/recipes-gnome/libportal/libportal_0.6.bb
>>> DEPENDS on or otherwise requires it)
>>> gtk4 was skipped: missing required distro feature 'opengl' (not in
>>> DISTRO_FEATURES)
>>> ERROR: Required build target 'meta-world-pkgdata' has no buildable
>>> providers.
>>> Missing or unbuildable dependency chain was: ['meta-world-pkgdata',
>>> 'libportal', 'gtk4']
>>> 
>>> 
>>> [1]
>>> <https://git.openembedded.org/openembedded-core/tree/meta/recipes-gnome/gtk+/gtk4_4.8.2.bb#n55>
>> 
>> Thanks for clarifying. Meanwhile there was a discussion in a 
>> different
>> thread about this, so the patch is fine.
>> 
>> Alex
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177396): 
> <https://lists.openembedded.org/g/openembedded-core/message/177396>
> Mute This Topic: <https://lists.openembedded.org/mt/96090762/3618223>
> Group Owner: openembedded-core+owner@lists.openembedded.org 
> <mailto:openembedded-core+owner@lists.openembedded.org>
> Unsubscribe: 
> <https://lists.openembedded.org/g/openembedded-core/unsub> 
> [f_l_k@t-online.de <mailto:f_l_k@t-online.de>]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk Feb. 20, 2023, 1:45 p.m. UTC | #9
Since this needs to be reworked for the next libportal version anyway, 
maybe we could do it just like that for now?

diff --git a/meta/recipes-gnome/libportal/libportal_0.6.bb 
b/meta/recipes-gnome/libportal/libportal_0.6.bb
index ca58ef4138..bf38fc85fd 100644
--- a/meta/recipes-gnome/libportal/libportal_0.6.bb
+++ b/meta/recipes-gnome/libportal/libportal_0.6.bb
@@ -15,6 +15,6 @@ GIDOCGEN_MESON_OPTION = 'docs'

 ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"

-DEPENDS += "glib-2.0 glib-2.0-native gtk+3 gtk4"
+DEPENDS += "glib-2.0 glib-2.0-native gtk+3 
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gtk4', '', d)}"

-EXTRA_OEMESON = "-Dbackends=gtk3,gtk4"
+EXTRA_OEMESON = 
"-Dbackends=gtk3${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 
',gtk4', '', d)}"


Am Mo, 20. Feb 2023 um 14:18:13 +0100 schrieb Markus Volk 
<f_l_k@t-online.de>:
> I guess this commit will fix the issue for libportal, because we 
> would then be able to remove the gtk+3 and gtk4 dependency as both 
> are now optional.
> 
> <https://github.com/flatpak/libportal/commit/333a299a3c7580de3a8fbbe882ab28f5666338bd>
> 
> Am Mo, 20. Feb 2023 um 16:36:53 +0800 schrieb "Yu, Mingli" 
> <mingli.yu@eng.windriver.com>:
>> Ping.
>> 
>> Thanks,
>> 
>> On 1/9/23 17:10, Alexander Kanavin wrote:
>>> CAUTION: This email comes from a non Wind River email account!
>>> Do not click links or open attachments unless you recognize the 
>>> sender and know the content is safe.
>>> 
>>> On Mon, 9 Jan 2023 at 10:02, Yu, Mingli <mingli.yu@windriver.com 
>>> <mailto:mingli.yu@windriver.com>> wrote:
>>>> Sorry for noise!
>>>> 
>>>> Originally, the patch is used to fix the yocto compliance issue. 
>>>> The
>>>> libportal depends on gtk4 and there is a line 
>>>> "REQUIRED_DISTRO_FEATURES
>>>> = "opengl"" as [1] in gtk4_4.8.2.bb. If not make opengl mandatory 
>>>> for
>>>> libportal, how to solve the below yocto compliance issue?  Any 
>>>> hints?
>>>> 
>>>> 
>>>> ERROR: Nothing PROVIDES 'gtk4' (but
>>>> /build/layers/oe-core/meta/recipes-gnome/libportal/libportal_0.6.bb
>>>> DEPENDS on or otherwise requires it)
>>>> gtk4 was skipped: missing required distro feature 'opengl' (not in
>>>> DISTRO_FEATURES)
>>>> ERROR: Required build target 'meta-world-pkgdata' has no buildable
>>>> providers.
>>>> Missing or unbuildable dependency chain was: ['meta-world-pkgdata',
>>>> 'libportal', 'gtk4']
>>>> 
>>>> 
>>>> [1]
>>>> <https://git.openembedded.org/openembedded-core/tree/meta/recipes-gnome/gtk+/gtk4_4.8.2.bb#n55>
>>> 
>>> Thanks for clarifying. Meanwhile there was a discussion in a 
>>> different
>>> thread about this, so the patch is fine.
>>> 
>>> Alex
>> 
>> 
>>
diff mbox series

Patch

diff --git a/meta/recipes-gnome/libportal/libportal_0.6.bb b/meta/recipes-gnome/libportal/libportal_0.6.bb
index ca58ef4138..cb3c5631d9 100644
--- a/meta/recipes-gnome/libportal/libportal_0.6.bb
+++ b/meta/recipes-gnome/libportal/libportal_0.6.bb
@@ -14,6 +14,7 @@  inherit meson gi-docgen gobject-introspection vala features_check pkgconfig
 GIDOCGEN_MESON_OPTION = 'docs'
 
 ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 DEPENDS += "glib-2.0 glib-2.0-native gtk+3 gtk4"