diff mbox series

cargo: Do not use open64 on musl anymore

Message ID 20221229190918.2242791-1-raj.khem@gmail.com
State Accepted, archived
Commit 44441c727a5301ab99ab8b4d8b8b1f61f0a810af
Headers show
Series cargo: Do not use open64 on musl anymore | expand

Commit Message

Khem Raj Dec. 29, 2022, 7:09 p.m. UTC
The same rust getrandom patch is needed for cargo on target as well
as it uses the same crate

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/rust/cargo_1.66.0.bb                   | 5 ++++-
 .../rust/{rust => files}/getrandom-open64.patch              | 0
 2 files changed, 4 insertions(+), 1 deletion(-)
 rename meta/recipes-devtools/rust/{rust => files}/getrandom-open64.patch (100%)

Comments

Alex Kiernan Dec. 29, 2022, 7:11 p.m. UTC | #1
Should we just move these patches to rust-source and apply them for
everyone who consumes it?

On Thu, 29 Dec 2022, 19:09 Khem Raj, <raj.khem@gmail.com> wrote:

> The same rust getrandom patch is needed for cargo on target as well
> as it uses the same crate
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-devtools/rust/cargo_1.66.0.bb                   | 5 ++++-
>  .../rust/{rust => files}/getrandom-open64.patch              | 0
>  2 files changed, 4 insertions(+), 1 deletion(-)
>  rename meta/recipes-devtools/rust/{rust => files}/getrandom-open64.patch
> (100%)
>
> diff --git a/meta/recipes-devtools/rust/cargo_1.66.0.bb
> b/meta/recipes-devtools/rust/cargo_1.66.0.bb
> index 37e0123ee3..f45f8f1e12 100644
> --- a/meta/recipes-devtools/rust/cargo_1.66.0.bb
> +++ b/meta/recipes-devtools/rust/cargo_1.66.0.bb
> @@ -14,7 +14,10 @@ LIC_FILES_CHKSUM = " \
>  require rust-source.inc
>  require rust-snapshot.inc
>
> -SRC_URI:append:class-target = "
> file://crossbeam_atomic.patch;patchdir=${RUSTSRC}"
> +SRC_URI:append:class-target = "\
> +    file://crossbeam_atomic.patch;patchdir=${RUSTSRC} \
> +    file://getrandom-open64.patch;patchdir=${RUSTSRC} \
>
> +"
>
>  # Used by crossbeam_atomic.patch
>  export TARGET_VENDOR
> diff --git a/meta/recipes-devtools/rust/rust/getrandom-open64.patch
> b/meta/recipes-devtools/rust/files/getrandom-open64.patch
> similarity index 100%
> rename from meta/recipes-devtools/rust/rust/getrandom-open64.patch
> rename to meta/recipes-devtools/rust/files/getrandom-open64.patch
> --
> 2.39.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175126):
> https://lists.openembedded.org/g/openembedded-core/message/175126
> Mute This Topic: https://lists.openembedded.org/mt/95942095/3618097
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kiernan@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Dec. 29, 2022, 7:21 p.m. UTC | #2
On Thu, Dec 29, 2022 at 11:11 AM Alex Kiernan <alex.kiernan@gmail.com> wrote:
>
> Should we just move these patches to rust-source and apply them for everyone who consumes it?

A common source will certainly be better however, we do not use shared
workspace for rust recipes
so it does not matter as much.

>
> On Thu, 29 Dec 2022, 19:09 Khem Raj, <raj.khem@gmail.com> wrote:
>>
>> The same rust getrandom patch is needed for cargo on target as well
>> as it uses the same crate
>>
>> Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> ---
>>  meta/recipes-devtools/rust/cargo_1.66.0.bb                   | 5 ++++-
>>  .../rust/{rust => files}/getrandom-open64.patch              | 0
>>  2 files changed, 4 insertions(+), 1 deletion(-)
>>  rename meta/recipes-devtools/rust/{rust => files}/getrandom-open64.patch (100%)
>>
>> diff --git a/meta/recipes-devtools/rust/cargo_1.66.0.bb b/meta/recipes-devtools/rust/cargo_1.66.0.bb
>> index 37e0123ee3..f45f8f1e12 100644
>> --- a/meta/recipes-devtools/rust/cargo_1.66.0.bb
>> +++ b/meta/recipes-devtools/rust/cargo_1.66.0.bb
>> @@ -14,7 +14,10 @@ LIC_FILES_CHKSUM = " \
>>  require rust-source.inc
>>  require rust-snapshot.inc
>>
>> -SRC_URI:append:class-target = " file://crossbeam_atomic.patch;patchdir=${RUSTSRC}"
>> +SRC_URI:append:class-target = "\
>> +    file://crossbeam_atomic.patch;patchdir=${RUSTSRC} \
>> +    file://getrandom-open64.patch;patchdir=${RUSTSRC} \
>> +"
>>
>>  # Used by crossbeam_atomic.patch
>>  export TARGET_VENDOR
>> diff --git a/meta/recipes-devtools/rust/rust/getrandom-open64.patch b/meta/recipes-devtools/rust/files/getrandom-open64.patch
>> similarity index 100%
>> rename from meta/recipes-devtools/rust/rust/getrandom-open64.patch
>> rename to meta/recipes-devtools/rust/files/getrandom-open64.patch
>> --
>> 2.39.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#175126): https://lists.openembedded.org/g/openembedded-core/message/175126
>> Mute This Topic: https://lists.openembedded.org/mt/95942095/3618097
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kiernan@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Richard Purdie Dec. 29, 2022, 11:11 p.m. UTC | #3
On Thu, 2022-12-29 at 11:21 -0800, Khem Raj wrote:
> On Thu, Dec 29, 2022 at 11:11 AM Alex Kiernan <alex.kiernan@gmail.com> wrote:
> > 
> > Should we just move these patches to rust-source and apply them for everyone who consumes it?
> 
> A common source will certainly be better however, we do not use shared
> workspace for rust recipes
> so it does not matter as much.

I think this may be why cargo was failing in my test build. There were
some other issues there too.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rust/cargo_1.66.0.bb b/meta/recipes-devtools/rust/cargo_1.66.0.bb
index 37e0123ee3..f45f8f1e12 100644
--- a/meta/recipes-devtools/rust/cargo_1.66.0.bb
+++ b/meta/recipes-devtools/rust/cargo_1.66.0.bb
@@ -14,7 +14,10 @@  LIC_FILES_CHKSUM = " \
 require rust-source.inc
 require rust-snapshot.inc
 
-SRC_URI:append:class-target = " file://crossbeam_atomic.patch;patchdir=${RUSTSRC}"
+SRC_URI:append:class-target = "\
+    file://crossbeam_atomic.patch;patchdir=${RUSTSRC} \
+    file://getrandom-open64.patch;patchdir=${RUSTSRC} \                          
+"
 
 # Used by crossbeam_atomic.patch
 export TARGET_VENDOR
diff --git a/meta/recipes-devtools/rust/rust/getrandom-open64.patch b/meta/recipes-devtools/rust/files/getrandom-open64.patch
similarity index 100%
rename from meta/recipes-devtools/rust/rust/getrandom-open64.patch
rename to meta/recipes-devtools/rust/files/getrandom-open64.patch